[PATCH] gnu: Add emacs-standard-dirs.

  • Done
  • quality assurance status badge
Details
3 participants
  • LaFreniere, Joseph
  • Ludovic Courtès
  • Nicolas Goaziou
Owner
unassigned
Submitted by
LaFreniere, Joseph
Severity
normal
L
L
LaFreniere, Joseph wrote on 26 Jul 2020 18:13
(address . guix-patches@gnu.org)
87lfj6s18t.fsf@odyssey.lafreniere.xyz
Patch file is attached. Disclaimer that I am the author of the
upstream package.

Even though Guix does not (to the best of my knowledge) currently
support macOS, I left the paragraph about behavior in macOS in the
description because cross-platform support for users of multiple
operating systems was one of my primary motivations for writing
the package.

--
Joseph LaFreniere
From 2e0716d7ed9b35b780cbefda29bb9982079461ed Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 26 Jul 2020 11:06:19 -0500
Subject: [PATCH] gnu: Add emacs-standard-dirs.

* gnu/packages/emacs-xyz.scm (emacs-standard-dirs): New variable.
---
gnu/packages/emacs-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index db395361b9..d9529a2182 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3570,6 +3570,39 @@ particular, the minor mode works quite well with Org or Markdown modes, or
other markup language major modes.")
(license license:gpl3+))))
+(define-public emacs-standard-dirs
+ (package
+ (name "emacs-standard-dirs")
+ (version "2.0.0")
+ (home-page "https://github.com/lafrenierejm/standard-dirs.el")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r814qcrhvx4qlx4sdzwdmrhiryslqclx0bnpp0qcrbx6g8qfl25"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)))
+ (synopsis "Platform-specific paths for config, cache, and other data")
+ (description
+ "This package provides platform-specific paths for reading and writing
+configuration, cache, and other data.
+
+On Linux (@code{gnu/linux}), the directory paths conform to the
+@uref{https://specifications.freedesktop.org/basedir-spec/basedir-spec-0.6.html,
+XDG Base Directory Specification} where relevant, with fallbacks to
+@code{xdg-user-dirs}.
+
+On macOS (@code{darwin}), the directory paths conform to Apple's
+@uref{https://developer.apple.com/library/archive/documentation/FileManagement/Conceptual/FileSystemProgrammingGuide/FileSystemOverview/FileSystemOverview.html#//apple_ref/doc/uid/TP40010672-CH2-SW14,
+macOS File System Programming Guide}.")
+ (license license:gpl3+)))
+
(define-public emacs-string-inflection
(package
(name "emacs-string-inflection")
--
2.27.0
N
N
Nicolas Goaziou wrote on 28 Jul 2020 12:37
(name . LaFreniere, Joseph)(address . joseph@lafreniere.xyz)(address . 42549@debbugs.gnu.org)
87y2n47wng.fsf@nicolasgoaziou.fr
Hello,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> writes:

Toggle quote (3 lines)
> Patch file is attached. Disclaimer that I am the author of the
> upstream package.

Thank you.

Toggle quote (6 lines)
> Even though Guix does not (to the best of my knowledge) currently
> support macOS, I left the paragraph about behavior in macOS in the
> description because cross-platform support for users of multiple
> operating systems was one of my primary motivations for writing the
> package.

I suggest to eschew the problem and stick to the first sentence of the
description:

This package provides platform-specific paths for reading and writing
configuration, cache, and other data.

I think this is enough to understand what the package is about without
looking at the gory details.

WDYT?

Regards,
--
Nicolas Goaziou
L
L
LaFreniere, Joseph wrote on 29 Jul 2020 01:01
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 42549@debbugs.gnu.org)
87ime7s0qv.fsf@odyssey.lafreniere.xyz
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
Toggle quote (14 lines)
> I suggest to eschew the problem and stick to the first sentence
> of the
> description:
>
> This package provides platform-specific paths for reading and
> writing
> configuration, cache, and other data.
>
> I think this is enough to understand what the package is about
> without
> looking at the gory details.
>
> WDYT?

Sounds good to me. A new patch file is attached with the
description updated.

--
Joseph LaFreniere
From 9ba21584daa8a62bf939162dbd91ccb706f75f0f Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 26 Jul 2020 11:06:19 -0500
Subject: [PATCH] gnu: Add emacs-standard-dirs.

* gnu/packages/emacs-xyz.scm (emacs-standard-dirs): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8aaa92e1b2..f74fa948e4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3592,6 +3592,30 @@ particular, the minor mode works quite well with Org or Markdown modes, or
other markup language major modes.")
(license license:gpl3+))))
+(define-public emacs-standard-dirs
+ (package
+ (name "emacs-standard-dirs")
+ (version "2.0.0")
+ (home-page "https://github.com/lafrenierejm/standard-dirs.el")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r814qcrhvx4qlx4sdzwdmrhiryslqclx0bnpp0qcrbx6g8qfl25"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)))
+ (synopsis "Platform-specific paths for config, cache, and other data")
+ (description
+ "This package provides platform-specific paths for reading and writing
+configuration, cache, and other data.")
+ (license license:gpl3+)))
+
(define-public emacs-string-inflection
(package
(name "emacs-string-inflection")
--
2.27.0
L
L
Ludovic Courtès wrote on 19 Sep 2020 22:39
(name . LaFreniere, Joseph)(address . joseph@lafreniere.xyz)
87eemxpkkz.fsf@gnu.org
Hi,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> skribis:

Toggle quote (7 lines)
>>From 9ba21584daa8a62bf939162dbd91ccb706f75f0f Mon Sep 17 00:00:00 2001
> From: Joseph LaFreniere <joseph@lafreniere.xyz>
> Date: Sun, 26 Jul 2020 11:06:19 -0500
> Subject: [PATCH] gnu: Add emacs-standard-dirs.
>
> * gnu/packages/emacs-xyz.scm (emacs-standard-dirs): New variable.

Applied, thanks!

Ludo’.
Closed
?