[PATCH 0/2] freedink: fix build

  • Done
  • quality assurance status badge
Details
4 participants
  • ???
  • Jesse Gibbons
  • Jesse Gibbons
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Jesse Gibbons
Severity
normal
J
J
Jesse Gibbons wrote on 21 Jul 2020 08:40
(address . guix-patches@gnu.org)
b0a63440-08bb-d171-9de4-3579d5f6d099@gmail.com
This patch series fixes the problems with freedink. In particular, it
adds a phase that takes care of the outdated autotools files in the
source, and adds a patch to fix an SDL mismatch.

-Jesse
J
J
Jesse Gibbons wrote on 21 Jul 2020 08:42
[PATCH 1/2] gnu: freedink-engine: Call autoreconf.
(address . 42462@debbugs.gnu.org)
bb1b9195-e434-4525-4450-c709bee402be@gmail.com
* gnu/packages/games.scm: freedink-engine (phases): add 'autoreconf
---
gnu/packages/games.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index dc0511e55a..835c8c5f52 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2743,7 +2743,16 @@ interface or via an external visual interface
such as GNU XBoard.")
;; These tests require a graphical interface.
(substitute* "src/Makefile.am"
(("test_gfx_fonts TestIOGfxDisplay") ""))
- #t)))))
+ #t))
+ (add-before 'bootstrap 'autoreconf
+ (lambda _
+ ;; automake is out of date in the source
+ ;; autoreconf updates the automake scripts
+ (invoke "autoreconf")
+ ;; Build fails when autom4te.cache exists.
+ (delete-file-recursively "autom4te.cache")
+ #t))
+ )))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)
("cxxtest" ,cxxtest)
J
J
Jesse Gibbons wrote on 21 Jul 2020 08:42
[PATCH 2/2] gnu: freedink-engine: Fix sdl hints.
(address . 42462@debbugs.gnu.org)
417cb347-4ad9-016d-b018-e533a7215832@gmail.com
* gnu/packages/games.scm: freedink: [patches]: Add fix.
* gnu/packages/patches/freedink-engine-fix-sdl-hints.patch: New file.
* gnu/local.mk: Add it.
---
gnu/local.mk | 1 +
gnu/packages/games.scm | 1 +
.../freedink-engine-fix-sdl-hints.patch | 33 +++++++++++++++++++
3 files changed, 35 insertions(+)
create mode 100644 gnu/packages/patches/freedink-engine-fix-sdl-hints.patch

Toggle diff (63 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index fc68786ab6..b468ee237a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -950,6 +950,7 @@ dist_patch_DATA = \
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
%D%/packages/patches/fontconfig-hurd-path-max.patch \
+ %D%/packages/patches/freedink-engine-fix-sdl-hints.patch \
%D%/packages/patches/freeimage-unbundle.patch \
%D%/packages/patches/fuse-overlapping-headers.patch \
%D%/packages/patches/ganeti-deterministic-manual.patch \
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 835c8c5f52..2efbb3964e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2730,6 +2730,7 @@ interface or via an external visual interface such
as GNU XBoard.")
(method url-fetch)
(uri (string-append "mirror://gnu/freedink/freedink-" version
".tar.gz"))
+ (patches (search-patches "freedink-engine-fix-sdl-hints.patch"))
(sha256
(base32
"00hhk1bjdrc1np2qz44sa5n1mb62qzwxbvsnws3vpms6iyn3a2sy"))))
diff --git a/gnu/packages/patches/freedink-engine-fix-sdl-hints.patch
b/gnu/packages/patches/freedink-engine-fix-sdl-hints.patch
new file mode 100644
index 0000000000..ce37ab4870
--- /dev/null
+++ b/gnu/packages/patches/freedink-engine-fix-sdl-hints.patch
@@ -0,0 +1,33 @@
+From 85f8dda6de28ef86e58f26c8aa863a26524f6ce0 Mon Sep 17 00:00:00 2001
+From: Jesse Gibbons <jgibbons2357+freedink@gmail.com>
+Date: Sun, 9 Feb 2020 21:46:26 -0700
+Subject: [PATCH] Fix mouse/touch event hints for SDL 2.0.10.
+
+This fixes the bug reported at
+<https://lists.gnu.org/archive/html/bug-freedink/2019-08/msg00000.html>.
+
+It should remain backwards compatible with releases of SDL prior to 2.0.10.
+---
+ src/input.cpp | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/input.cpp b/src/input.cpp
+index b5ae21e..153d349 100644
+--- a/src/input.cpp
++++ b/src/input.cpp
+@@ -91,7 +91,12 @@ void input_init(void)
+ + // TODO: don't attempt to simulate mouse events from touch events -
+ // fake mouse events often are de-centered
++#ifdef SDL_HINT_ANDROID_SEPARATE_MOUSE_AND_TOUCH
+ SDL_SetHint(SDL_HINT_ANDROID_SEPARATE_MOUSE_AND_TOUCH, "0");
++#elif defined SDL_HINT_MOUSE_TOUCH_EVENTS && defined
SDL_HINT_TOUCH_MOUSE_EVENTS
++ SDL_SetHint(SDL_HINT_MOUSE_TOUCH_EVENTS, "0");
++ SDL_SetHint(SDL_HINT_TOUCH_MOUSE_EVENTS, "0");
++#endif
+ + /* Touch devices */
+ {
+-- +2.25.0
+
?
Re: [bug#42462] [PATCH 0/2] freedink: fix build
(name . Jesse Gibbons)(address . jgibbons2357@gmail.com)(address . 42462@debbugs.gnu.org)
87lfj8t31o.fsf@member.fsf.org
Jesse Gibbons <jgibbons2357@gmail.com> writes:

Toggle quote (6 lines)
> This patch series fixes the problems with freedink. In particular, it
> adds a phase that takes care of the outdated autotools files in the
> source, and adds a patch to fix an SDL mismatch.
>
> -Jesse

Hello, your patches doesn't apply (with 'git am'), as the alignment
(leading spaces) is wrong. Can you send them again as proper
attachments (inline or external) or via 'git send-email'?

Thank you!
J
J
Jesse Gibbons wrote on 28 Jul 2020 23:43
(re-send) [PATCH 0/2] freedink: fix build
(address . 42462@debbugs.gnu.org)
624a56fa-d0b3-d47a-faec-4c9bb1cb515e@byui.edu
The patches were mangled, and I didn't get the reply saying they were
mangled. Attached are the patch files.
From fb4f7827cb8aab1b5db3d8837981a5c0caa2b40c Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Mon, 10 Feb 2020 10:18:57 -0700
Subject: [PATCH 2/2] gnu: freedink-engine: Fix sdl hints.

* gnu/packages/games.scm: freedink: [patches]: Add fix.
* gnu/packages/patches/freedink-engine-fix-sdl-hints.patch: New file.
* gnu/local.mk: Add it.
---
gnu/local.mk | 1 +
gnu/packages/games.scm | 1 +
.../freedink-engine-fix-sdl-hints.patch | 33 +++++++++++++++++++
3 files changed, 35 insertions(+)
create mode 100644 gnu/packages/patches/freedink-engine-fix-sdl-hints.patch

Toggle diff (65 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index fc68786ab6..b468ee237a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -950,6 +950,7 @@ dist_patch_DATA = \
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
%D%/packages/patches/fontconfig-hurd-path-max.patch \
+ %D%/packages/patches/freedink-engine-fix-sdl-hints.patch \
%D%/packages/patches/freeimage-unbundle.patch \
%D%/packages/patches/fuse-overlapping-headers.patch \
%D%/packages/patches/ganeti-deterministic-manual.patch \
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 835c8c5f52..2efbb3964e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2730,6 +2730,7 @@ interface or via an external visual interface such as GNU XBoard.")
(method url-fetch)
(uri (string-append "mirror://gnu/freedink/freedink-" version
".tar.gz"))
+ (patches (search-patches "freedink-engine-fix-sdl-hints.patch"))
(sha256
(base32
"00hhk1bjdrc1np2qz44sa5n1mb62qzwxbvsnws3vpms6iyn3a2sy"))))
diff --git a/gnu/packages/patches/freedink-engine-fix-sdl-hints.patch b/gnu/packages/patches/freedink-engine-fix-sdl-hints.patch
new file mode 100644
index 0000000000..ce37ab4870
--- /dev/null
+++ b/gnu/packages/patches/freedink-engine-fix-sdl-hints.patch
@@ -0,0 +1,33 @@
+From 85f8dda6de28ef86e58f26c8aa863a26524f6ce0 Mon Sep 17 00:00:00 2001
+From: Jesse Gibbons <jgibbons2357+freedink@gmail.com>
+Date: Sun, 9 Feb 2020 21:46:26 -0700
+Subject: [PATCH] Fix mouse/touch event hints for SDL 2.0.10.
+
+This fixes the bug reported at
+<https://lists.gnu.org/archive/html/bug-freedink/2019-08/msg00000.html>.
+
+It should remain backwards compatible with releases of SDL prior to 2.0.10.
+---
+ src/input.cpp | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/input.cpp b/src/input.cpp
+index b5ae21e..153d349 100644
+--- a/src/input.cpp
++++ b/src/input.cpp
+@@ -91,7 +91,12 @@ void input_init(void)
+
+ // TODO: don't attempt to simulate mouse events from touch events -
+ // fake mouse events often are de-centered
++#ifdef SDL_HINT_ANDROID_SEPARATE_MOUSE_AND_TOUCH
+ SDL_SetHint(SDL_HINT_ANDROID_SEPARATE_MOUSE_AND_TOUCH, "0");
++#elif defined SDL_HINT_MOUSE_TOUCH_EVENTS && defined SDL_HINT_TOUCH_MOUSE_EVENTS
++ SDL_SetHint(SDL_HINT_MOUSE_TOUCH_EVENTS, "0");
++ SDL_SetHint(SDL_HINT_TOUCH_MOUSE_EVENTS, "0");
++#endif
+
+ /* Touch devices */
+ {
+--
+2.25.0
+
--
2.27.0
From babb7bd41959a450ac3ab4a77e9bd36dea6d94fd Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Fri, 3 Jul 2020 16:54:21 -0600
Subject: [PATCH 1/2] gnu: freedink-engine: Call autoreconf.

* gnu/packages/games.scm: freedink-engine (phases): add 'autoreconf
---
gnu/packages/games.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index dc0511e55a..835c8c5f52 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2743,7 +2743,16 @@ interface or via an external visual interface such as GNU XBoard.")
;; These tests require a graphical interface.
(substitute* "src/Makefile.am"
(("test_gfx_fonts TestIOGfxDisplay") ""))
- #t)))))
+ #t))
+ (add-before 'bootstrap 'autoreconf
+ (lambda _
+ ;; automake is out of date in the source
+ ;; autoreconf updates the automake scripts
+ (invoke "autoreconf")
+ ;; Build fails when autom4te.cache exists.
+ (delete-file-recursively "autom4te.cache")
+ #t))
+ )))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)
("cxxtest" ,cxxtest)
--
2.27.0
J
J
Jesse Gibbons wrote on 29 Jul 2020 00:56
(address . 42462@debbugs.gnu.org)
acf49a6d-5575-bdc5-6a42-883287e842d7@gmail.com
The patches were mangled, and I didn't get the reply saying they were
mangled. Attached are the patch files.
From fb4f7827cb8aab1b5db3d8837981a5c0caa2b40c Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Mon, 10 Feb 2020 10:18:57 -0700
Subject: [PATCH 2/2] gnu: freedink-engine: Fix sdl hints.

* gnu/packages/games.scm: freedink: [patches]: Add fix.
* gnu/packages/patches/freedink-engine-fix-sdl-hints.patch: New file.
* gnu/local.mk: Add it.
---
gnu/local.mk | 1 +
gnu/packages/games.scm | 1 +
.../freedink-engine-fix-sdl-hints.patch | 33 +++++++++++++++++++
3 files changed, 35 insertions(+)
create mode 100644 gnu/packages/patches/freedink-engine-fix-sdl-hints.patch

Toggle diff (65 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index fc68786ab6..b468ee237a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -950,6 +950,7 @@ dist_patch_DATA = \
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
%D%/packages/patches/fontconfig-hurd-path-max.patch \
+ %D%/packages/patches/freedink-engine-fix-sdl-hints.patch \
%D%/packages/patches/freeimage-unbundle.patch \
%D%/packages/patches/fuse-overlapping-headers.patch \
%D%/packages/patches/ganeti-deterministic-manual.patch \
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 835c8c5f52..2efbb3964e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2730,6 +2730,7 @@ interface or via an external visual interface such as GNU XBoard.")
(method url-fetch)
(uri (string-append "mirror://gnu/freedink/freedink-" version
".tar.gz"))
+ (patches (search-patches "freedink-engine-fix-sdl-hints.patch"))
(sha256
(base32
"00hhk1bjdrc1np2qz44sa5n1mb62qzwxbvsnws3vpms6iyn3a2sy"))))
diff --git a/gnu/packages/patches/freedink-engine-fix-sdl-hints.patch b/gnu/packages/patches/freedink-engine-fix-sdl-hints.patch
new file mode 100644
index 0000000000..ce37ab4870
--- /dev/null
+++ b/gnu/packages/patches/freedink-engine-fix-sdl-hints.patch
@@ -0,0 +1,33 @@
+From 85f8dda6de28ef86e58f26c8aa863a26524f6ce0 Mon Sep 17 00:00:00 2001
+From: Jesse Gibbons <jgibbons2357+freedink@gmail.com>
+Date: Sun, 9 Feb 2020 21:46:26 -0700
+Subject: [PATCH] Fix mouse/touch event hints for SDL 2.0.10.
+
+This fixes the bug reported at
+<https://lists.gnu.org/archive/html/bug-freedink/2019-08/msg00000.html>.
+
+It should remain backwards compatible with releases of SDL prior to 2.0.10.
+---
+ src/input.cpp | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/input.cpp b/src/input.cpp
+index b5ae21e..153d349 100644
+--- a/src/input.cpp
++++ b/src/input.cpp
+@@ -91,7 +91,12 @@ void input_init(void)
+
+ // TODO: don't attempt to simulate mouse events from touch events -
+ // fake mouse events often are de-centered
++#ifdef SDL_HINT_ANDROID_SEPARATE_MOUSE_AND_TOUCH
+ SDL_SetHint(SDL_HINT_ANDROID_SEPARATE_MOUSE_AND_TOUCH, "0");
++#elif defined SDL_HINT_MOUSE_TOUCH_EVENTS && defined SDL_HINT_TOUCH_MOUSE_EVENTS
++ SDL_SetHint(SDL_HINT_MOUSE_TOUCH_EVENTS, "0");
++ SDL_SetHint(SDL_HINT_TOUCH_MOUSE_EVENTS, "0");
++#endif
+
+ /* Touch devices */
+ {
+--
+2.25.0
+
--
2.27.0
From babb7bd41959a450ac3ab4a77e9bd36dea6d94fd Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Fri, 3 Jul 2020 16:54:21 -0600
Subject: [PATCH 1/2] gnu: freedink-engine: Call autoreconf.

* gnu/packages/games.scm: freedink-engine (phases): add 'autoreconf
---
gnu/packages/games.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index dc0511e55a..835c8c5f52 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2743,7 +2743,16 @@ interface or via an external visual interface such as GNU XBoard.")
;; These tests require a graphical interface.
(substitute* "src/Makefile.am"
(("test_gfx_fonts TestIOGfxDisplay") ""))
- #t)))))
+ #t))
+ (add-before 'bootstrap 'autoreconf
+ (lambda _
+ ;; automake is out of date in the source
+ ;; autoreconf updates the automake scripts
+ (invoke "autoreconf")
+ ;; Build fails when autom4te.cache exists.
+ (delete-file-recursively "autom4te.cache")
+ #t))
+ )))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)
("cxxtest" ,cxxtest)
--
2.27.0
J
N
N
Nicolas Goaziou wrote on 12 Aug 2020 17:12
(name . Jesse Gibbons)(address . jgibbons2357@gmail.com)(address . 42462-done@debbugs.gnu.org)
87eeobaof0.fsf@nicolasgoaziou.fr
Hello,

Jesse Gibbons <jgibbons2357@gmail.com> writes:

Toggle quote (4 lines)
> This is just a friendly bump!
>
> https://issues.guix.gnu.org/42462

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?