[PATCH] gnu: Add npiet.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Jesse Gibbons
  • Jakub K?dzio?ka
  • Marius Bakke
Owner
unassigned
Submitted by
Jesse Gibbons
Severity
normal
J
J
Jesse Gibbons wrote on 21 Jul 2020 08:11
(name . Guix Patches)(address . guix-patches@gnu.org)
ffa48c1a-9901-23bd-8068-0b75fd640580@gmail.com
* gnu/packages/piet.scm: New file.
* gnu/local.mk: Add it.
---
gnu/local.mk | 1 +
gnu/packages/piet.scm | 50 +++++++++++++++++++++++++++++++++++++++++++
2 files changed, 51 insertions(+)
create mode 100644 gnu/packages/piet.scm

Toggle diff (68 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 7bae1daf61..fc68786ab6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -425,6 +425,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/photo.scm \
%D%/packages/phabricator.scm \
%D%/packages/php.scm \
+ %D%/packages/piet.scm \
%D%/packages/pkg-config.scm \
%D%/packages/plotutils.scm \
%D%/packages/poedit.scm \
diff --git a/gnu/packages/piet.scm b/gnu/packages/piet.scm
new file mode 100644
index 0000000000..ee7137fad9
--- /dev/null
+++ b/gnu/packages/piet.scm
@@ -0,0 +1,50 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages piet)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages gd)
+ #:use-module (gnu packages groff)
+ #:use-module (guix licenses))
+
+
+(define-public npiet
+ (package
+ (name "npiet")
+ (version "1.3e")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://www.bertnase.de/npiet/npiet-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1i9ihbjmravid3h7wvns712axdl5xn398hk12pvzl79fs5kcf6g8"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gd" ,gd)))
+ (native-inputs `(("groff" ,groff)))
+ (synopsis "Piet interpreter")
+ (description
+ "An interpreter for the piet programming language")
+ (home-page "https://www.bertnase.de/npiet/")
+ (license gpl2+)))
+
M
M
Marius Bakke wrote on 25 Jul 2020 17:30
87365fvchn.fsf@gnu.org
Jesse Gibbons <jgibbons2357@gmail.com> writes:

Toggle quote (3 lines)
> * gnu/packages/piet.scm: New file.
> * gnu/local.mk: Add it.

The patch seems to have been mangled so it does not apply.

It would be great if you could expand the description with information
about what the piet language is and why users would want to try it.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8cUAQACgkQoqBt8qM6
VPpe7wgAzGJzMxuAVWDnvEuHSXI/9B4GEpktZCyWfxK7ixvYc7KJl18sHZOViTV0
ac25c2xfQ58lSUUiAGX+hn9dQb8F+5GO0igsvTibj+Lhw4sHsOQ3dAr2xla4iBnU
8rpUNUU152UI13o6uonItggzU0KQCBU2AvaOu+bPn4aMB0fS/qrtJOUXYXuHRAWg
5xxkJ/YiBZxQ/MBYkDj0bsDEtJhFp9S/07moH8PXUrji7n1wZ3d1T0ME3kBJbS+j
TWc6DsWMJLiwSunOHjoXN1YKoP1I7MemMFxtvBD+Bja0R3Lmu5DtGLIakGpoK5Sd
DA2ckmeX7vPbQ6DNBZT2ZDsrACs//w==
=Mb4O
-----END PGP SIGNATURE-----

J
J
Jesse Gibbons wrote on 28 Jul 2020 06:05
299c431d-40d0-6db3-553f-eb1d4fd69856@gmail.com
V2 attached.

On 7/25/20 9:30 AM, Marius Bakke wrote:
Toggle quote (8 lines)
> Jesse Gibbons <jgibbons2357@gmail.com> writes:
>
>> * gnu/packages/piet.scm: New file.
>> * gnu/local.mk: Add it.
> The patch seems to have been mangled so it does not apply.
>
> It would be great if you could expand the description with information
> about what the piet language is and why users would want to try it.
From 077214a6e13d770f70dfba2a7fe2faf40b1fbc56 Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Mon, 20 Jul 2020 20:35:09 -0600
Subject: [PATCH v2 1/1] gnu: Add npiet.

* gnu/packages/piet.scm: New file.
* gnu/local.mk: Add it.
---
gnu/local.mk | 1 +
gnu/packages/piet.scm | 60 +++++++++++++++++++++++++++++++++++++++++++
2 files changed, 61 insertions(+)
create mode 100644 gnu/packages/piet.scm

Toggle diff (80 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 7bae1daf61..fc68786ab6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -425,6 +425,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/photo.scm \
%D%/packages/phabricator.scm \
%D%/packages/php.scm \
+ %D%/packages/piet.scm \
%D%/packages/pkg-config.scm \
%D%/packages/plotutils.scm \
%D%/packages/poedit.scm \
diff --git a/gnu/packages/piet.scm b/gnu/packages/piet.scm
new file mode 100644
index 0000000000..e82b2aa339
--- /dev/null
+++ b/gnu/packages/piet.scm
@@ -0,0 +1,60 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages piet)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages gd)
+ #:use-module (gnu packages groff)
+ #:use-module (guix licenses))
+
+
+(define-public npiet
+ (package
+ (name "npiet")
+ (version "1.3e")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://www.bertnase.de/npiet/npiet-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1i9ihbjmravid3h7wvns712axdl5xn398hk12pvzl79fs5kcf6g8"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gd" ,gd)))
+ (native-inputs `(("groff" ,groff)))
+ (synopsis "Piet interpreter")
+ (description
+ "Npiet is an interpreter for the piet programming language. Instead of
+text, piet programs are pictures. Commands are determined based on changes in
+color.
+
+This package includes:
+@enumerate
+@item npiet, a piet interpreter with debugging capabilities
+@item npiet-foogol, a program that builds a piet program from foogol, an
+algol-like language
+@item npietedit, an editor for the piet programming language
+@end enumerate")
+ (home-page "https://www.bertnase.de/npiet/")
+ (license gpl2+)))
+
--
2.27.0
J
E
E
Efraim Flashner wrote on 19 Aug 2020 09:09
Re: [bug#42458] [PATCH] gnu: Add npiet.
(name . Jesse Gibbons)(address . jgibbons2357@gmail.com)
20200819070904.GD10528@E5400
Overall looks good, just a few changes before it can be merged:

On Mon, Jul 27, 2020 at 10:05:56PM -0600, Jesse Gibbons wrote:
Toggle quote (75 lines)
> V2 attached.
>
> On 7/25/20 9:30 AM, Marius Bakke wrote:
> > Jesse Gibbons <jgibbons2357@gmail.com> writes:
> >
> > > * gnu/packages/piet.scm: New file.
> > > * gnu/local.mk: Add it.
> > The patch seems to have been mangled so it does not apply.
> >
> > It would be great if you could expand the description with information
> > about what the piet language is and why users would want to try it.

> From 077214a6e13d770f70dfba2a7fe2faf40b1fbc56 Mon Sep 17 00:00:00 2001
> From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
> Date: Mon, 20 Jul 2020 20:35:09 -0600
> Subject: [PATCH v2 1/1] gnu: Add npiet.
>
> * gnu/packages/piet.scm: New file.
> * gnu/local.mk: Add it.
> ---
> gnu/local.mk | 1 +
> gnu/packages/piet.scm | 60 +++++++++++++++++++++++++++++++++++++++++++
> 2 files changed, 61 insertions(+)
> create mode 100644 gnu/packages/piet.scm
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 7bae1daf61..fc68786ab6 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -425,6 +425,7 @@ GNU_SYSTEM_MODULES = \
> %D%/packages/photo.scm \
> %D%/packages/phabricator.scm \
> %D%/packages/php.scm \
> + %D%/packages/piet.scm \
> %D%/packages/pkg-config.scm \
> %D%/packages/plotutils.scm \
> %D%/packages/poedit.scm \
> diff --git a/gnu/packages/piet.scm b/gnu/packages/piet.scm
> new file mode 100644
> index 0000000000..e82b2aa339
> --- /dev/null
> +++ b/gnu/packages/piet.scm
> @@ -0,0 +1,60 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
> +;;;
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify it
> +;;; under the terms of the GNU General Public License as published by
> +;;; the Free Software Foundation; either version 3 of the License, or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public License
> +;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu packages piet)
> + #:use-module (guix packages)
> + #:use-module (guix download)
> + #:use-module (guix build-system gnu)
> + #:use-module (gnu packages gd)
> + #:use-module (gnu packages groff)
> + #:use-module (guix licenses))
> +
> +
> +(define-public npiet
> + (package
> + (name "npiet")
> + (version "1.3e")

It seems 1.3f has come out in the meantime, can you update to the newer
version?

Toggle quote (13 lines)
> + (source (origin
> + (method url-fetch)
> + (uri
> + (string-append
> + "https://www.bertnase.de/npiet/npiet-"
> + version ".tar.gz"))
> + (sha256
> + (base32
> + "1i9ihbjmravid3h7wvns712axdl5xn398hk12pvzl79fs5kcf6g8"))))
> + (build-system gnu-build-system)
> + (inputs
> + `(("gd" ,gd)))

Looking at the build output and the test output (and npiet --help) it
looks like it's missing giflib and libpng.

Toggle quote (21 lines)
> + (native-inputs `(("groff" ,groff)))
> + (synopsis "Piet interpreter")
> + (description
> + "Npiet is an interpreter for the piet programming language. Instead of
> +text, piet programs are pictures. Commands are determined based on changes in
> +color.
> +
> +This package includes:
> +@enumerate
> +@item npiet, a piet interpreter with debugging capabilities
> +@item npiet-foogol, a program that builds a piet program from foogol, an
> +algol-like language
> +@item npietedit, an editor for the piet programming language
> +@end enumerate")
> + (home-page "https://www.bertnase.de/npiet/")
> + (license gpl2+)))
> +
> --
> 2.27.0
>

Also, when running npietedit, the program complains about missing wish.
npietedit should be wrapped with tk, which provides the 'wish' binary.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl880A0ACgkQQarn3Mo9
g1F3wA/9EdT63qNl6B16RusowDvYcgssPgbpOjIsv6Weaw14RP2K+lMLb3NPa2qW
er0wZNe0ajoM7xp4hFwVzYIEzXCcoRtUGHFkMSkh4p49WYBc5YO9s5O1WheF9Ano
1gxd8IGOMBFdLKqrtyeBAodNnLoKj+2bb+tvLsbVSwCvfcM804UGILISk0GOLI7G
RogOZ0oWMK76i9Cl38u6J78bnn3ac+8ZAtZzgaBQFDWZ6xi+BHQMAyOrbExFrPHp
u71engpnfMM3PHuB79OtK8ZOgcT3GgXXROKngfARKB8vJNNNf1AMpZDWJ3746TOo
u0frsEaORgUv20oaKrAIBVpWLBqVGwdmblWq77sQdFMsJjgKKKgz5gZ9fbLougkQ
KJxZ2suLCHzg72avtuPACwiTbbQssr5/udLfAEP0m2hNrdoCVXgHEItEG/TzFn9h
ltX6LoRi5OFq/U5Yezw2h5VOMU/ha+DnzVfZXzxBYikK+yywvh+jXCtdLNbsNb/2
MfpK+t1TqDpuUQsnLIwG0zsHUqoZVUfHIIz2kurf8JgCNgGMosjiPxW9y171WP4B
mbdAjuTux9jwMzURPA6HOazUkHBhmt50is37MrJyV7X4LZgpGB3pAMOXtWmHojTL
HkMM/1liMZrIXcA6tPooo/XkfiYs8RcJqxLxTb70j9HAqopPKj4=
=ChBV
-----END PGP SIGNATURE-----


J
J
Jesse Gibbons wrote on 4 Sep 2020 06:06
(name . Efraim Flashner)(address . efraim@flashner.co.il)
8705fe29-ed91-acd4-7eb5-a5bdb9c851a9@gmail.com
Hello again

On 8/19/20 1:09 AM, Efraim Flashner wrote:
Toggle quote (117 lines)
> Overall looks good, just a few changes before it can be merged:
>
> On Mon, Jul 27, 2020 at 10:05:56PM -0600, Jesse Gibbons wrote:
>> V2 attached.
>>
>> On 7/25/20 9:30 AM, Marius Bakke wrote:
>>> Jesse Gibbons <jgibbons2357@gmail.com> writes:
>>>
>>>> * gnu/packages/piet.scm: New file.
>>>> * gnu/local.mk: Add it.
>>> The patch seems to have been mangled so it does not apply.
>>>
>>> It would be great if you could expand the description with information
>>> about what the piet language is and why users would want to try it.
>> From 077214a6e13d770f70dfba2a7fe2faf40b1fbc56 Mon Sep 17 00:00:00 2001
>> From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
>> Date: Mon, 20 Jul 2020 20:35:09 -0600
>> Subject: [PATCH v2 1/1] gnu: Add npiet.
>>
>> * gnu/packages/piet.scm: New file.
>> * gnu/local.mk: Add it.
>> ---
>> gnu/local.mk | 1 +
>> gnu/packages/piet.scm | 60 +++++++++++++++++++++++++++++++++++++++++++
>> 2 files changed, 61 insertions(+)
>> create mode 100644 gnu/packages/piet.scm
>>
>> diff --git a/gnu/local.mk b/gnu/local.mk
>> index 7bae1daf61..fc68786ab6 100644
>> --- a/gnu/local.mk
>> +++ b/gnu/local.mk
>> @@ -425,6 +425,7 @@ GNU_SYSTEM_MODULES = \
>> %D%/packages/photo.scm \
>> %D%/packages/phabricator.scm \
>> %D%/packages/php.scm \
>> + %D%/packages/piet.scm \
>> %D%/packages/pkg-config.scm \
>> %D%/packages/plotutils.scm \
>> %D%/packages/poedit.scm \
>> diff --git a/gnu/packages/piet.scm b/gnu/packages/piet.scm
>> new file mode 100644
>> index 0000000000..e82b2aa339
>> --- /dev/null
>> +++ b/gnu/packages/piet.scm
>> @@ -0,0 +1,60 @@
>> +;;; GNU Guix --- Functional package management for GNU
>> +;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
>> +;;;
>> +;;; This file is part of GNU Guix.
>> +;;;
>> +;;; GNU Guix is free software; you can redistribute it and/or modify it
>> +;;; under the terms of the GNU General Public License as published by
>> +;;; the Free Software Foundation; either version 3 of the License, or (at
>> +;;; your option) any later version.
>> +;;;
>> +;;; GNU Guix is distributed in the hope that it will be useful, but
>> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
>> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
>> +;;; GNU General Public License for more details.
>> +;;;
>> +;;; You should have received a copy of the GNU General Public License
>> +;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
>> +
>> +(define-module (gnu packages piet)
>> + #:use-module (guix packages)
>> + #:use-module (guix download)
>> + #:use-module (guix build-system gnu)
>> + #:use-module (gnu packages gd)
>> + #:use-module (gnu packages groff)
>> + #:use-module (guix licenses))
>> +
>> +
>> +(define-public npiet
>> + (package
>> + (name "npiet")
>> + (version "1.3e")
> It seems 1.3f has come out in the meantime, can you update to the newer
> version?
>
>> + (source (origin
>> + (method url-fetch)
>> + (uri
>> + (string-append
>> + "https://www.bertnase.de/npiet/npiet-"
>> + version ".tar.gz"))
>> + (sha256
>> + (base32
>> + "1i9ihbjmravid3h7wvns712axdl5xn398hk12pvzl79fs5kcf6g8"))))
>> + (build-system gnu-build-system)
>> + (inputs
>> + `(("gd" ,gd)))
> Looking at the build output and the test output (and npiet --help) it
> looks like it's missing giflib and libpng.
>
>> + (native-inputs `(("groff" ,groff)))
>> + (synopsis "Piet interpreter")
>> + (description
>> + "Npiet is an interpreter for the piet programming language. Instead of
>> +text, piet programs are pictures. Commands are determined based on changes in
>> +color.
>> +
>> +This package includes:
>> +@enumerate
>> +@item npiet, a piet interpreter with debugging capabilities
>> +@item npiet-foogol, a program that builds a piet program from foogol, an
>> +algol-like language
>> +@item npietedit, an editor for the piet programming language
>> +@end enumerate")
>> + (home-page "https://www.bertnase.de/npiet/")
>> + (license gpl2+)))
>> +
>> --
>> 2.27.0
>>
> Also, when running npietedit, the program complains about missing wish.
> npietedit should be wrapped with tk, which provides the 'wish' binary.
>
All of these objections have been fixed. See attached patch.

-Jesse
From 5e856c667c9763666cfd164735cd854c8dae7804 Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Mon, 20 Jul 2020 20:35:09 -0600
Subject: [PATCH v2 1/1] gnu: Add npiet.

* gnu/packages/piet.scm: New file.
* gnu/local.mk: Add it.
---
gnu/local.mk | 1 +
gnu/packages/piet.scm | 55 +++++++++++++++++++++++++++++++++++++++++++
2 files changed, 56 insertions(+)
create mode 100644 gnu/packages/piet.scm

Toggle diff (75 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index d2753f52ae..974d44e481 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -430,6 +430,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/photo.scm \
%D%/packages/phabricator.scm \
%D%/packages/php.scm \
+ %D%/packages/piet.scm \
%D%/packages/pkg-config.scm \
%D%/packages/plotutils.scm \
%D%/packages/poedit.scm \
diff --git a/gnu/packages/piet.scm b/gnu/packages/piet.scm
new file mode 100644
index 0000000000..a70089a481
--- /dev/null
+++ b/gnu/packages/piet.scm
@@ -0,0 +1,55 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages piet)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages gd)
+ #:use-module (gnu packages groff)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages tcl)
+ #:use-module (guix licenses))
+
+
+(define-public npiet
+ (package
+ (name "npiet")
+ (version "1.3f")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://www.bertnase.de/npiet/npiet-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0nl59fhdqqr7nslxdirdn8nvlq5wws67c7jyx2ckbmxbc9h8bv9d"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gd" ,gd)
+ ("tk" ,tk)
+ ("giflib" ,giflib)
+ ("libpng" ,libpng)))
+ (native-inputs `(("groff" ,groff)))
+ (synopsis "Piet interpreter")
+ (description
+ "An interpreter for the piet programming language")
+ (home-page "https://www.bertnase.de/npiet/")
+ (license gpl2+)))
+
--
2.28.0
E
E
Efraim Flashner wrote on 5 Sep 2020 21:51
(name . Jesse Gibbons)(address . jgibbons2357@gmail.com)
20200905195159.GB1643@E5400
Attachment: file
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl9T7F8ACgkQQarn3Mo9
g1Ewvg//ZWb+AdljQXLBFtcod5ZYBZjttNSvm09RXszd8x0K0SUsR0IGBQrwZXFz
tJ3GHBiWH48ToiLNXkI7fU1fMA+Fc8BBRN9hbUkDtfmJDBXg4LtWUCISKGe9XuIA
1XJLnKzitKF2m5ZIuZXcurzCKnHTU1CkZicId05VYZb84PLv6UAvGJLDT+Aphjl+
6qNiBI81VkhZGsJLDd/cRumlcaSzm0v3jfR5VFs2o/ipOaMD87ha9s7B8mRL8QBu
dtc5vlnllpsWtcWHWzWp0rlk/34NBzswiFCq1mGL60Ps3/GKt50M0xiCIRphKlOP
6nC822TOfjEmXmIY1Aek5zQaoX/Vrhctr6nt5CnSz71UZp6nnxCl5TRYUpigURjv
BmQRpBRbzzBEkLKRod3M7ifQth4RIdQyy6CjzyJDrpynFJhOQpzLBy8rS0+v+/QK
MUVhhZKEqVPvm2kLwbtZD84F3hu+TdjiL2x8d2rb1ytbl+AMywCQGaCm/PAX/+NK
HPbIz2WwbsdrlYNcZUFxRdkwunhQG+hcieY9SgnNqCYHGPsRx9NYg2zeGeI03mbq
KkCObKkxzSyn+IRuh6Bi1I6RRvCDYGrjq+HphBa2NFvUB2di1fSGsd5WxfW+FsyK
SYAhVcKKRs1KKcIQzcL2uxuHUz355nOEkBKf1s/V+g31Uo3WjNQ=
=JlB8
-----END PGP SIGNATURE-----


J
J
Jakub K?dzio?ka wrote on 3 Jan 2021 01:20
close #42458
(address . control@debbugs.gnu.org)
C893CZCJ9VC7.2FDFQW9V4EDYK@gravity
close 42458
?