[PATCH] gnu: enigma: Fix enigma.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Efraim Flashner
  • Jesse Gibbons
Owner
unassigned
Submitted by
Jesse Gibbons
Severity
normal
J
J
Jesse Gibbons wrote on 21 Jul 2020 08:07
(name . Guix Patches)(address . guix-patches@gnu.org)
9d761881-01d7-7ac3-92a1-32ec5e63d47a@gmail.com
* gnu/packages/games.scm: enigma(phases): Add 'fix-proxy.
---
gnu/packages/games.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2efbb3964e..14d47dcbe6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5872,7 +5872,17 @@ The Flag. You can even design your own maps!")
(substitute* "src/main.cc"
(("#include <SDL_(image|ttf|mixer).h>" line header)
(string-append "#include \"SDL/SDL_" header ".h\"")))
- #t)))))
+ #t))
+ (add-after 'find-sdl 'fix-proxy
+ (lambda _
+ ;; Build fails when making src/lev/Proxy.cc because
+ ;; the wrong operator overload is used.
+ (substitute* "src/lev/Proxy.cc"
+ (("ifs != NULL")
+ "!ifs"))
+ (display "...")
+ #t))
+ )))
(inputs
`(("xerces-c" ,xerces-c)
("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))
B
B
Brett Gilio wrote on 25 Jul 2020 03:21
(name . Jesse Gibbons)(address . jgibbons2357@gmail.com)(address . 42454@debbugs.gnu.org)
874kpw5qzi.fsf@gnu.org
Jesse Gibbons <jgibbons2357@gmail.com> writes:

Toggle quote (29 lines)
> * gnu/packages/games.scm: enigma(phases): Add 'fix-proxy.
> ---
> gnu/packages/games.scm | 12 +++++++++++-
> 1 file changed, 11 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 2efbb3964e..14d47dcbe6 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -5872,7 +5872,17 @@ The Flag. You can even design your own maps!")
> (substitute* "src/main.cc"
> (("#include <SDL_(image|ttf|mixer).h>" line header)
> (string-append "#include \"SDL/SDL_" header ".h\"")))
> - #t)))))
> + #t))
> + (add-after 'find-sdl 'fix-proxy
> + (lambda _
> + ;; Build fails when making src/lev/Proxy.cc because
> + ;; the wrong operator overload is used.
> + (substitute* "src/lev/Proxy.cc"
> + (("ifs != NULL")
> + "!ifs"))
> + (display "...")
> + #t))
> + )))
> (inputs
> `(("xerces-c" ,xerces-c)
> ("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))

Hey Jesse,

Just like the last patch this one is mangled :).
J
J
Jesse Gibbons wrote on 28 Jul 2020 06:04
(name . Brett Gilio)(address . brettg@gnu.org)(address . 42454@debbugs.gnu.org)
809b8336-0f80-423a-f754-4d2c5eefa8ae@gmail.com
Attached. I removed some debug code I had left in.

On 7/24/20 7:21 PM, Brett Gilio wrote:
Toggle quote (33 lines)
> Jesse Gibbons <jgibbons2357@gmail.com> writes:
>
>> * gnu/packages/games.scm: enigma(phases): Add 'fix-proxy.
>> ---
>> gnu/packages/games.scm | 12 +++++++++++-
>> 1 file changed, 11 insertions(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
>> index 2efbb3964e..14d47dcbe6 100644
>> --- a/gnu/packages/games.scm
>> +++ b/gnu/packages/games.scm
>> @@ -5872,7 +5872,17 @@ The Flag. You can even design your own maps!")
>> (substitute* "src/main.cc"
>> (("#include <SDL_(image|ttf|mixer).h>" line header)
>> (string-append "#include \"SDL/SDL_" header ".h\"")))
>> - #t)))))
>> + #t))
>> + (add-after 'find-sdl 'fix-proxy
>> + (lambda _
>> + ;; Build fails when making src/lev/Proxy.cc because
>> + ;; the wrong operator overload is used.
>> + (substitute* "src/lev/Proxy.cc"
>> + (("ifs != NULL")
>> + "!ifs"))
>> + (display "...")
>> + #t))
>> + )))
>> (inputs
>> `(("xerces-c" ,xerces-c)
>> ("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))
> Hey Jesse,
>
> Just like the last patch this one is mangled :).
From a2ed7bff6ff65518910edac44f7e498418042bfb Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Fri, 3 Jul 2020 18:35:57 -0600
Subject: [PATCH v2 1/1] gnu: enigma: Fix enigma.

* gnu/packages/games.scm: enigma(phases): Add 'fix-proxy.
---
gnu/packages/games.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2efbb3964e..057f7f2d45 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5872,7 +5872,16 @@ The Flag. You can even design your own maps!")
(substitute* "src/main.cc"
(("#include <SDL_(image|ttf|mixer).h>" line header)
(string-append "#include \"SDL/SDL_" header ".h\"")))
- #t)))))
+ #t))
+ (add-after 'find-sdl 'fix-proxy
+ (lambda _
+ ;; Build fails when making src/lev/Proxy.cc because
+ ;; the wrong operator overload is used.
+ (substitute* "src/lev/Proxy.cc"
+ (("ifs != NULL")
+ "!ifs"))
+ #t))
+ )))
(inputs
`(("xerces-c" ,xerces-c)
("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))
--
2.27.0
J
E
E
Efraim Flashner wrote on 19 Aug 2020 08:54
Re: [bug#42454] [PATCH] gnu: enigma: Fix enigma.
(name . Jesse Gibbons)(address . jgibbons2357@gmail.com)(address . 42454-done@debbugs.gnu.org)
20200819065445.GC10528@E5400
It looks like a similar patch was pushed on July 24.
0b95f51eae50fbe627a354f50fa053a6d52b81aa


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl88zLIACgkQQarn3Mo9
g1E9+w//efQLWTt6BCEv0zxa592BRik1IQDuUVtjQIT0Bpt8ZPo4Bqm5n2+GWZ1T
UA1GpApgPjtxQHFAvxTpgjNqGBaq+FqF8906dApmEnOJf46NWQZ/Eh9SwDpjBMuW
t9JIayHJkpZUivVTlggq/+oOFHPgvGpA0SPXa+Rs5DQvt4zW+HaNui1CNoN7Ktnc
Doi9otxJwpGXzSJKGxTmlfkDrYqMGyzLH3/+G/hzhJmSQPe+qWmL70U+wXD0Rxir
17eHjLt5qcp2lraplMTd5QfDKO/MfsfHZcweS/ZdVwYVFyfaL/ygVECILjbgFbRT
x+r2rvufjhuYuusKVa0VMdH09G1k7wVCj6/IZEMXsobVM5iFWTZc/nE5FPct4yuG
ofeGVspgUa5MDj95T1KfPKeZ6N/sq8DH272h0+nTC3kUdEfjehZOUt3akzgvkrmS
cMsEfzHAqwWgl53cw/hAV0pUQt9H+ebKFV8fkjx7IqYeGXhWlQ65uLydMi+ddjYc
mwhke2VGhSzuJoyXf43rQBZUJzbCK9fQHFlDp0rr5h8ZdpfUctoOPO3VQlQiWrDY
p3Klp93H3Giuiqi+ruAZbAgucW93yRmewi9lO/H65BMxFTZ0OsHbjIStPhnJDAMV
VLmKfbmUbvm2umO3PCOoZim9fA2N3euj/5ij3Mi3Ho2vZ15wHUE=
=2TL/
-----END PGP SIGNATURE-----


Closed
?