[PATCH] gnu: Add python-robber.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Marius Bakke
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 15 Jul 2020 14:28
(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20200715122832.9196-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-robber): New variable.
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 15d9e097c5..f6afb73fcb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3522,6 +3522,26 @@ designed to be used by Robot Framework and tools and libraries in its
ecosystem, but can naturally be used also by other projects.")
(license license:asl2.0)))
+(define-public python-robber
+ (package
+ (name "python-robber")
+ (version "1.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "robber" version))
+ (sha256
+ (base32
+ "0xp5csgv2g9q38hscml6bc5i1nm4xy5lzqqiimm2drxsf0hw2nq5"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; no tests
+ (propagated-inputs
+ `(("python-mock" ,python-mock)
+ ("python-termcolor" ,python-termcolor)))
+ (home-page "https://github.com/vesln/robber.py")
+ (synopsis "BDD / TDD assertion library for Python")
+ (description "Robber is a BDD / TDD assertion library for Python.")
+ (license license:expat)))
+
(define-public python-robotframework
(package
(name "python-robotframework")
--
2.27.0
M
M
Marius Bakke wrote on 21 Jul 2020 23:22
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
87imegftre.fsf@gnu.org
Tanguy Le Carrour <tanguy@bioneland.org> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-robber): New variable.

Thanks! As this appears to be a test library, can you move it to
python-check.scm?

[...]
Toggle quote (13 lines)
> +(define-public python-robber
> + (package
> + (name "python-robber")
> + (version "1.1.5")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "robber" version))
> + (sha256
> + (base32
> + "0xp5csgv2g9q38hscml6bc5i1nm4xy5lzqqiimm2drxsf0hw2nq5"))))
> + (build-system python-build-system)
> + (arguments '(#:tests? #f)) ; no tests

There appears to be tests in the upstream repository:


Perhaps we should pull that instead of the PyPI release?

Otherwise LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8XXJUACgkQoqBt8qM6
VPom9Af/XG9LxpxyG2d99dg3+UV/sX6KA44oGNKCBduNowo9E44aq+2EeqxeaCYR
rtM7qhue/G+0JUTkfLsRdpAvp9sxDaJQvHBN64g/8asd8rKhGJms03gFNsDm3xpk
Kk4Ah+AYPnnvmSF2fDCXl9UfttIn1KWPNxda39EKjLUuscd/FLAwGv6H/Tr/i58A
1VNkYY2aPh+XQ+9a8PLdu2CiDOIo4vdldSlQkQg+4DvVITAgNoS8BO5ARQKuDWjs
qOt4DmgQbfsZZsuZAppN6C3JLEFW6Id3iMgWEtVqdvpynP15UNVxEvA0pTlflzGC
kujOiF0umRm5iJk2UcM6RQ2k75ccbA==
=ylcl
-----END PGP SIGNATURE-----

T
T
Tanguy Le Carrour wrote on 22 Jul 2020 10:14
(name . Marius Bakke)(address . marius@gnu.org)(address . 42364@debbugs.gnu.org)
20200722081423.camhgxzz5tltfcyq@melmoth
Hi,

Le 07/21, Marius Bakke a écrit :
Toggle quote (7 lines)
> Tanguy Le Carrour <tanguy@bioneland.org> writes:
>
> > * gnu/packages/python-xyz.scm (python-robber): New variable.
>
> Thanks! As this appears to be a test library, can you move it to
> python-check.scm?

Would make sense, indeed! I'm sending a v2 for this.


Toggle quote (19 lines)
> > +(define-public python-robber
> > + (package
> > + (name "python-robber")
> > + (version "1.1.5")
> > + (source (origin
> > + (method url-fetch)
> > + (uri (pypi-uri "robber" version))
> > + (sha256
> > + (base32
> > + "0xp5csgv2g9q38hscml6bc5i1nm4xy5lzqqiimm2drxsf0hw2nq5"))))
> > + (build-system python-build-system)
> > + (arguments '(#:tests? #f)) ; no tests
>
> There appears to be tests in the upstream repository:
>
> https://github.com/vesln/robber.py/tree/master/tests
>
> Perhaps we should pull that instead of the PyPI release?

Yes, but… for an (yet) unknown reason, version 1.1.5 is not in the git
repo!? The last version is 0.1.0!?
I sent an email to the author mentioned on PyPI. I'm adding a comment on
this in the package definition.

--
Tanguy
T
T
Tanguy Le Carrour wrote on 22 Jul 2020 10:14
[PATCH v2] gnu: Add python-robber.
(address . 42364@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20200722081440.21986-1-tanguy@bioneland.org
* gnu/packages/python-check.scm (python-robber): New variable.
---
gnu/packages/python-check.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2e3cfe05c5..8c4af22fab 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -534,3 +534,26 @@ it, the declaration of a name's public export semantics are not separated from
the implementation of that name.")
(license (list license:asl2.0
license:lgpl3)))) ; only for setup_helpers.py
+
+(define-public python-robber
+ (package
+ (name "python-robber")
+ (version "1.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "robber" version))
+ (sha256
+ (base32
+ "0xp5csgv2g9q38hscml6bc5i1nm4xy5lzqqiimm2drxsf0hw2nq5"))))
+ (build-system python-build-system)
+ ;; The last version tagged in Github (0.1.0) is older than the one on PyPI.
+ ;; Reported upstream: <https://github.com/vesln/robber.py/issues/20>.
+ ;; There are no tests in the tarball downloaded from PyPI.
+ (arguments '(#:tests? #f))
+ (propagated-inputs
+ `(("python-mock" ,python-mock)
+ ("python-termcolor" ,python-termcolor)))
+ (home-page "https://github.com/vesln/robber.py")
+ (synopsis "BDD / TDD assertion library for Python")
+ (description "Robber is a BDD / TDD assertion library for Python.")
+ (license license:expat)))
--
2.27.0
M
M
Marius Bakke wrote on 25 Jul 2020 17:40
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
87wo2rtxfw.fsf@gnu.org
Tanguy Le Carrour <tanguy@bioneland.org> writes:

Toggle quote (2 lines)
> * gnu/packages/python-check.scm (python-robber): New variable.

[...]

Toggle quote (3 lines)
> + ;; The last version tagged in Github (0.1.0) is older than the one on PyPI.
> + ;; Reported upstream: <https://github.com/vesln/robber.py/issues/20>.

Wow, it's concerning that someone just uploaded a fork on PyPI without
notifying the original author, yet reuses the original home page.

Even more so when there are no tags matching the uploaded tarball.

I think we should adjust the home page of this package to point to the
fork, and maybe add a comment explaining the situation. WDYT?

Can you also add a copyright line for yourself in python-check.scm?

Thanks for tracking down this issue!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8cUnMACgkQoqBt8qM6
VPqMtQf/RyjOE29KTAiDkjZVSWUcIunqCWCObQ/auBctIanjJ0TR2w8edZ8YPAET
oVHCzWhuBd3zkPzbXov9ScIO89/4rUIltGyKXJ/5jCW5ln3fA9i5mY3XugnTR+Uy
T5CuBtuUX1wCp5P4fW1gdfxdHCx91CTe2pxGXoVJ5ra2iF033gWMdT+u+DfSkLU/
KkC9KMnigdeuxGd2OHg5vT7PvMtNeacbTIAZ9qA5WPiEYrj0CCKWsXN5H1KLif0w
eGE46t4hjFL+EGDwNHRK14lba4aag8aPSe2sAy3IztCrMQyC4vgCMEr9RtUzkQ6R
Jo5A1ZrRCDRvmhGIUEV1pGhGXUMZ+w==
=w3J9
-----END PGP SIGNATURE-----

T
T
Tanguy Le Carrour wrote on 27 Jul 2020 10:26
(name . Marius Bakke)(address . marius@gnu.org)(address . 42364@debbugs.gnu.org)
20200727082627.wmg4fplswlikpbwp@melmoth
Hi Marius,


Le 07/25, Marius Bakke a écrit :
Toggle quote (12 lines)
> Tanguy Le Carrour <tanguy@bioneland.org> writes:
>
> > * gnu/packages/python-check.scm (python-robber): New variable.
>
> [...]
>
> > + ;; The last version tagged in Github (0.1.0) is older than the one on PyPI.
> > + ;; Reported upstream: <https://github.com/vesln/robber.py/issues/20>.
>
> Wow, it's concerning that someone just uploaded a fork on PyPI without
> notifying the original author, yet reuses the original home page.

He might have tried, but… the original author's email address given on
PyPI does not exist any more!


Toggle quote (5 lines)
> Even more so when there are no tags matching the uploaded tarball.
>
> I think we should adjust the home page of this package to point to the
> fork, and maybe add a comment explaining the situation. WDYT?

I've just send a email to the author of the last commit in the second
repo. Let's see what will happen!
In the worst case scenario, I can open a claim request on PyPI and fix
the mess myself. But let's hope I don't have to do that! ^_^'


--
Tanguy
M
M
Marius Bakke wrote on 30 Jul 2020 00:23
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 42364@debbugs.gnu.org)
87eeouq7tg.fsf@gnu.org
Tanguy Le Carrour <tanguy@bioneland.org> writes:

Toggle quote (19 lines)
> Hi Marius,
>
>
> Le 07/25, Marius Bakke a écrit :
>> Tanguy Le Carrour <tanguy@bioneland.org> writes:
>>
>> > * gnu/packages/python-check.scm (python-robber): New variable.
>>
>> [...]
>>
>> > + ;; The last version tagged in Github (0.1.0) is older than the one on PyPI.
>> > + ;; Reported upstream: <https://github.com/vesln/robber.py/issues/20>.
>>
>> Wow, it's concerning that someone just uploaded a fork on PyPI without
>> notifying the original author, yet reuses the original home page.
>
> He might have tried, but… the original author's email address given on
> PyPI does not exist any more!

Oh, right. That makes sense. :-)

Toggle quote (10 lines)
>> Even more so when there are no tags matching the uploaded tarball.
>>
>> I think we should adjust the home page of this package to point to the
>> fork, and maybe add a comment explaining the situation. WDYT?
>
> I've just send a email to the author of the last commit in the second
> repo. Let's see what will happen!
> In the worst case scenario, I can open a claim request on PyPI and fix
> the mess myself. But let's hope I don't have to do that! ^_^'

I hope so too! Meanwhile I think we can take the original patch you
sent, but adjust the home page to that of the fork.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8h9usACgkQoqBt8qM6
VPqj+Af/R7K8KepM6V/JVNnbWKgwG+t3T360tzTVPHSFsmgE8c5uJUjOaS497W9Q
WAHB6AACKYD7vivWgUTvi3kUgQ6Ssj1VfdDndPPNmNYNhbHVFbHziE5r5vjr06ML
YMNsEt+ft3CtHGI+3sjHEhuRcHuQE7isw6zByk8jwrrp4WOZJNWAun7SGRCQbHgY
3lY/QY1BYkAbJcCgU98cHfpwwLzgbvt9nXbmt8Dzgqo1Wo5cg+NVzEm7pklb3ofo
MMsAxe2+mpi34VP19dvOzXdknX4Ox1082HEuIF4vLAsZsX/9uRjlirrUjxfskSCg
g8FjecPCnRHfwQIaqoRM4kDJjhjIvw==
=K7Hw
-----END PGP SIGNATURE-----

T
T
Tanguy Le Carrour wrote on 30 Jul 2020 11:40
[PATCH v3] gnu: Add python-robber.
(address . 42364@debbugs.gnu.org)
20200730094015.12575-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (python-robber): New variable.
---
gnu/packages/python-check.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 51b864957f..aa00a35d23 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -889,3 +889,27 @@ any Python VM with basically no runtime overhead.")
;; Foundation License version 2: stdlib-samples/*, mypyc/lib-rt/pythonsupport.h and
;; mypyc/lib-rt/getargs.c
(license (list license:expat license:psfl))))
+
+(define-public python-robber
+ (package
+ (name "python-robber")
+ (version "1.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "robber" version))
+ (sha256
+ (base32
+ "0xp5csgv2g9q38hscml6bc5i1nm4xy5lzqqiimm2drxsf0hw2nq5"))))
+ (build-system python-build-system)
+ ;; There are no tests in the tarball downloaded from PyPI.
+ ;; The last version tagged in Github (0.1.0) is older than the one on PyPI.
+ ;; Reported upstream: <https://github.com/vesln/robber.py/issues/20>.
+ (arguments '(#:tests? #f))
+ (propagated-inputs
+ `(("python-mock" ,python-mock)
+ ("python-termcolor" ,python-termcolor)))
+ ;; URL of the fork used to generate the package available on PyPI.
+ (home-page "https://github.com/EastAgile/robber.py")
+ (synopsis "BDD / TDD assertion library for Python")
+ (description "Robber is a BDD / TDD assertion library for Python.")
+ (license license:expat)))
--
2.27.0
L
L
Ludovic Courtès wrote on 24 Sep 2020 17:49
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
87r1qr5g48.fsf@gnu.org
Hi,

Tanguy Le Carrour <tanguy@bioneland.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-robber): New variable.

[...]

Toggle quote (3 lines)
> + (synopsis "BDD / TDD assertion library for Python")
> + (description "Robber is a BDD / TDD assertion library for Python.")

I tweaked these and applied, thanks!

Ludo’.
Closed
T
T
Tanguy Le Carrour wrote on 27 Sep 2020 15:39
(name . Ludovic Courtès)(address . ludo@gnu.org)
20200927133900.kk6wrz2nrb5cj2ur@melmoth
Le 09/24, Ludovic Court�s a �crit :
Toggle quote (13 lines)
> Hi,
>
> Tanguy Le Carrour <tanguy@bioneland.org> skribis:
>
> > * gnu/packages/python-xyz.scm (python-robber): New variable.
>
> [...]
>
> > + (synopsis "BDD / TDD assertion library for Python")
> > + (description "Robber is a BDD / TDD assertion library for Python.")
>
> I tweaked these and applied, thanks!

Thanks!

--
Tanguy
Closed
?