[PATCH] gnu: Add python-buku.

  • Done
  • quality assurance status badge
Details
3 participants
  • Alexandros Theodotou
  • Ludovic Courtès
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 8 Jul 2020 23:38
(name . Guix patches)(address . guix-patches@gnu.org)
2253d09b2894e2630055161c99db21b334a861b6.camel@zrythm.org
Hi,

This patch adds python-buku, a command line bookmark manager.

Thanks,
Alex
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl8GPO4ACgkQAi6uQjE9
cPNlFQf9HY0i3imrLc8TZoDvtf0X6gor3dPHNsJXKnEu4MCUUkbEpB4o8IUhVTD2
leFoRBqkYuj/9mHg0+Qxt3bTlWHKiTuakzzFkSj76C0XPspidAVsWkVgeST+nRR3
zMyg4ekf8luAbz6xUhNKNTjyphF7zXaOanOa1g7HRthGR3+f9fGWdaEVRr3hKCIh
tWTNamuggI37c15/aLG8NSTM8RvJJJAZSqtNnEfQk8mSZ9EN96hqe52iWv0BOCjj
kjBpETmommtBow+VTzYmXQ0lPDD86zwl1omKR+LEdgBIiaoeMz5dO6PXjur3Q7yI
X/w3BTbXnSsUgt+arW/zLbLQzbsTiA==
=aSr0
-----END PGP SIGNATURE-----


A
A
Alexandros Theodotou wrote on 8 Jul 2020 23:41
(address . 42281@debbugs.gnu.org)
640185039a38a8f421546d3b8b987f6d4cb4ec59.camel@zrythm.org
Forgot patch
From b9dee307a164daac75874f85fe5192adc77fc505 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 22:37:25 +0100
Subject: [PATCH] gnu: Add python-buku.

* gnu/packages/python-xyz.scm (python-buku): New variable.
---
gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 98db6d9e51..e4b5cde95a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20261,6 +20261,36 @@ randomness (including real life dice) and different wordlists (including
cryptographically signed ones).")
(license license:gpl3+)))
+(define-public python-buku
+ (package
+ (name "python-buku")
+ (version "4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "buku" version))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g1xhdskfn72xaraqzz2v8dl2iza7bzfpn17z2wdrzkq3ih7yvgg"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; needs python-mypy-extensions which fails to build
+ (propagated-inputs
+ `(("python-html5lib" ,python-html5lib)
+ ("python-urllib3" ,python-urllib3)
+ ("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pylint" ,python-pylint)
+ ("python-vcrpy" ,python-vcrpy)))
+ (home-page "https://github.com/jarun/buku")
+ (synopsis
+ "Bookmark manager")
+ (description
+ "buku is a powerful bookmark manager written in Python3 and SQLite3.")
+ (license license:gpl3+)))
+
(define-public pyzo
(package
(name "pyzo")
--
2.27.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl8GPX0ACgkQAi6uQjE9
cPOWbwf/c5nOEpeammndPfkaMXMw3VN0jCI6yk4k2a6qP+I3N4WzWIeyqJZkGpa2
bW2581cghPkuA+PUaN+jE+RqFAM/TYMr7u7ZjPhqTg34DAW0MIaSTDoj1ZqxM2R+
0wlnwRR6YVsgbSgrkdSCDCRi04UqHJYayXWyElyBA8JoH2YZ2rj04Kf3D0Ejo8rI
Wbj2VixRUnn6G7xmSAOpKxsBXqL4yvWpVby5WoxlGbQ9vNeLbIjF7Gw/ly8KsjWl
EwSvc6jkjDPUK0R1EW5mmoVW6OPqcrg1w6KmQYisbDD2wDSGYTFUNZF3k+1s1s5S
zPD8x8YCYIoM273MPiDPBarLnFNS8A==
=nM3t
-----END PGP SIGNATURE-----


M
M
Marius Bakke wrote on 21 Jul 2020 00:29
Re: [bug#42281] [PATCH] gnu: Add python-buku.
878sfdhlc0.fsf@gnu.org
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-buku): New variable.

As this seems like a general-purpose tool and not a Python library, it
would be good to place this elsewhere. I'm not sure where though, maybe
(gnu packages web)?

Also I think the 'python-' prefix can be removed.

[...]
Toggle quote (16 lines)
> +(define-public python-buku
> + (package
> + (name "python-buku")
> + (version "4.4")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "buku" version))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1g1xhdskfn72xaraqzz2v8dl2iza7bzfpn17z2wdrzkq3ih7yvgg"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:tests? #f)) ; needs python-mypy-extensions which fails to build

Actually python-mypy-extensions seems to not be in Guix at all. Can you
adjust the comment with a TODO?

Toggle quote (9 lines)
> + (propagated-inputs
> + `(("python-html5lib" ,python-html5lib)
> + ("python-urllib3" ,python-urllib3)
> + ("python-beautifulsoup4" ,python-beautifulsoup4)
> + ("python-pytest" ,python-pytest)
> + ("python-pytest-cov" ,python-pytest-cov)
> + ("python-pylint" ,python-pylint)
> + ("python-vcrpy" ,python-vcrpy)))

These can probably be regular inputs, as python-build-system will
automatically 'wrap' the executables with these on PYTHONPATH.

Toggle quote (6 lines)
> + (synopsis
> + "Bookmark manager")
> + (description
> + "buku is a powerful bookmark manager written in Python3 and SQLite3.")

It's a chore, but it would be great if you could expand on the
description. Something along the lines of "@command{buku} can
auto-import bookmarks from your browser and present them in an
interactive command-line interface that lets you compose and update
bookmarks directly. It can also present them in a web interface with
@command{bukuserver}."

Can you send an updated patch?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl8WGr8ACgkQoqBt8qM6
VPpbwAf/VymtuxdYPGINbYFMBxwCN2tQGU9+zp3Ii/EDf2W9UdiaCFZ7PAjlq48T
8CyTJXweula4KCwl9gKkhFuyKexg6MyU1dnbhNWc7bjgETZmfbSXypLE1j8CSEom
IdyUJ5KcqC/c7Mg24uQdSL0FU2uTC1rb0PC0tPZvcoerQmigSC12lbR54wx0JOz0
+BirqaC04AufzwByJtXfkkXWNhv8BCcxV6bO5yG84wqm9NLcYHMlPksZTxobcfaq
EnCeDbg8rXmq4RnimvUWd7R8tmiYPUUclowSVu1YKSqyA/yp3BIGLOaOdY470mPG
t9+kWKNXj04yhHTmKZ+pLTD35kuvzA==
=Rn4w
-----END PGP SIGNATURE-----

A
A
Alexandros Theodotou wrote on 10 Sep 2020 17:57
bd6a71b8e9a68016b6eedbed96a39fa06bf6ed07.camel@zrythm.org
Hi Marius,

On Tue, 2020-07-21 at 00:29 +0200, Marius Bakke wrote:
Toggle quote (8 lines)
> As this seems like a general-purpose tool and not a Python library,
> it
> would be good to place this elsewhere. I'm not sure where though,
> maybe
> (gnu packages web)?
>
> Also I think the 'python-' prefix can be removed.

Done.

Toggle quote (8 lines)
> > + (arguments
> > + `(#:tests? #f)) ; needs python-mypy-extensions which fails
> > to build
>
> Actually python-mypy-extensions seems to not be in Guix at all. Can
> you
> adjust the comment with a TODO?

Done.

Toggle quote (13 lines)
>
> > + (propagated-inputs
> > + `(("python-html5lib" ,python-html5lib)
> > + ("python-urllib3" ,python-urllib3)
> > + ("python-beautifulsoup4" ,python-beautifulsoup4)
> > + ("python-pytest" ,python-pytest)
> > + ("python-pytest-cov" ,python-pytest-cov)
> > + ("python-pylint" ,python-pylint)
> > + ("python-vcrpy" ,python-vcrpy)))
>
> These can probably be regular inputs, as python-build-system will
> automatically 'wrap' the executables with these on PYTHONPATH.

Done.

Toggle quote (15 lines)
>
> > + (home-page "https://github.com/jarun/buku")
> > + (synopsis
> > + "Bookmark manager")
> > + (description
> > + "buku is a powerful bookmark manager written in Python3 and
> > SQLite3.")
>
> It's a chore, but it would be great if you could expand on the
> description. Something along the lines of "@command{buku} can
> auto-import bookmarks from your browser and present them in an
> interactive command-line interface that lets you compose and update
> bookmarks directly. It can also present them in a web interface with
> @command{bukuserver}."

Added your proposed text.

Toggle quote (2 lines)
> Can you send an updated patch?

Please find the new patch attached.

Thanks,
Alex
From 217d5661c4d76f79176d947b2376dfa89e5dcc01 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Thu, 10 Sep 2020 16:54:52 +0100
Subject: [PATCH] gnu: Add buku.

* gnu/packages/web.scm (buku): New variable.
---
gnu/packages/web.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2c3a007779..cf4f1ef0b1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7424,6 +7424,40 @@ update an existing mirrored site, and resume interrupted downloads.
HTTrack is fully configurable, and has an integrated help system.")
(license license:gpl3+)))
+(define-public buku
+ (package
+ (name "buku")
+ (version "4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "buku" version))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g1xhdskfn72xaraqzz2v8dl2iza7bzfpn17z2wdrzkq3ih7yvgg"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; TODO needs python-mypy-extensions
+ (inputs
+ `(("python-html5lib" ,python-html5lib)
+ ("python-urllib3" ,python-urllib3)
+ ("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pylint" ,python-pylint)
+ ("python-vcrpy" ,python-vcrpy)))
+ (home-page "https://github.com/jarun/buku")
+ (synopsis
+ "Bookmark manager")
+ (description
+ "buku is a powerful bookmark manager written in Python3 and SQLite3.
+@command{buku} can auto-import bookmarks from your browser and present them
+in an interactive command-line interface that lets you compose and update
+bookmarks directly. It can also present them in a web interface with
+@command{bukuserver}.")
+ (license license:gpl3+)))
+
(define-public anonip
(package
(name "anonip")
--
2.27.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl9aTQEACgkQAi6uQjE9
cPPGVwf/ah4k/0AzZaGVpiBp4hOfCNU3ruaEKZxAfjZGuRX6BLJBDWGbToEuk4ga
AVZTfJ+jSc5IoXq+/078IeeFW9i1GNCRvKW+eAgHh48ik1PjfH6ekr5PHc1Vye8t
2/RyGk4tSGq86pxLtsOet+1/AURSwqxMO7kJ2gULVPssM6Y6ZwMNJvsC4/ESS8ow
LHWRzoUXNEvDFMRtg15l8sP95e9HxpF7xT4qxmfyFubYOE2Hr3Yy8NFIxdJzasuE
fjbqskLgKwoUNQBIaqYhr99/qAsjkg2YokXnr93KIQv9OzCUeSCIFwiIDjjWgSyd
FSW6Rfr9QDqSv0ByH0tTBAKIREoy+w==
=BohS
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 18 Dec 2020 15:02
(name . Alexandros Theodotou)(address . alex@zrythm.org)
87o8irciw5.fsf@gnu.org
Alexandros Theodotou <alex@zrythm.org> skribis:

Toggle quote (7 lines)
> From 217d5661c4d76f79176d947b2376dfa89e5dcc01 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Thu, 10 Sep 2020 16:54:52 +0100
> Subject: [PATCH] gnu: Add buku.
>
> * gnu/packages/web.scm (buku): New variable.

Applied in 26f6bd0403ed20c1d26eca9d4f28a0da519a56ac, closing!

Ludo’.
Closed
?