[PATCH] gnu: Add kicad-doc.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brice Waegeneire
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
B
B
Brice Waegeneire wrote on 4 Jul 2020 18:01
(address . guix-patches@gnu.org)(address . me@tobias.gr)
20200704160124.13847-1-brice@waegenei.re
* gnu/packages/engineering.scm (kicad-doc): New variable.
(kicad)[native-search-paths]: Add 'KICAD'.
---

The environment variable 'KICAD' is set to the the root of the profile because
there isn't a specific variable to set the documentation path. This
environment variable isn't documented tho it is explicitly used in the code.


gnu/packages/engineering.scm | 46 +++++++++++++++++++++++++++++++++++-
1 file changed, 45 insertions(+), 1 deletion(-)

Toggle diff (87 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f2d32e663f..fb8ffc8263 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -65,6 +65,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages dejagnu)
#:use-module (gnu packages digest)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
@@ -95,6 +96,7 @@
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages mpi)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -805,7 +807,6 @@ language.")
(license (list license:mpl2.0 ;library
license:gpl2+))))) ;Guile bindings and GUI
-;; TODO Add doc https://gitlab.com/kicad/services/kicad-doc/-/tree/master
(define-public kicad
(package
(name "kicad")
@@ -855,6 +856,9 @@ language.")
#t)))))
(native-search-paths
(list (search-path-specification
+ (variable "KICAD") ; to find kicad-doc
+ (files '("")))
+ (search-path-specification
(variable "KICAD_TEMPLATE_DIR")
(files '("share/kicad/template")))
(search-path-specification
@@ -926,6 +930,46 @@ translations for KiCad.")
(define-public kicad-i18l
(deprecated-package "kicad-i18l" kicad-i18n))
+(define-public kicad-doc
+ (package
+ (name "kicad-doc")
+ (version "5.1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/kicad/services/kicad-doc.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03kvss8a0xrjnfvkwymm0vfd7rn9ix7i926xdzz9jg9iycrjfj3g"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DBUILD_FORMATS=html")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build)
+ (add-before 'install 'set-perl-env
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "PERL5LIB"
+ (string-append (assoc-ref inputs "perl-unicode-linebreak")
+ "/lib/perl5/site_perl" ":"
+ (getenv "PERL5LIB")))
+ #t))
+ (delete 'check))))
+ (native-inputs
+ `(("asciidoc" ,asciidoc)
+ ("gettext" ,gettext-minimal)
+ ("git" ,git-minimal)
+ ("perl" ,perl)
+ ("perl-unicode-linebreak" ,perl-unicode-linebreak)
+ ("po4a" ,po4a)
+ ("source-highlight" ,source-highlight)))
+ (home-page "https://kicad-pcb.org/")
+ (synopsis "KiCad official documentation")
+ (description "This repository contains the official KiCad documentation.")
+ (license license:gpl3+)))
+
(define-public kicad-symbols
(package
(name "kicad-symbols")
--
2.26.2
D
D
Danny Milosavljevic wrote on 17 Jul 2020 20:51
(name . Brice Waegeneire)(address . brice@waegenei.re)
20200717205138.30b772ad@scratchpost.org
LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl8R8zoACgkQ5xo1VCww
uqV9TQf/UlxGuJYqr4FNdGa/vrzbp0ELYudQFu0okLHHGfLLl6wXiX9F55z++Nd8
oPL5EVD7NrCS7Yo63eyjXODCrB+a2Rs4zsjZk9pbcEwYB0P2ITwceP4Eo3Nt/C4u
pOZa3rKgg+PWQbJuS0mF4zu+f9zSCC8swxiChujC55ZhcM1rzFqmudWobdrfzQt0
BxduQFgm5GMnG/+BY+WIxg58wZGR8BFN24kmM1E7cXlSBXhsHPP/qpY8/0nqqepy
EqHXxGSf6nseKeOQQZan82A1a8gJS/jNdv9xEaDpaTik8p68Xpxd1Uc2aO6UXDW+
DikZx9qLHQqyWZC7TjsgwkU1ytPCVQ==
=+6va
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 18 Dec 2020 16:04
(name . Brice Waegeneire)(address . brice@waegenei.re)
87blerb1f8.fsf@gnu.org
Hi Brice,

Brice Waegeneire <brice@waegenei.re> skribis:

Toggle quote (3 lines)
> * gnu/packages/engineering.scm (kicad-doc): New variable.
> (kicad)[native-search-paths]: Add 'KICAD'.

Finally applied on your behalf, thanks!

Ludo’.
Closed
?