[PATCH] gnu: gfortran: Remove unusable versions.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jakub K?dzio?ka
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jakub K?dzio?ka
Severity
normal
J
J
Jakub K?dzio?ka wrote on 29 Jun 2020 22:48
(address . guix-patches@gnu.org)
20200629204819.8685-1-kuba@kadziolka.net
The gfortran packages cannot be used without being wrapped with
gfortran-toolchain. However, as the comment in (gnu packages
commencement) explains, there cannot be more than one gfortran-toolchain
package because of ABI issues. Thus, versions of gfortran other than the
main one are useless.

* gnu/packages/gcc.scm (gfortran-4.8, gfortran-4.9, gfortran-5,
gfortran-6, gfortran-7, gfortran-8, gfortran-9): Remove variables.
(gfortran): Define the gfortran package based on the gcc variable.
---
gnu/packages/gcc.scm | 41 ++---------------------------------------
1 file changed, 2 insertions(+), 39 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 0c5be69fbf..31d88f2e0b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -687,48 +687,11 @@ as the 'native-search-paths' field."
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))
-(define-public gfortran-4.8
- (hidden-package
- (custom-gcc gcc-4.8 "gfortran" '("fortran")
- %generic-search-paths)))
-
-(define-public gfortran-4.9
- (hidden-package
- (custom-gcc gcc-4.9 "gfortran" '("fortran")
- %generic-search-paths)))
-
-(define-public gfortran-5
- (hidden-package
- (custom-gcc gcc-5 "gfortran" '("fortran")
- %generic-search-paths)))
-
-(define-public gfortran-6
- (hidden-package
- (custom-gcc gcc-6 "gfortran" '("fortran")
- %generic-search-paths)))
-
-(define-public gfortran-7
- (hidden-package
- (custom-gcc gcc-7 "gfortran" '("fortran")
- %generic-search-paths)))
-
-(define-public gfortran-8
- (hidden-package
- (custom-gcc gcc-8 "gfortran" '("fortran")
- %generic-search-paths)))
-
-(define-public gfortran-9
+(define-public gfortran
(hidden-package
- (custom-gcc gcc-9 "gfortran" '("fortran")
+ (custom-gcc gcc "gfortran" '("fortran")
%generic-search-paths)))
-(define-public gfortran
- ;; Note: Update this when GCC changes! We cannot use
- ;; (custom-gcc gcc "fortran" …) because that would lead to a package object
- ;; that is not 'eq?' with GFORTRAN-5, and thus 'fold-packages' would
- ;; report two gfortran@5 that are in fact identical.
- gfortran-7)
-
(define-public libgccjit
(package
(inherit gcc-9)
--
2.27.0
L
L
Ludovic Courtès wrote on 30 Jun 2020 11:23
(name . Jakub K?dzio?ka)(address . kuba@kadziolka.net)(address . 42132@debbugs.gnu.org)
87tuys9abv.fsf@gnu.org
Hello,

Jakub K?dzio?ka <kuba@kadziolka.net> skribis:

Toggle quote (10 lines)
> The gfortran packages cannot be used without being wrapped with
> gfortran-toolchain. However, as the comment in (gnu packages
> commencement) explains, there cannot be more than one gfortran-toolchain
> package because of ABI issues. Thus, versions of gfortran other than the
> main one are useless.
>
> * gnu/packages/gcc.scm (gfortran-4.8, gfortran-4.9, gfortran-5,
> gfortran-6, gfortran-7, gfortran-8, gfortran-9): Remove variables.
> (gfortran): Define the gfortran package based on the gcc variable.

LGTM, thanks! :-)

Ludo’.
J
J
Jakub K?dzio?ka wrote on 30 Jun 2020 13:01
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 42132-done@debbugs.gnu.org)
20200630110119.ozdijqnegx4b26ob@gravity
On Tue, Jun 30, 2020 at 11:23:00AM +0200, Ludovic Courtès wrote:
Toggle quote (18 lines)
> Hello,
>
> Jakub K?dzio?ka <kuba@kadziolka.net> skribis:
>
> > The gfortran packages cannot be used without being wrapped with
> > gfortran-toolchain. However, as the comment in (gnu packages
> > commencement) explains, there cannot be more than one gfortran-toolchain
> > package because of ABI issues. Thus, versions of gfortran other than the
> > main one are useless.
> >
> > * gnu/packages/gcc.scm (gfortran-4.8, gfortran-4.9, gfortran-5,
> > gfortran-6, gfortran-7, gfortran-8, gfortran-9): Remove variables.
> > (gfortran): Define the gfortran package based on the gcc variable.
>
> LGTM, thanks! :-)
>
> Ludo’.

Thanks, pushed as 0681f05486d901c92637c098bb7afddef35068b0.

Regards,
Jakub K?dzio?ka
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl77G38ACgkQ4xWnWEYT
FWQ88w/+J0253TGFpOKCEFzmD1ea+xUtb7iEFxFHVGxwgvdviFvYcBSqJ2V9iwc1
z4W1xhehMWHkpXp3P1JzatiedPPMCBDvHPTqPpFQ18H/sRQNSOZfngjHb2VXAHcK
JKz9hBg7n5sI7a864JCh6xGqyzhpDR9Yo+YuZaHFxwpnyp6swiuVT3tA9q4+wr82
KJ3YA69NYPAwVezvRg2rH7Lh5fXbvQf4x7wYvlcr6jcdZ1Z1a4UE5m0+Fxy6WQLG
9FTXsAmpbJ99keOfN8jhWI57feqrChvX47PZ4ozGpG4ZSWqeaPvPvNqZD4P1CoJw
uvSAPBCDBebK982tUVFIUTzQnvgH4zyDWzU0p9GLpAxA40jaloM+AorawygpprTn
UMIazBXdaClWE+nN9VSL9XY0ip7lfo/lE3o2NtC7Uivk/qhGWu26TTSyXIE0rVDy
fDqdQzxBDlErlV7TNJrQiLm7Y7yQ8RIfZJFCeiRY3lxECSXod6/4BRBJBWzMltT9
Qjg3RReI0YvNaMN19hqjc29pTzqvD8SBlYv6lMP+CuVRIJM6Cquwla7Ia8mwvJP5
cu9n73fpnInGNWhBQHa2RnyhM/6kbpWdc3BhiHOjP5c+4PQe/au5GCg1a/JmKK5u
LjST0LkDDoGUppREMWQ/ubq5Af/w5p8OKFMXqKFLbwOJEnxKpkM=
=fJWk
-----END PGP SIGNATURE-----


Closed
?