[PATCH 2/2] gnu: Add webvfx.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Marius Bakke
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 21 Jun 2020 20:25
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200621182547.27225-2-monego@posteo.net
* gnu/packages/video.scm (webvfx): New variable.
---
gnu/packages/video.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e51729138c..a0b454c403 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2390,6 +2390,44 @@ functionality of the system is provided via an assortment of ready to use
tools, XML authoring components, and an extensible plug-in based API.")
(license license:gpl3)))
+(define-public webvfx
+ (package
+ (name "webvfx")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mltframework/webvfx")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0brpnf2yllx3510dlm1p7bq5p5havnvr1bglhsbl2f07281m7nl1"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (let ((out (assoc-ref %outputs "out")))
+ (invoke "qmake"
+ (string-append "PREFIX=" out)
+ "all.pro")))))))
+ (native-inputs
+ `(("qmake" ,qttools)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebkit" ,qtwebkit)))
+ (propagated-inputs
+ `(("mlt" ,mlt)))
+ (home-page "https://github.com/mltframework/webvfx")
+ (synopsis "Video effects engine based on web technologies")
+ (description "WebVfx is a video effects library that allows effects to
+be implemented using WebKit HTML or Qt QML.")
+ (license license:bsd-3)))
+
(define-public v4l-utils
(package
(name "v4l-utils")
--
2.20.1
M
M
Marius Bakke wrote on 22 Jun 2020 23:36
(name . Vinicius Monego)(address . monego@posteo.net)
87tuz2ailj.fsf@gnu.org
Vinicius Monego <monego@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/video.scm (webvfx): New variable.

This fails to install like so:

make[2]: Entering directory '/tmp/guix-build-webvfx-1.2.0.drv-0/source/mlt'
/gnu/store/59dq1n4wj3maa3kcar6hspj2zd82as7q-qtbase-5.14.2/bin/qmake -install qinstall -exe ../build/release/libmltwebvfx.so /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so
Error copying ../build/release/libmltwebvfx.so to /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so: Cannot create /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so for output

It seems it attempts to write the the mlt store directory. Can you look
into it?

TIA,
Marius
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7xJFgACgkQoqBt8qM6
VPof+QgAmSvyJt2MmI0TeXfNc6b2raQHpIYFdCjoNHHj5GOan1SQcIevKgvGIhpB
76OMmIKx6GNhsPS5w1CqWMF9JI7f8qFd3jZkfn9IA6wz8pSed7pJzzzeC9jX1syV
M09bgsxgRkGY6R1ObDrZGZfs90Trg3BmJrszkS9JYY4sOtoGoNkxEUxmzh9buJHI
i6MVpVV5s8IJ38fqKR1OoSENF7roW667nCjKq4BUTso7t2XFvf6WtGByfXWXEFVA
cWKOpgOYWJ7KaY6dui4+tY4LykAp4ebfmj4RtFn7c6x2Rj/Z0P92NjHqUs0HUA7L
MNWwnk6xN1S42mklq3TmVg1FClS9Aw==
=e/Up
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 2 Sep 2020 17:10
(name . Marius Bakke)(address . marius@gnu.org)
87pn7443k8.fsf@gnu.org
Hi Vinicius,

Friendly ping! :-)

Marius Bakke <marius@gnu.org> skribis:

Toggle quote (15 lines)
> Vinicius Monego <monego@posteo.net> writes:
>
>> * gnu/packages/video.scm (webvfx): New variable.
>
> This fails to install like so:
>
> make[2]: Entering directory '/tmp/guix-build-webvfx-1.2.0.drv-0/source/mlt'
> /gnu/store/59dq1n4wj3maa3kcar6hspj2zd82as7q-qtbase-5.14.2/bin/qmake -install qinstall -exe ../build/release/libmltwebvfx.so /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so
> Error copying ../build/release/libmltwebvfx.so to /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so: Cannot create /gnu/store/fqf6g8smi81vix825x78z9py5b5qgshh-mlt-6.20.0/lib/mlt/libmltwebvfx.so for output
>
> It seems it attempts to write the the mlt store directory. Can you look
> into it?
>
> TIA,
> Marius
V
V
Vinicius Monego wrote on 2 Sep 2020 18:59
(name . Ludovic Courtès)(address . ludo@gnu.org)
875z8wjerc.fsf@posteo.net
Ludovic Courtès writes:

Toggle quote (5 lines)
> Hi Vinicius,
>
> Friendly ping! :-)
>

Hello Ludo, Marius.

Apologies for the delay. An easy solution to this is to disable
the MLT
services by removing MLT from the inputs. I intended to have them
enabled because I was packaging webvfx as optional dependency for
the
Shotcut video editor, which uses MLT.

However, I checked the webvfx repository right now and it was
deprecated
in the meantime and is no longer maintained. For this reason I am
closing the issue.

Vinicius
Closed
L
L
Ludovic Courtès wrote on 2 Sep 2020 22:19
(name . Vinicius Monego)(address . monego@posteo.net)
87tuwg2ap4.fsf@gnu.org
Hi,

Vinicius Monego <monego@posteo.net> skribis:

Toggle quote (11 lines)
> Apologies for the delay. An easy solution to this is to disable the
> MLT
> services by removing MLT from the inputs. I intended to have them
> enabled because I was packaging webvfx as optional dependency for the
> Shotcut video editor, which uses MLT.
>
> However, I checked the webvfx repository right now and it was
> deprecated
> in the meantime and is no longer maintained. For this reason I am
> closing the issue.

OK, thank you for the quick reply!

Ludo’.
Closed
?