[PATCH 0/2] Add pass-tomb.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brice Waegeneire
  • Danny Milosavljevic
  • Julien Lepiller
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
B
B
Brice Waegeneire wrote on 20 Jun 2020 17:09
(address . guix-patches@gnu.org)
20200620150912.27001-1-brice@waegenei.re
Brice Waegeneire (2):
gnu: tomb: Add 'getent' to PATH.
gnu: Add 'pass-tomb'.

gnu/packages/crypto.scm | 3 ++-
gnu/packages/password-utils.scm | 41 +++++++++++++++++++++++++++++++++
2 files changed, 43 insertions(+), 1 deletion(-)

--
2.26.2
B
B
Brice Waegeneire wrote on 20 Jun 2020 17:11
[PATCH 1/2] gnu: tomb: Add 'getent' to PATH.
(address . 41964@debbugs.gnu.org)
20200620151111.28385-1-brice@waegenei.re
* gnu/packages/crypto.scm (tomb)[arguments]: In 'wrap' phase add
'getent' to the PATH.
---
gnu/packages/crypto.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index be8f8b9f05..5cee32b0bb 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -389,7 +390,7 @@ no man page, refer to the home page for usage details.")
(error "program not found:" program)))
'("seq" "mkfs.ext4" "pinentry"
"gpg" "cryptsetup" "gettext" "lsof"
- "qrencode" "steghide" "findmnt")))))
+ "qrencode" "steghide" "findmnt" "getent")))))
#t)))
(delete 'check)
(add-after 'wrap 'check
--
2.26.2
B
B
Brice Waegeneire wrote on 20 Jun 2020 17:11
[PATCH 2/2] gnu: Add 'pass-tomb'.
(address . 41964@debbugs.gnu.org)
20200620151111.28385-2-brice@waegenei.re
* gnu/packages/password-utils.scm (pass-tomb): New variable.
---
gnu/packages/password-utils.scm | 41 +++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 6bd1e94c91..c356dba309 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1210,3 +1210,44 @@ desired length. It can also generate their corresponding hashes for a given
encryption algorithm if so desired.")
(home-page "https://github.com/khorben/makepasswd")
(license license:gpl3))))
+
+(define-public pass-tomb
+ (package
+ (name "pass-tomb")
+ (version "1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/roddhjav/pass-tomb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qj7vx7svk1ljwihj3kv310k17mafnf919n30n4qn1yxmmsvj924"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "PREFIX=" out)
+ (string-append "BASHCOMPDIR=" out "/etc/bash_completion.d")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-tomb-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((tomb (assoc-ref inputs "tomb")))
+ (substitute* "tomb.bash"
+ ((":-tomb")
+ (string-append ":-" tomb "/bin/tomb"))))))
+ (delete 'configure)
+ ;; No test suite
+ (delete 'check))))
+ (inputs
+ `(("tomb" ,tomb)))
+ (home-page "https://github.com/roddhjav/pass-tomb")
+ (synopsis "Pass extension keeping the tree of passwords encrypted")
+ (description "Pass-tomb provides a convenient solution to put your
+password store in a Tomb and then keep your password tree encrypted when you
+are not using it. It uses the same GPG key to encrypt passwords and tomb,
+therefore you don't need to manage more key or secret. Moreover, you can ask
+pass-tomb to automatically close your store after a given time.")
+ (license license:gpl3+)))
--
2.26.2
J
J
Julien Lepiller wrote on 11 Jul 2020 23:51
Re: [bug#41964] [PATCH 0/2] Add pass-tomb.
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 41964-done@debbugs.gnu.org)
20200711235045.19354852@tachikoma.lepiller.eu
Le Sat, 20 Jun 2020 17:09:12 +0200,
Brice Waegeneire <brice@waegenei.re> a écrit :

Toggle quote (10 lines)
> Brice Waegeneire (2):
> gnu: tomb: Add 'getent' to PATH.
> gnu: Add 'pass-tomb'.
>
> gnu/packages/crypto.scm | 3 ++-
> gnu/packages/password-utils.scm | 41
> +++++++++++++++++++++++++++++++++ 2 files changed, 43 insertions(+),
> 1 deletion(-)
>

Pushed as 12d69fc5745759b11d6e19cdcdad64d34ecd9dd4 and
36a1925f21ee6787d8b80025f1b96238309f4b96.

I tried to enable tests in pass-tomb (because there were actually
tests) but it didn't work because it checks there is no swap partition,
and tries to use /tmp/zsh which is not accessible in the build
container. One of the test dependencies was kcov, which I added in a
separate patch, but ended up not using, as it's only required for tests
and we disable them.

Note that the usual way to disable tests is by using the argument

#:tests? #f

instead of deleting the check phase. I've fixed that before pushing.

Thanks for working on this!
Closed
D
D
Danny Milosavljevic wrote on 17 Jul 2020 20:52
Re: [bug#41964] [PATCH 2/2] gnu: Add 'pass-tomb'.
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 41964@debbugs.gnu.org)
20200717205243.6028a334@scratchpost.org
On Sat, 20 Jun 2020 17:11:11 +0200
Brice Waegeneire <brice@waegenei.re> wrote:

Toggle quote (9 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'set-tomb-path
> + (lambda* (#:key inputs #:allow-other-keys)
> + (let ((tomb (assoc-ref inputs "tomb")))
> + (substitute* "tomb.bash"
> + ((":-tomb")
> + (string-append ":-" tomb "/bin/tomb"))))))

Phase should end in #t.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl8R83sACgkQ5xo1VCww
uqWobwf9FvFx4EJ/JKP18mDqA/ALh6OSgK1Q2UqE6g+XPOhdQptOGqnaIgYrgSFd
M74FyAdWQCBtsU0hFH7lBEFESP8q/WGy8iHmex9E8iMGbW2C5gUjD4mfy5xBMPAp
AdSqU/zq2oZYGBU6dq7pdMOe5EyPvFG1+rcXKytEnNeU+3lSmJ7SEuzCRjzcNoNX
RQpHYj6G/qNbgKej9bQPyz2NyMqkbsiT+guPpxiTnwf90Z/THKfE94/ArCM+MKf6
JsH6yGQUt/HPrzva4YvgS+zIhD1YWXsIiwcGlHZLt96kTvPqrgdZjxUuGO6/X368
AB9eWFbxrvFbbRuCQ05rileJAvj1fQ==
=ZI2g
-----END PGP SIGNATURE-----


D
D
Danny Milosavljevic wrote on 17 Jul 2020 20:53
Re: [bug#41964] [PATCH 1/2] gnu: tomb: Add 'getent' to PATH.
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 41964@debbugs.gnu.org)
20200717205300.3e1678dc@scratchpost.org
LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl8R84wACgkQ5xo1VCww
uqVdbwf/dlFR2BO+KLTg0Escn1W0jvSyuJJs/v/T7Yf/Mn8md74sUzIcSySdmYdP
MLenafnxvJGDrC7eAaOtyXebv580kO+DgJJaQznBtfqQrygnGfo77W7RnI7WREv0
py/p82z6m2+UA6LqIibd1WK+9y+UT9lXFxaH73xVu5W+iFe07U0EX/t2bNkeXcgO
tG9VZSx1Pz1rcfnSLgVvdA1QoOQT7PUJAIASI3sSs+bF6k98b9khXnXecwkfaQ0d
WDAG15f8ejSTt64h7TUCYlwUlaB5frlLRcgPKpmefKDnizPV+84pIgprpTNagFQp
oznPRd51h3gW4AcSX+2LDWyDq2A1QQ==
=lMEe
-----END PGP SIGNATURE-----


?