[PATCH] gnu: Add ebusd.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 15 Jun 2020 17:42
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20200615154243.22617-1-dannym@scratchpost.org
* gnu/packages/embedded.scm (ebusd): New variable.
---
gnu/packages/embedded.scm | 47 +++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 9be1065de2..2c5a8991fc 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1352,3 +1352,50 @@ simplifies configuration and is also pluggable: you can write your own west
this feature to provide conveniences for building applications, flashing and
debugging them, and more.")
(license license:expat)))
+
+;; TODO: Support MQTT.
+(define-public ebusd
+ (package
+ (name "ebusd")
+ (version "3.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/john30/ebusd.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0iva70bam7wdx60bpd3an9kxr28zxlvp3vprivgqshwwdhqa0hzp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-config
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((config-destination
+ (string-append (assoc-ref outputs "out")
+ "/share/ebusd")))
+ (copy-recursively (string-append (assoc-ref inputs "config")
+ "/ebusd-2.1.x")
+ config-destination)
+ #t))))))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("config"
+ ,(origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/john30/ebusd-configuration.git")
+ (commit "666c0f6b9c4d7545eff7f43ab28a1c7baeab7913")))
+ (file-name "config-checkout")
+ (sha256
+ (base32
+ "0yxnx8p4lbk614l16854r9s9d8s9c7ixgczfs8mph94xz0wkda7x"))))))
+ (synopsis "Daemon for communicating with eBUS devices")
+ (description "This package provides @command{ebusd}, a daemon for
+handling communication with eBUS devices connected to a 2-wire bus system
+(\"energy bus\" used by numerous heating systems).")
+ (home-page "https://ebusd.eu/")
+ (license license:gpl3+)))
M
M
Mathieu Othacehe wrote on 21 Jun 2020 11:57
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 41873@debbugs.gnu.org)
87k1004u88.fsf@gnu.org
Hey Danny,

Toggle quote (4 lines)
> + (uri (git-reference
> + (url "https://github.com/john30/ebusd.git")
> + (commit (string-append "v" version))))

Indentation is off here and a bit below.

Toggle quote (3 lines)
> + (copy-recursively (string-append (assoc-ref inputs "config")
> + "/ebusd-2.1.x")

Maybe you could use the "latest" file here?

Toggle quote (5 lines)
> + (synopsis "Daemon for communicating with eBUS devices")
> + (description "This package provides @command{ebusd}, a daemon for
> +handling communication with eBUS devices connected to a 2-wire bus system
> +(\"energy bus\" used by numerous heating systems).")

I think you can turn this into a full sentence.

Otherwise, it look fine.

Thanks,

Mathieu
D
D
Danny Milosavljevic wrote on 7 Sep 2020 00:20
Re: [PATCH] gnu: Add ebusd.
(address . 41873-done@debbugs.gnu.org)
20200907002053.54beaae7@scratchpost.org
Pushed to guix master as commit bbf8a309662c8378b817cfb760447cd6f8ce59e8.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl9VYMUACgkQ5xo1VCww
uqVacAf+I9yN+ztumV0rxlg7JegAAlkKMqZhsZr8ZQdndghj8RGIlYw9RtRDBhua
mWn/ExxcpcI9vRYQLZ0ynwSXVaTxtvVfPvWkHJrcIuDjHDH1Ah2+6uC5UKRIqPGD
s3DR53He0dGF8gZ7vyResdQ8mXcR+jU8ck8bzJpcVHB25Bj4kOq6ts2HF0Aq+hpS
1GDUltWQqbWehK0KtZnzDl+r+ITMUtfu9SJVLCtKHTDoEZb601IL7FcShng8Gx2F
SekVgrkBQhXuK/h3SQuY0tctuVxA6KEmQa3p5XUa70gu3m9L3IoEQF0THfL+Acc9
dyFBplUPxa+0uu7kNzc3X9xviHjylg==
=3t0Y
-----END PGP SIGNATURE-----


Closed
?