[PATCH] news: Add entry for script execution via "guix repl".

  • Done
  • quality assurance status badge
Details
3 participants
  • Konrad Hinsen
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
Konrad Hinsen
Severity
normal
K
K
Konrad Hinsen wrote on 15 Jun 2020 09:35
(address . guix-patches@gnu.org)
m1r1ughjdf.fsf@fastmail.net
* etc/news.scm: Add entry.
---
etc/news.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/etc/news.scm b/etc/news.scm
index 6bf88ccb44..0e72c5cceb 100644
--- a/etc/news.scm
+++ b/etc/news.scm
@@ -13,6 +13,45 @@
(channel-news
(version 0)
+ (entry (commit "c924e541390f9595d819edc33c19d979917c15ec")
+ (title (en "@command{guix repl} adds support for running Guile scripts")
+ (de "@command{guix repl} kann Guile-Skripte ausführen")
+ (fr "@command{guix repl} permet d'exécuter des scripts en langage Guile"))
+ (body
+ (en "The @command{guix repl} command can now be used to run
+Guile scripts. Compared to just launching the @command{guile} command,
+@command{guix repl} guarantees that all the Guix modules and all its
+dependencies are available in the search path. Scripts are run like this:
+
+@example
+guix repl -- my-script,scm --option1 --option2=option-arg arg1 arg2
+@end example
+
+Run @command{info \"(guix) Invoking guix repl\"} for more information.")
+ (de "Der Befehl @command{guix repl} kann jetzt zur Ausführung von
+Guile-Skripten verwendet werden. Im Vergleich zum Befehl
+@command{guile} garantiert @command{guix repl}, dass alle Guix-Module und
+alle seine Abhängigkeiten im Suchpfad verfügbar sind. Skripte werden wie
+folgt ausgeführt:
+
+@Beispiel
+guix repl -- my-script,scm --option1 --option2 --option2=option-arg arg1 arg2
+@End-Beispiel
+
+Weitere Informationen erhalten Sie mit
+@command{info \"(guix) ausführen und guix repl\"}.")
+ (fr "La commande @command{guix repl} peut maintenant être utilisée
+pour exécuter des scripts en langage Guile. Par rapport au simple lancement
+de la commande @command{guile}, @command{guix repl} garantit que tous les
+modules Guix et toutes ses dépendances sont disponibles dans le chemin
+de recherche. Les scripts sont exécutés comme ceci :
+
+@exemple
+guix repl -- my-script,scm --option1 --option2=option-arg arg1 arg2
+Exemple @end
+
+Exécutez @command{info \"(guix) Invoquant guix repl\"} pour plus d'informations.")))
+
(entry (commit "b460ba7992a0b4af2ddb5927dcf062784539ef7b")
(title (en "Add support to boot from a Btrfs subvolume")
(de "Unterstützung für Systemstart von einem
--
2.26.2
L
L
Ludovic Courtès wrote on 15 Jun 2020 09:51
(name . Konrad Hinsen)(address . konrad.hinsen@fastmail.net)(address . 41867-done@debbugs.gnu.org)
878sgo3gwx.fsf@gnu.org
Morning,

Konrad Hinsen <konrad.hinsen@fastmail.net> skribis:

Toggle quote (2 lines)
> * etc/news.scm: Add entry.

Applied with the changes below, thanks!

Ludo’.
Toggle diff (34 lines)
diff --git a/etc/news.scm b/etc/news.scm
index 0e72c5cceb..d037734013 100644
--- a/etc/news.scm
+++ b/etc/news.scm
@@ -34,23 +34,23 @@ Guile-Skripten verwendet werden. Im Vergleich zum Befehl
alle seine Abhängigkeiten im Suchpfad verfügbar sind. Skripte werden wie
folgt ausgeführt:
-@Beispiel
+@example
guix repl -- my-script,scm --option1 --option2 --option2=option-arg arg1 arg2
-@End-Beispiel
+@end example
Weitere Informationen erhalten Sie mit
-@command{info \"(guix) ausführen und guix repl\"}.")
+@command{info \"(guix.de) Aufruf von guix repl\"}.")
(fr "La commande @command{guix repl} peut maintenant être utilisée
pour exécuter des scripts en langage Guile. Par rapport au simple lancement
de la commande @command{guile}, @command{guix repl} garantit que tous les
modules Guix et toutes ses dépendances sont disponibles dans le chemin
de recherche. Les scripts sont exécutés comme ceci :
-@exemple
+@example
guix repl -- my-script,scm --option1 --option2=option-arg arg1 arg2
-Exemple @end
+@end example
-Exécutez @command{info \"(guix) Invoquant guix repl\"} pour plus d'informations.")))
+Exécutez @command{info \"(guix.fr) Invoquer guix repl\"} pour plus d'informations.")))
(entry (commit "b460ba7992a0b4af2ddb5927dcf062784539ef7b")
(title (en "Add support to boot from a Btrfs subvolume")
Closed
Z
Z
zimoun wrote on 16 Jun 2020 10:25
86o8pjs9hj.fsf@gmail.com
Dear Konrad,

On Mon, 15 Jun 2020 at 09:35, Konrad Hinsen <konrad.hinsen@fastmail.net> wrote:
Toggle quote (2 lines)
> * etc/news.scm: Add entry.

[...]

Toggle quote (4 lines)
> +@example
> +guix repl -- my-script,scm --option1 --option2=option-arg arg1 arg2
> +@end example

That's awesome!!
Thank you.

All the best,
simon
?