[PATCH] services: Fix gdm-autologin pam service.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex Griffin
  • Marius Bakke
Owner
unassigned
Submitted by
Alex Griffin
Severity
normal
A
A
Alex Griffin wrote on 15 Jun 2020 01:24
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
-CkK6xCmE4SCUTOS1nupxqCONmgZkMEUjRUNRiBXxpuT9bRhVj74k6fTGlkQg4xu8r6BAWNhSpod7a0vH4ufBiNT1GR_fxHbc0U5Vqr-xMw=@ajgrf.com
This patch fixes GDM's auto-login feature.

See the discussions in #35674 and #40411. It works for me, but I don't want to just commit it because I don't really understand PAM. (Then again, who does?)

--
Alex Griffin
From 2d07fab70a4051189e013a20a95cfbb08c904803 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sun, 14 Jun 2020 17:58:47 -0500
Subject: [PATCH] services: Fix gdm-autologin pam service.

* gnu/services/xorg.scm (gdm-pam-service): Mark pam_gdm.so optional.
---
gnu/services/xorg.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
index ca39994516..4590709187 100644
--- a/gnu/services/xorg.scm
+++ b/gnu/services/xorg.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2020 shtwzrd <shtwzrd@protonmail.com>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
+;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -925,7 +926,7 @@ the GNOME desktop environment.")
(inherit (unix-pam-service "gdm-autologin"
#:login-uid? #t))
(auth (list (pam-entry
- (control "[success=ok default=1]")
+ (control "optional")
(module (file-append (gdm-configuration-gdm config)
"/lib/security/pam_gdm.so")))
(pam-entry
--
2.26.2
M
M
Marius Bakke wrote on 2 Oct 2020 19:54
875z7sh5t7.fsf@gnu.org
Alex Griffin via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (4 lines)
> This patch fixes GDM's auto-login feature.
>
> See the discussions in #35674 and #40411. It works for me, but I don't want to just commit it because I don't really understand PAM. (Then again, who does?)

[...]

Toggle quote (7 lines)
> @@ -925,7 +926,7 @@ the GNOME desktop environment.")
> (inherit (unix-pam-service "gdm-autologin"
> #:login-uid? #t))
> (auth (list (pam-entry
> - (control "[success=ok default=1]")
> + (control "optional")

This is one of the alternatives Timothy proposed in #35674 back in May
last year(!). As long as GDM still rejects wrong or blank passwords, I
think it is good to go.

It would be good to get it in 1.2.0. :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl93aVQACgkQoqBt8qM6
VPqRHggArQUeDOH1f44wmrz/vDGIKmHgC2OK0/+u35Z0ucRyV8g1qoHnL/qePRlD
CFIYE9P5DTeC+UZ7ndyJF072cRJS3rLYBSHS/oOWbjrHhF29XarYhGtyoYKapUyA
0W36+56x1Fm7d5HCB6sTZFPcyceMYNXF3292296v+n3iIebqIv2LcA83LWNXefEj
Rayuf1BHoF09ywvV8gk/JaBiZXRzrJt8NOgfRQlUtu4Q+y/MSgA4coSbclKZvuSX
2KtQRYilgSyY633aeQKEp3ylWEbxRuwKa6SJ2aIWmfYlIUMmez+De1DgJq4Z8W7J
rl41R6bO8uJsYk8Dur99U2cwv0yoqg==
=R2ue
-----END PGP SIGNATURE-----

A
A
Alex Griffin wrote on 7 Oct 2020 21:12
(name . 41863@debbugs.gnu.org)(address . 41863@debbugs.gnu.org)
K6RV2CtLbhY6qSnWHocTk-Bu0rCBTxsuzioDTLA8s6Yecc-tvdGIbkmGRUwxlwwEsM1f0FTqO28GIpjUqznSR2sLJKjrTcsgakUQ_65HtvQ=@ajgrf.com
Fixed in commit d8258177fe.

--
Alex Griffin

??????? Original Message ???????

On Wednesday, October 7th, 2020 at 7:11 PM, Alex Griffin <a@ajgrf.com> wrote:

Toggle quote (36 lines)
> Fixed in commit d8258177fe.
>
> --
> Alex Griffin
>
> ??????? Original Message ???????
>
> On Friday, October 2nd, 2020 at 5:54 PM, Marius Bakke marius@gnu.org wrote:
>
> > Alex Griffin via Guix-patches via writes:
> >
> > > This patch fixes GDM's auto-login feature.
> >
> > > See the discussions in #35674 and #40411. It works for me, but I don't want to just commit it because I don't really understand PAM. (Then again, who does?)
> >
> > [...]
> >
> > > @@ -925,7 +926,7 @@ the GNOME desktop environment.")
> >
> > > (inherit (unix-pam-service "gdm-autologin"
> >
> > > #:login-uid? #t))
> >
> > > (auth (list (pam-entry
> >
> > > - (control "[success=ok default=1]")
> >
> > > - (control "optional")
> >
> > This is one of the alternatives Timothy proposed in #35674 back in May
> >
> > last year(!). As long as GDM still rejects wrong or blank passwords, I
> >
> > think it is good to go.
> >
> > It would be good to get it in 1.2.0. :-)
A
A
Alex Griffin wrote on 7 Oct 2020 21:13
(name . 41863-done@debbugs.gnu.org)(address . 41863-done@debbugs.gnu.org)
cdppGo7BWiqTlY-eMkU4oWa13qCrvRlsm4diY9FWzOICH_V7u6Qk7VOFO-athHPw3GB8l-abgtMVtVJ4lgO00vw8vQxZYbW1VjJ9Xg8-F6g=@ajgrf.com
Fixed in commit d8258177fe.

--
Alex Griffin

??????? Original Message ???????

On Wednesday, October 7th, 2020 at 7:12 PM, Alex Griffin <a@ajgrf.com> wrote:

Toggle quote (46 lines)
> Fixed in commit d8258177fe.
>
> --
> Alex Griffin
>
> ??????? Original Message ???????
>
> On Wednesday, October 7th, 2020 at 7:11 PM, Alex Griffin a@ajgrf.com wrote:
>
> > Fixed in commit d8258177fe.
> >
> > --
> >
> > Alex Griffin
> >
> > ??????? Original Message ???????
> >
> > On Friday, October 2nd, 2020 at 5:54 PM, Marius Bakke marius@gnu.org wrote:
> >
> > > Alex Griffin via Guix-patches via writes:
> > >
> > > > This patch fixes GDM's auto-login feature.
> > >
> > > > See the discussions in #35674 and #40411. It works for me, but I don't want to just commit it because I don't really understand PAM. (Then again, who does?)
> > >
> > > [...]
> > >
> > > > @@ -925,7 +926,7 @@ the GNOME desktop environment.")
> > >
> > > > (inherit (unix-pam-service "gdm-autologin"
> > >
> > > > #:login-uid? #t))
> > >
> > > > (auth (list (pam-entry
> > >
> > > > - (control "[success=ok default=1]")
> > >
> > > > - (control "optional")
> > >
> > > This is one of the alternatives Timothy proposed in #35674 back in May
> > >
> > > last year(!). As long as GDM still rejects wrong or blank passwords, I
> > >
> > > think it is good to go.
> > >
> > > It would be good to get it in 1.2.0. :-)
Closed
?