[PATCH] activation: Fix function call for system activation

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Royce Strange
Owner
unassigned
Submitted by
Royce Strange
Severity
normal
R
R
Royce Strange wrote on 9 Jun 2020 04:53
(address . guix-patches@gnu.org)
20200609025330.30555-1-royball@disroot.org
* gnu/build/activation.scm (boot-time-system):
Evaluate the linux-command-line thunk for linux systems to boot
---
gnu/build/activation.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/build/activation.scm b/gnu/build/activation.scm
index b915e6bb67..4b67926e88 100644
--- a/gnu/build/activation.scm
+++ b/gnu/build/activation.scm
@@ -321,7 +321,7 @@ improvement."
(define (boot-time-system)
"Return the '--system' argument passed on the kernel command line."
(find-long-option "--system" (if (string-contains %host-type "linux-gnu")
- linux-command-line
+ (linux-command-line)
(command-line))))
(define* (activate-current-system
--
2.26.2
L
L
Ludovic Courtès wrote on 9 Jun 2020 09:40
(name . Royce Strange)(address . royball@disroot.org)(address . 41771-done@debbugs.gnu.org)
87h7vkoff2.fsf@gnu.org
Hi,

Royce Strange <royball@disroot.org> skribis:

Toggle quote (3 lines)
> * gnu/build/activation.scm (boot-time-system):
> Evaluate the linux-command-line thunk for linux systems to boot

Applied, thanks for the quick fix!

Ludo’.
Closed
?