[PATCH] system: vm: Fix missing imported module

  • Done
  • quality assurance status badge
Details
2 participants
  • maxim.cournoyer
  • Royce Strange
Owner
unassigned
Submitted by
Royce Strange
Severity
normal
R
R
Royce Strange wrote on 9 Jun 2020 03:13
(address . guix-patches@gnu.org)
20200609011310.24284-1-royball@disroot.org
* gnu/system/vm.scm (qemu-image):
Make sure (gnu build hurd-boot) gets imported.
---
gnu/system/vm.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index 686e56348d..f2b6b71b4d 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -337,6 +337,7 @@ system that is passed to 'populate-root-file-system'."
(with-extensions gcrypt-sqlite3&co
(with-imported-modules `(,@(source-module-closure '((gnu build vm)
(gnu build bootloader)
+ (gnu build hurd-boot)
(guix store database)
(guix build utils))
#:select? not-config?)
--
2.26.2
M
M
maxim.cournoyer wrote on 9 Jun 2020 07:33
(name . Royce Strange)(address . royball@disroot.org)(address . 41770-done@debbugs.gnu.org)
874krkkdko.fsf@hurd.i-did-not-set--mail-host-address--so-tickle-me
Hello!

Royce Strange <royball@disroot.org> writes:

Toggle quote (19 lines)
> * gnu/system/vm.scm (qemu-image):
> Make sure (gnu build hurd-boot) gets imported.
> ---
> gnu/system/vm.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
> index 686e56348d..f2b6b71b4d 100644
> --- a/gnu/system/vm.scm
> +++ b/gnu/system/vm.scm
> @@ -337,6 +337,7 @@ system that is passed to 'populate-root-file-system'."
> (with-extensions gcrypt-sqlite3&co
> (with-imported-modules `(,@(source-module-closure '((gnu build vm)
> (gnu build bootloader)
> + (gnu build hurd-boot)
> (guix store database)
> (guix build utils))
> #:select? not-config?)

I've retouched the commit message slightly and pushed! Thank you.

Maxim
Closed
?