[PATCH] gnu: Add emacs-meson-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Fredrik Salomonsson
Owner
unassigned
Submitted by
Fredrik Salomonsson
Severity
normal
F
F
Fredrik Salomonsson wrote on 4 Jun 2020 21:42
(address . guix-patches@gnu.org)(name . Fredrik Salomonsson)(address . plattfot@gmail.com)
20200604194230.11212-1-plattfot@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-meson-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 87797aabcc..4d32b9258a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22671,6 +22671,35 @@ two user-defined directories, as well as using more descriptive names for
files and subdirectories when appropriate.")
(license license:gpl3+)))
+(define-public emacs-meson-mode
+ (package
+ (name "emacs-meson-mode")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wentasah/meson-mode.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1720b3hpfqd989zrgcns51jbjrv4vzl9di9mccl55vkmkbqzfin0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/wentasah/meson-mode")
+ (synopsis "Major mode for the Meson build system files")
+ (description
+ "This is an emacs major mode for Meson build system files. Syntax
+highlighting works reliably. Indentation works too, but there are probably
+cases where it breaks. Simple completion is supported via
+@code{completion-at-point}. To start completion, use either @kbd{C-M-i} or
+install completion frameworks such as @code{company}. To enable
+@code{company}, add the following to your @file{init.el}:
+@example
+(add-hook 'meson-mode-hook 'company-mode)
+@end example
+")
+ (license license:gpl3+)))
+
(define-public emacs-message-x
;; Use the latest commit, as there are no tagged releases.
(let ((commit "5524de7bbfdd8749c110f48de5afb024d9f83133")
--
2.26.2
N
N
Nicolas Goaziou wrote on 4 Jun 2020 22:17
(name . Fredrik Salomonsson)(address . plattfot@gmail.com)(address . 41717-done@debbugs.gnu.org)
877dwmr3fo.fsf@nicolasgoaziou.fr
Hello,

Fredrik Salomonsson <plattfot@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-meson-mode): New variable.

Applied with the change below. Thank you.

Toggle quote (12 lines)
> + (description
> + "This is an emacs major mode for Meson build system files. Syntax
> +highlighting works reliably. Indentation works too, but there are probably
> +cases where it breaks. Simple completion is supported via
> +@code{completion-at-point}. To start completion, use either @kbd{C-M-i} or
> +install completion frameworks such as @code{company}. To enable
> +@code{company}, add the following to your @file{init.el}:
> +@example
> +(add-hook 'meson-mode-hook 'company-mode)
> +@end example
> +")

I removed the last sentences, from "To start completion…", which belong
more to a manual than a package description.

Regards,

--
Nicolas Goaziou
Closed
?