[PATCH 0/3] Adds vala-language-server and updates vala

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ryan Prior
Owner
unassigned
Submitted by
Ryan Prior
Severity
normal
R
R
Ryan Prior wrote on 1 Jun 2020 07:56
(address . guix-patches@gnu.org)
20200601055649.988-1-rprior@protonmail.com
The vala-language-server package just got its first production release, so
here's a Guix package! It requires a newer version of Vala than what we have,
so I include an up-to-date package in this patch series. I split vala into
vala-0.46 (with alias vala) and vala-0.48 which is required by the language
server. Hopefully we can update the vala package to point to 0.48 during the
next major core update cycle.


Ryan Prior (3):
gnu: vala-0.46: Create alias for vala.
gnu: Add vala-0.48
gnu: Add vala-language-server.

gnu/packages/gnome-xyz.scm | 30 ++++++++++++++++++++++++++++++
gnu/packages/gnome.scm | 16 +++++++++++++++-
2 files changed, 45 insertions(+), 1 deletion(-)

--
2.26.2
R
R
Ryan Prior wrote on 1 Jun 2020 08:00
[PATCH 1/3] gnu: vala-0.46: Create alias for vala.
(address . 41639@debbugs.gnu.org)
20200601055949.1702-1-rprior@protonmail.com
* gnu/packages/gnome.scm (vala-0.46): New symbol.

The vala package is now an alias for vala-0.46.
---
gnu/packages/gnome.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index da69f1bdeb..fcc83e8e06 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3262,7 +3262,7 @@ engineering.")
passwords in the GNOME keyring.")
(license license:gpl2+)))
-(define-public vala
+(define-public vala-0.46
(package
(name "vala")
(version "0.46.5")
@@ -3307,6 +3307,8 @@ requirements and without using a different ABI compared to applications and
libraries written in C.")
(license license:lgpl2.1+)))
+(define-public vala vala-0.46)
+
(define-public vte
(package
(name "vte")
--
2.26.2
R
R
Ryan Prior wrote on 1 Jun 2020 08:00
[PATCH 2/3] gnu: Add vala-0.48
(address . 41639@debbugs.gnu.org)
20200601055949.1702-2-rprior@protonmail.com
* gnu/packages/gnome.scm (vala-0.48): New variable.
---
gnu/packages/gnome.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fcc83e8e06..ff9dad4d64 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3307,6 +3307,18 @@ requirements and without using a different ABI compared to applications and
libraries written in C.")
(license license:lgpl2.1+)))
+(define-public vala-0.48
+ (package/inherit vala-0.46
+ (version "0.48.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/vala/"
+ (version-major+minor version) "/"
+ "vala-" version ".tar.xz"))
+ (sha256
+ (base32
+ "01wppzgacdmp8dgf8047myz1any2yffmrhgl8kqf1q0c0gnhi3fi"))))))
+
(define-public vala vala-0.46)
(define-public vte
--
2.26.2
R
R
Ryan Prior wrote on 1 Jun 2020 08:00
[PATCH 3/3] gnu: Add vala-language-server.
(address . 41639@debbugs.gnu.org)
20200601055949.1702-3-rprior@protonmail.com
* gnu/packages/gnome-xyz.scm (vala-language-server): New variable.
---
gnu/packages/gnome-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 83e37f97b0..3c63829e99 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -585,3 +585,33 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
(description "Papirus is a fork of the icon theme Paper with a lot of new icons
and a few extra features.")
(license license:gpl3))))
+
+(define-public vala-language-server
+ (package
+ (name "vala-language-server")
+ (version "0.48")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/benwaffle/vala-language-server.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0chgfpci247skrvsiq1l8cas8sj2z6z42dlarka3df3qwxmh0if0"))))
+ (build-system meson-build-system)
+ (arguments '(#:glib-or-gtk? #t))
+ (inputs
+ `(("jsonrpc-glib" ,jsonrpc-glib)
+ ("libgee" ,libgee)
+ ("json-glib" ,json-glib)))
+ (native-inputs
+ `(("glib" ,glib)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala-0.48)))
+ (home-page "https://github.com/benwaffle/vala-language-server")
+ (synopsis "Language server for Vala")
+ (description "The Vala language server is an implementation of the Vala
+language specification for the Language Server Protocol (LSP). This tool is
+used in text editing environments to provide a complete and integrated
+feature-set for programming Vala effectively.")
+ (license license:lgpl2.1+)))
--
2.26.2
E
E
Efraim Flashner wrote on 2 Jun 2020 11:29
Re: [bug#41639] [PATCH 0/3] Adds vala-language-server and updates vala
(address . 41639@debbugs.gnu.org)
20200602092949.GJ7397@E5400
On Mon, Jun 01, 2020 at 05:56:59AM +0000, Ryan Prior via Guix-patches via wrote:
Toggle quote (17 lines)
> The vala-language-server package just got its first production release, so
> here's a Guix package! It requires a newer version of Vala than what we have,
> so I include an up-to-date package in this patch series. I split vala into
> vala-0.46 (with alias vala) and vala-0.48 which is required by the language
> server. Hopefully we can update the vala package to point to 0.48 during the
> next major core update cycle.
>
>
> Ryan Prior (3):
> gnu: vala-0.46: Create alias for vala.
> gnu: Add vala-0.48
> gnu: Add vala-language-server.
>
> gnu/packages/gnome-xyz.scm | 30 ++++++++++++++++++++++++++++++
> gnu/packages/gnome.scm | 16 +++++++++++++++-
> 2 files changed, 45 insertions(+), 1 deletion(-)

Does the vala-language-server need to be the same version as the vala
version it is built with? If so then you should add a note either with
vala or the language server noting which package it should be paired
with.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl7WHAkACgkQQarn3Mo9
g1H1sw//X1I9xDM2eg4PsWO1n7n0Nv/frWep2BtM37ONOz3MtzPBg35dB6CZ1lcL
/82eicg2qcP5wJgWM1lE/+q+q9OPIyrZYbyFSA7weBW6OrG6pQ/BMYOgiJjts9PY
Jb8F4QEezNrtBc8CLRpz2q4ugrJvwoDttTvG8T0oZ7nrVgWCQ+hIM2cVT5WPzMGg
tLOPtU8/bIoYUHu7nJ8ESiIPPbEWDcleOgpWjflpBvzMBndPLzT1jZhJPOawpPn/
aQxXCzk+eFyXEihmJWyBJz1ND2MpcPuM///onS3+2tK4KCGd6Ft8Wwv6+SD+gCMQ
uktRTP4d9N4G6h2sH1aJGevIUt8BQja7buLOGspSXVdo07HoZoYM8v/m6ETWNdpc
h0vVpUksrx6IvFKJxnDsfXqKv0dQ2q6iGHmQVVUqNTw73me9LIf3hAWTVN2nKewX
rGH2DD8E5ifgzbO6wpQ/p2ppEe/2H1AKP2EfFywYEwFfhXbbSX1aMMN1PHtR6Xqd
+jt4+WP8XU2+ONrb1sTAPjAU/466cH6RaFKGHy/nDSDrT1zn5NRxAGWxKj+qZmvv
+ccx7PUFarddUKx3vrj6lfC42U9uSlS3ngL2nRZO6LD0GaatAXCALRkHwo2LqTHm
U+6rouc4t3HKUeim/1cRHyXam3LQjfbjxqSBe3gP8Qoq/59op3Q=
=1OZR
-----END PGP SIGNATURE-----


R
R
Ryan Prior wrote on 3 Jun 2020 05:06
[PATCH 0/1] Added note to vala-language-server package
(address . 41639@debbugs.gnu.org)
20200603030611.19336-1-rprior@protonmail.com
Hi Efraim, thanks for the question. I did the research and added a relevant
note. What do you think?

Ryan Prior (1):
gnu: Add vala-language-server.

gnu/packages/gnome-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

--
2.26.2
R
R
Ryan Prior wrote on 3 Jun 2020 05:06
[PATCH 1/1] gnu: Add vala-language-server.
(address . 41639@debbugs.gnu.org)
20200603030611.19336-2-rprior@protonmail.com
* gnu/packages/gnome-xyz.scm (vala-language-server): New variable.
---
gnu/packages/gnome-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 83e37f97b0..03621b8ccf 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -585,3 +585,36 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
(description "Papirus is a fork of the icon theme Paper with a lot of new icons
and a few extra features.")
(license license:gpl3))))
+
+(define-public vala-language-server
+ (package
+ (name "vala-language-server")
+ ;; Note to maintainer: VLS must be built with a Vala toolchain the same
+ ;; version or newer. Therefore when you update this package you may need
+ ;; to update Vala too.
+ (version "0.48")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/benwaffle/vala-language-server.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0chgfpci247skrvsiq1l8cas8sj2z6z42dlarka3df3qwxmh0if0"))))
+ (build-system meson-build-system)
+ (arguments '(#:glib-or-gtk? #t))
+ (inputs
+ `(("jsonrpc-glib" ,jsonrpc-glib)
+ ("libgee" ,libgee)
+ ("json-glib" ,json-glib)))
+ (native-inputs
+ `(("glib" ,glib)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala-0.48)))
+ (home-page "https://github.com/benwaffle/vala-language-server")
+ (synopsis "Language server for Vala")
+ (description "The Vala language server is an implementation of the Vala
+language specification for the Language Server Protocol (LSP). This tool is
+used in text editing environments to provide a complete and integrated
+feature-set for programming Vala effectively.")
+ (license license:lgpl2.1+)))
--
2.26.2
E
E
Efraim Flashner wrote on 7 Jun 2020 17:19
(name . Ryan Prior)(address . rprior@protonmail.com)(address . 41639-done@debbugs.gnu.org)
20200607151925.GD24239@E5400
Patch 2 and 3 pushed. I'm not convinced (yet!) about renaming vala to
vala-0.46 and making a vala -> vala-0.46 renaming package.

On Wed, Jun 03, 2020 at 03:06:35AM +0000, Ryan Prior via Guix-patches via wrote:
Toggle quote (40 lines)
> * gnu/packages/gnome-xyz.scm (vala-language-server): New variable.
> ---
> gnu/packages/gnome-xyz.scm | 33 +++++++++++++++++++++++++++++++++
> 1 file changed, 33 insertions(+)
>
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index 83e37f97b0..03621b8ccf 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -585,3 +585,36 @@ dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
> (description "Papirus is a fork of the icon theme Paper with a lot of new icons
> and a few extra features.")
> (license license:gpl3))))
> +
> +(define-public vala-language-server
> + (package
> + (name "vala-language-server")
> + ;; Note to maintainer: VLS must be built with a Vala toolchain the same
> + ;; version or newer. Therefore when you update this package you may need
> + ;; to update Vala too.
> + (version "0.48")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/benwaffle/vala-language-server.git")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0chgfpci247skrvsiq1l8cas8sj2z6z42dlarka3df3qwxmh0if0"))))
> + (build-system meson-build-system)
> + (arguments '(#:glib-or-gtk? #t))
> + (inputs
> + `(("jsonrpc-glib" ,jsonrpc-glib)
> + ("libgee" ,libgee)
> + ("json-glib" ,json-glib)))
> + (native-inputs
> + `(("glib" ,glib)
> + ("pkg-config" ,pkg-config)
> + ("vala" ,vala-0.48)))

vala-language-server keeps a reference to glib and vala so I moved them
to inputs.

Toggle quote (15 lines)
> + (synopsis "Language server for Vala")
> + (description "The Vala language server is an implementation of the Vala
> +language specification for the Language Server Protocol (LSP). This tool is
> +used in text editing environments to provide a complete and integrated
> +feature-set for programming Vala effectively.")
> + (license license:lgpl2.1+)))
> --
> 2.26.2
>
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl7dBX0ACgkQQarn3Mo9
g1Fp5BAAgxg4sXFWBGyx2gmyXDioev5TaQUN3m08OoVRFlQV694bOseouyLSvj8x
BJJue0TCOfBFKOBLvYe7BX2Jx1UKnXTKqJb+p2pHBltt++0Zlg8IZt9bfwtxy+3f
zUS/DIWrpv9cAmn14xa77n3hwJ+/V14a/R8G4gOXbp7WJCuHsYR/UkUc5P6xclF3
4IZWqIUONLCA6UmDFqlxO5PuzkGI0mm0eDv75ja80+JHeEVI09xHalzsHtWD8kuY
NkmPmdKOZDbL8l0n70jyaICqKUrbwNFh/v3rSsslR9bDk80oQASRukqCeq7Pn3uc
wGkW81Hgagxyv/NzB7BgYRDXyctH63abrKf1OqZ+UN/2coGVGZWYN4ed4SWxsnvt
n8Q5nafHH9HaLgJYVJI/9avaeoovoq3Tn6S4O8fVxdM6VQScf//+dklQMIgU9K84
GIon5ElxC72ULzq3iUhFYWrM00IPRjqEqFKqvL3DwOMf9gBXe8nxh/krofmweeSP
GEz2NpR8zm9qLxXp6xCkGSk9Z60ZWPIh2p6mAg+oAF30ruWK72t0DfsmH/Os33Vy
67oSfuwVYGPnQMNHs5NUZGjoLUz2yR4BC0nZOs2ToJFfVCoyxlRMx/BJOPb94Yte
ZJhk87aGq2zhpQxhsk7XtLdeHZl21E+VxaWHZtqcXa+Eh0QvBMs=
=ACbA
-----END PGP SIGNATURE-----


Closed
?