broken asdf-build-system on some CL source packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Ji?í Špa?ek
Owner
unassigned
Submitted by
Ji?í Špa?ek
Severity
normal
J
J
Ji?í Špa?ek wrote on 31 May 2020 18:12
(address . bug-guix@gnu.org)
CA+VBW33=SguC3oCAZKbE+MtPA5XDFC6tCXwjpc5+rhs7YCDByw@mail.gmail.com
This problem manifests when installing cl-stumpwm package from
gnu/packages/wm.scm but other cl-* packages are likely to be affected
as well.

guix build cl-stumpwm fails with:

...
phase `unpack' succeeded after 0.0 seconds
starting phase `patch-usr-bin-file'
phase `patch-usr-bin-file' succeeded after 0.0 seconds
starting phase `patch-source-shebangs'
patch-shebang: ./autogen.sh: changing `/bin/sh' to
`/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/sh'
phase `patch-source-shebangs' succeeded after 0.0 seconds
starting phase `patch-generated-file-shebangs'
phase `patch-generated-file-shebangs' succeeded after 0.0 seconds
starting phase `install'
Backtrace:
8 (primitive-load "/gnu/store/3yrl560yxms43sqvyhv0g5xy4ki…")
In ice-9/eval.scm:
191:35 7 (_ #f)
In guix/build/gnu-build-system.scm:
838:2 6 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
In ice-9/boot-9.scm:
1736:10 5 (with-exception-handler _ _ #:unwind? _ # _)
In srfi/srfi-1.scm:
857:16 4 (every1 #<procedure 7ffff4b067c0 at guix/build/gnu-bui…> …)
In guix/build/gnu-build-system.scm:
847:30 3 (_ _)
In guix/build/asdf-build-system.scm:
128:24 2 (install #:inputs _ #:outputs _)
In unknown file:
1 (string-take "stumpwm" #f)
In ice-9/boot-9.scm:
1669:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1669:16: In procedure raise-exception:
Wrong type (expecting exact integer): #f

The problem seems to be caused by this commit
"
build: asdf-build-system: Use SBCL source in CL packages.
"


More specifically the way the parent-source is computed does not seem
handle packages that lack hyphen character in the name of their
parent.
+ (define parent-source
+ (and parent
+ (string-append parent "/share/common-lisp/"
+ (string-take parent-name
+ (string-index parent-name #\-))
+ "-source")))

My guix describe is:
Generation 10 May 31 2020 18:04:46 (current)
my-personal-packages 451bc28
branch: master
commit: 451bc28676242ff3ada89eae73b3a914836205e6
guix bf6438f
branch: master
commit: bf6438f46583003cfd851c9f8ff4104aa3107c4d


Thank you for advice,

Jiri
G
G
Guillaume Le Vaillant wrote on 29 Nov 2020 17:04
(name . Ji?í Špa?ek)(address . spacekj3@gmail.com)(address . 41631-done@debbugs.gnu.org)
877dq4b14j.fsf@yamatai
Ji?í Špa?ek <spacekj3@gmail.com> skribis:

Toggle quote (72 lines)
> This problem manifests when installing cl-stumpwm package from
> gnu/packages/wm.scm but other cl-* packages are likely to be affected
> as well.
>
> guix build cl-stumpwm fails with:
>
> ...
> phase `unpack' succeeded after 0.0 seconds
> starting phase `patch-usr-bin-file'
> phase `patch-usr-bin-file' succeeded after 0.0 seconds
> starting phase `patch-source-shebangs'
> patch-shebang: ./autogen.sh: changing `/bin/sh' to
> `/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/sh'
> phase `patch-source-shebangs' succeeded after 0.0 seconds
> starting phase `patch-generated-file-shebangs'
> phase `patch-generated-file-shebangs' succeeded after 0.0 seconds
> starting phase `install'
> Backtrace:
> 8 (primitive-load "/gnu/store/3yrl560yxms43sqvyhv0g5xy4ki…")
> In ice-9/eval.scm:
> 191:35 7 (_ #f)
> In guix/build/gnu-build-system.scm:
> 838:2 6 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
> In ice-9/boot-9.scm:
> 1736:10 5 (with-exception-handler _ _ #:unwind? _ # _)
> In srfi/srfi-1.scm:
> 857:16 4 (every1 #<procedure 7ffff4b067c0 at guix/build/gnu-bui…> …)
> In guix/build/gnu-build-system.scm:
> 847:30 3 (_ _)
> In guix/build/asdf-build-system.scm:
> 128:24 2 (install #:inputs _ #:outputs _)
> In unknown file:
> 1 (string-take "stumpwm" #f)
> In ice-9/boot-9.scm:
> 1669:16 0 (raise-exception _ #:continuable? _)
>
> ice-9/boot-9.scm:1669:16: In procedure raise-exception:
> Wrong type (expecting exact integer): #f
>
> The problem seems to be caused by this commit
> https://git.savannah.gnu.org/cgit/guix.git/commit/guix/build/asdf-build-system.scm?id=c3f1f09586967c3fefbb280014a4d46b57786696
> "
> build: asdf-build-system: Use SBCL source in CL packages.
> "
>
>
> More specifically the way the parent-source is computed does not seem
> handle packages that lack hyphen character in the name of their
> parent.
> + (define parent-source
> + (and parent
> + (string-append parent "/share/common-lisp/"
> + (string-take parent-name
> + (string-index parent-name #\-))
> + "-source")))
>
> My guix describe is:
> Generation 10 May 31 2020 18:04:46 (current)
> my-personal-packages 451bc28
> repository URL: https://github.com/geostarling/guix-packages.git
> branch: master
> commit: 451bc28676242ff3ada89eae73b3a914836205e6
> guix bf6438f
> repository URL: https://git.savannah.gnu.org/git/guix.git
> branch: master
> commit: bf6438f46583003cfd851c9f8ff4104aa3107c4d
>
>
> Thank you for advice,
>
> Jiri

This seems to be fixed on the master branch since commit
4dadb4977908028bb0651d43ed4813cc988db92d.
Closing.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCX8PGjA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j90yAEAmQIhDpTGgQuk2AP+/4LtPVQly965x23Gi3fh
bpwuvZcA/0Wcg8KGmzOGa0u6iSkzaszznKts0y1ACgrAOHfFXf1i
=V2v5
-----END PGP SIGNATURE-----

Closed
?