[PATCH] gnu: emacsy-minimal: inputs now use guile version 2.2

DoneSubmitted by Mike Rosset.
Details
2 participants
  • Marius Bakke
  • Mike Rosset
Owner
unassigned
Severity
normal
M
M
Mike Rosset wrote on 29 May 16:20 +0200
(address . guix-patches@gnu.org)(name . Mike Rosset)(address . mike.rosset@gmail.com)
20200529142046.43522-1-mike.rosset@gmail.com
* gnu/packages/guile-xyz.scm (emacsy-minimal): guile-lib and guile-readlinenow default to guile 3.0. This explicitly uses guile 2.2 versions.--- gnu/packages/guile-xyz.scm | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (17 lines)diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scmindex c7349af790..fc18c830e9 100644--- a/gnu/packages/guile-xyz.scm+++ b/gnu/packages/guile-xyz.scm@@ -2890,8 +2890,8 @@ in C using Gtk+-3 and WebKitGtk.") (build-system gnu-build-system) (inputs `(("guile" ,guile-2.2)- ("guile-lib" ,guile-lib)- ("guile-readline" ,guile-readline)))+ ("guile-lib" ,guile2.2-lib)+ ("guile-readline" ,guile2.2-readline))) (propagated-inputs '()) (arguments `(#:configure-flags '("--without-examples")-- 2.25.1
M
M
Marius Bakke wrote on 30 May 16:29 +0200
(name . Mike Rosset)(address . mike.rosset@gmail.com)
87a71pzeaw.fsf@gnu.org
Mike Rosset <mike.rosset@gmail.com> writes:
Toggle quote (3 lines)> * gnu/packages/guile-xyz.scm (emacsy-minimal): guile-lib and guile-readline> now default to guile 3.0. This explicitly uses guile 2.2 versions.
This should say (emacsy-minimal)[inputs]: ...
Fixed & applied, thank you!
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SbdcACgkQoqBt8qM6VProBAgAyKd4eXSULTGeKohN9tGxoH9U1+sl4daJqy5QxqPmNkl+SYv8mLtH/NrQJm8sbkiqxeOoQPXK2safJ05aGQpoyjkUTPNppJw0S1waXUJvAFK1/75pUypP9GZssO1Vl8wxPZBqbl+s3rVy9Wb+ND7xvYgje+J99uwiQH9adHUH8IKgCuWWVL+NTxIzz49lxRKq8AP33esbN12MeoHU2n3+9yaTCndZ8XR/FxTrJOtH9We72Pb++YV/4EwCX99x9f8iUR63nyOE5V2gUpGd81+SVo74QYO0fXvzQlNK54x0qr+IReuuaigWw9z+oP/P77uHwju/MTtLCGkcMOIu8dDkaA===ycbd-----END PGP SIGNATURE-----
Closed
?