fix tests failing on flowee package

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Tom Zander
Owner
unassigned
Submitted by
Tom Zander
Severity
normal
T
T
Tom Zander wrote on 27 May 2020 13:25
(address . guix-patches@gnu.org)
5645574.lOV4Wx5bFT@cherry
The comment to disable it is there, but only one of the two CMake lines that
enables this test was removed. So now really disable it.
--
Tom Zander
From bc9a3faa045579f48804cf42f958409e51cdfbf6 Mon Sep 17 00:00:00 2001
From: TomZ <tomz@freedommail.ch>
Date: Wed, 27 May 2020 13:21:58 +0200
Subject: [PATCH] gnu: flowee: Disable unpredictable test.

* gnu/packages/finance.scm (flowee): The test 'api' has some timeouts
which fail half the time in a build, so disable the test.
---
gnu/packages/finance.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f182057bb4..d176ac0660 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1531,7 +1531,7 @@ like Flowee the Hub, which Fulcrum connects to over RPC.")
(base32 "1vwvaxm3b71pfx8l4rrv06wqks6xdf2333w856b36s1bzvj53rhc"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF")
+ `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF" "-Denable_gui=false")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'make-qt-deterministic
@@ -1546,6 +1546,8 @@ like Flowee the Hub, which Fulcrum connects to over RPC.")
(lambda _
(substitute* "testing/CMakeLists.txt"
(("test_api") ""))
+ (substitute* "testing/CMakeLists.txt"
+ (("add_subdirectory\\(api\\)") ""))
#t))
(add-after 'configure 'set-build-info
;; Their genbuild.sh to generate a build.h fails in guix (no .git dir) .
--
2.25.1
T
T
Tom Zander wrote on 29 May 2020 15:27
use consistent arguments.
(address . 41562@debbugs.gnu.org)
3098426.mvXUDI8C0e@cherry
As suggested on IRC
--
Tom Zander
From bc9a3faa045579f48804cf42f958409e51cdfbf6 Mon Sep 17 00:00:00 2001
From: TomZ <tomz@freedommail.ch>
Date: Wed, 27 May 2020 13:21:58 +0200
Subject: [PATCH] gnu: flowee: Disable unpredictable test.

* gnu/packages/finance.scm (flowee): The test 'api' has some timeouts
which fail half the time in a build, so disable the test.
---
gnu/packages/finance.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f182057bb4..d176ac0660 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1531,7 +1531,7 @@ like Flowee the Hub, which Fulcrum connects to over RPC.")
(base32 "1vwvaxm3b71pfx8l4rrv06wqks6xdf2333w856b36s1bzvj53rhc"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF")
+ `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF" "-Denable_gui=OFF")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'make-qt-deterministic
@@ -1546,6 +1546,8 @@ like Flowee the Hub, which Fulcrum connects to over RPC.")
(lambda _
(substitute* "testing/CMakeLists.txt"
(("test_api") ""))
+ (substitute* "testing/CMakeLists.txt"
+ (("add_subdirectory\\(api\\)") ""))
#t))
(add-after 'configure 'set-build-info
;; Their genbuild.sh to generate a build.h fails in guix (no .git dir) .
--
2.25.1
M
M
Marius Bakke wrote on 29 May 2020 22:56
874kry4g0d.fsf@gnu.org
Tom Zander via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (11 lines)
> As suggested on IRC
> --
> Tom Zander
>>From bc9a3faa045579f48804cf42f958409e51cdfbf6 Mon Sep 17 00:00:00 2001
> From: TomZ <tomz@freedommail.ch>
> Date: Wed, 27 May 2020 13:21:58 +0200
> Subject: [PATCH] gnu: flowee: Disable unpredictable test.
>
> * gnu/packages/finance.scm (flowee): The test 'api' has some timeouts
> which fail half the time in a build, so disable the test.

Can you move this piece of information to a comment in the code?

Also, this should say (flowee)[arguments]: ...

Toggle quote (11 lines)
> diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
> index f182057bb4..d176ac0660 100644
> --- a/gnu/packages/finance.scm
> +++ b/gnu/packages/finance.scm
> @@ -1531,7 +1531,7 @@ like Flowee the Hub, which Fulcrum connects to over RPC.")
> (base32 "1vwvaxm3b71pfx8l4rrv06wqks6xdf2333w856b36s1bzvj53rhc"))))
> (build-system cmake-build-system)
> (arguments
> - `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF")
> + `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF" "-Denable_gui=OFF")

This should probably not be here?

Toggle quote (8 lines)
> #:phases
> (modify-phases %standard-phases
> (add-before 'configure 'make-qt-deterministic
> @@ -1546,6 +1546,8 @@ like Flowee the Hub, which Fulcrum connects to over RPC.")
> (lambda _
> (substitute* "testing/CMakeLists.txt"
> (("test_api") ""))

Can this be removed? It looks like it tries to do the same as your new
substitution below.

Toggle quote (7 lines)
> + (substitute* "testing/CMakeLists.txt"
> + (("add_subdirectory\\(api\\)") ""))
> #t))
> (add-after 'configure 'set-build-info
> ;; Their genbuild.sh to generate a build.h fails in guix (no .git dir) .
> --
> 2.25.1
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7RdvIACgkQoqBt8qM6
VPrj0Qf/UB7zSebDzKVLzH6XTxllF8LKu5Sz6e2amsgLJ9iMRBQwQEXPLV68x/we
nfS6RGZpQWmKyrgECTWKaA/bXpqFiVPSscmUKo8OqvHzMy62T8UMYsrZ8ANbela0
S3bNle2cIHwBViotsugLFvJNMJh2ecT/JcnN5CoWDa0/niMbdGWQOMPHZgOFBzG1
GlBY8d8akfOoq8p81eaP1n3JbR0MNDs2MvzFYUlQzUYJ9qjfyETfp5dHMChKt8HF
AFFSlY1PFS5LxHICB5EDQw0Z0uP4jLSm8c3YpRcE1FBpXegWvAL/VoNA/ohGs3Sj
q5JgHsCL7RFxKSyu8XWGYKyb2qKdjg==
=5lI6
-----END PGP SIGNATURE-----

T
T
Tom Zander wrote on 30 May 2020 09:40
2590775.irdbgypaU6@cherry
On vrijdag 29 mei 2020 22:56:18 CEST Marius Bakke wrote:
Toggle quote (15 lines)
> Tom Zander via Guix-patches via <guix-patches@gnu.org> writes:
> > As suggested on IRC
> >
> >>From bc9a3faa045579f48804cf42f958409e51cdfbf6 Mon Sep 17 00:00:00 2001
> >>
> > From: TomZ <tomz@freedommail.ch>
> > Date: Wed, 27 May 2020 13:21:58 +0200
> > Subject: [PATCH] gnu: flowee: Disable unpredictable test.
> >
> > * gnu/packages/finance.scm (flowee): The test 'api' has some timeouts
> >
> > which fail half the time in a build, so disable the test.
>
> Can you move this piece of information to a comment in the code?

Can you point to the file I find the code in, to add this to?

In case you mean the package description, its already there.

Toggle quote (19 lines)
> Also, this should say (flowee)[arguments]: ...
>
> > diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
> > index f182057bb4..d176ac0660 100644
> > --- a/gnu/packages/finance.scm
> > +++ b/gnu/packages/finance.scm
> > @@ -1531,7 +1531,7 @@ like Flowee the Hub, which Fulcrum connects to over
> > RPC.")>
> > (base32
> > "1vwvaxm3b71pfx8l4rrv06wqks6xdf2333w856b36s1bzvj53rhc"))))
> >
> > (build-system cmake-build-system)
> > (arguments
> >
> > - `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF")
> > + `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF"
> > "-Denable_gui=OFF")
> This should probably not be here?

Why not?

Toggle quote (17 lines)
> > #:phases
> >
> > (modify-phases %standard-phases
> >
> > (add-before 'configure 'make-qt-deterministic
> >
> > @@ -1546,6 +1546,8 @@ like Flowee the Hub, which Fulcrum connects to over
> > RPC.")>
> > (lambda _
> >
> > (substitute* "testing/CMakeLists.txt"
> >
> > (("test_api") ""))
>
> Can this be removed? It looks like it tries to do the same as your new
> substitution below.

Same file, two substitutes because there are two lines that need changing.
CMake blocks for 1) the actual subdir and 2) a build-dependency for 'make-
check'
Toggle quote (11 lines)
> > + (substitute* "testing/CMakeLists.txt"
> > + (("add_subdirectory\\(api\\)") ""))
> >
> > #t))
> >
> > (add-after 'configure 'set-build-info
> >
> > ;; Their genbuild.sh to generate a build.h fails in guix (no
> > .git dir) .


--
Tom Zander
M
M
Marius Bakke wrote on 30 May 2020 10:07
87o8q53kya.fsf@gnu.org
Tom Zander <tomz@freedommail.ch> writes:

Toggle quote (20 lines)
> On vrijdag 29 mei 2020 22:56:18 CEST Marius Bakke wrote:
>> Tom Zander via Guix-patches via <guix-patches@gnu.org> writes:
>> > As suggested on IRC
>> >
>> >>From bc9a3faa045579f48804cf42f958409e51cdfbf6 Mon Sep 17 00:00:00 2001
>> >>
>> > From: TomZ <tomz@freedommail.ch>
>> > Date: Wed, 27 May 2020 13:21:58 +0200
>> > Subject: [PATCH] gnu: flowee: Disable unpredictable test.
>> >
>> > * gnu/packages/finance.scm (flowee): The test 'api' has some timeouts
>> >
>> > which fail half the time in a build, so disable the test.
>>
>> Can you move this piece of information to a comment in the code?
>
> Can you point to the file I find the code in, to add this to?
>
> In case you mean the package description, its already there.

Oh you're right. In that case it would be clearer to change the commit
message to something like "really disable the black box tests".

Toggle quote (21 lines)
>> Also, this should say (flowee)[arguments]: ...
>>
>> > diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
>> > index f182057bb4..d176ac0660 100644
>> > --- a/gnu/packages/finance.scm
>> > +++ b/gnu/packages/finance.scm
>> > @@ -1531,7 +1531,7 @@ like Flowee the Hub, which Fulcrum connects to over
>> > RPC.")>
>> > (base32
>> > "1vwvaxm3b71pfx8l4rrv06wqks6xdf2333w856b36s1bzvj53rhc"))))
>> >
>> > (build-system cmake-build-system)
>> > (arguments
>> >
>> > - `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF")
>> > + `(#:configure-flags '("-Dbuild_tests=ON" "-Denable_gui=OFF"
>> > "-Denable_gui=OFF")
>> This should probably not be here?
>
> Why not?

I don't think passing -Denable_gui=OFF twice makes a difference. Does
it?

Toggle quote (21 lines)
>> > #:phases
>> >
>> > (modify-phases %standard-phases
>> >
>> > (add-before 'configure 'make-qt-deterministic
>> >
>> > @@ -1546,6 +1546,8 @@ like Flowee the Hub, which Fulcrum connects to over
>> > RPC.")>
>> > (lambda _
>> >
>> > (substitute* "testing/CMakeLists.txt"
>> >
>> > (("test_api") ""))
>>
>> Can this be removed? It looks like it tries to do the same as your new
>> substitution below.
>
> Same file, two substitutes because there are two lines that need changing.
> CMake blocks for 1) the actual subdir and 2) a build-dependency for 'make-
> check'

Makes sense, thanks for the explanation.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SFC0ACgkQoqBt8qM6
VPqvOQf+Jjwp3HCAFL/vUDFgqognlAd8sTnEroOFTp80GOPVoDsIWnBndb2TvtFD
1ZP3gaMDcY/gyYVntQNqBp7JdI8OeFSxWC/BbtInem2OPhZX06ocpFagatrSMv3X
CfW+i+jGq15IliDyoaoYtKYy/HbxOkcSTWR+yxdeCO5/A8IlZg4VwpQDsyOhSkhy
hZKpgv39fcW1gdQX59sTCvT1OZD88LYJtse8uivj9KyLwqzOqvSDbBczVZqehDPS
z40iCfnkZjNyhhnrhNcAlv4JfIvqAqwCy0LpiI3AxbSWN9DtPHdy/V3MJE/4qcim
/ST+O3RqTRPB2hmtkZDb2QzmIXIyxg==
=H1jA
-----END PGP SIGNATURE-----

T
T
Tom Zander wrote on 30 May 2020 14:21
3288784.e9J7NaK4W3@cherry
On zaterdag 30 mei 2020 10:07:09 CEST Marius Bakke wrote:
Toggle quote (3 lines)
> I don't think passing -Denable_gui=OFF twice makes a difference. Does
> it?

LOL, yeah, you are right. It doesn't.

Here is a new patch.
--
Tom Zander
From 093cb41d3dbef752b9f53ea410dc49fbba64fb95 Mon Sep 17 00:00:00 2001
From: TomZ <tomz@freedommail.ch>
Date: Wed, 27 May 2020 13:21:58 +0200
Subject: [PATCH] gnu: flowee: Really disable black-box test.

* gnu/packages/finance.scm (flowee): The test 'api' has some timeouts
which fail half the time in a build, so really disable the test.
---
gnu/packages/finance.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f182057bb4..28789c02d7 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1546,6 +1546,8 @@ like Flowee the Hub, which Fulcrum connects to over RPC.")
(lambda _
(substitute* "testing/CMakeLists.txt"
(("test_api") ""))
+ (substitute* "testing/CMakeLists.txt"
+ (("add_subdirectory\\(api\\)") ""))
#t))
(add-after 'configure 'set-build-info
;; Their genbuild.sh to generate a build.h fails in guix (no .git dir) .
--
2.25.1
M
M
Marius Bakke wrote on 30 May 2020 14:34
87y2p91u12.fsf@gnu.org
Tom Zander <tomz@freedommail.ch> writes:

Toggle quote (6 lines)
> On zaterdag 30 mei 2020 10:07:09 CEST Marius Bakke wrote:
>> I don't think passing -Denable_gui=OFF twice makes a difference. Does
>> it?
>
> LOL, yeah, you are right. It doesn't.

:-)

Toggle quote (2 lines)
> Here is a new patch.

I fixed the missing [arguments] in the commit message and applied.
Thank you!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SUrkACgkQoqBt8qM6
VPrB2QgAxu4S97ynQ9FBiBptf3bW+XLEWn0VqkobZM6VLI8FYHACZTYqTr7vBoMZ
i2Mbn+PIWEcBAxpssyYuBb4gEYQbFhxf6UVnAAsTSYNcjaEnwFsr05FcpIyMywFp
Vm2e6lZXUPJ+dyrVLhwkA+Z/oKh2BjxuKqW6RuRKd1NfTkhn/jFHrbywIiW6fti+
ZQzH2A+fFJDHNxZMCHUxJY5HQayW0O0U/4y8x0EmXHWEq3RYJhAFw2SfWzFn1PlC
wjdAt2yPRDj+RNj10MY9X4moAY5fsSA+wevecEuOIDzI2AWQo0Hzql3FGMLsAM2+
d1LnDne/8vbP+grKmmm1y1Nm3TWVkg==
=ZZck
-----END PGP SIGNATURE-----

Closed
?