[PATCH] gnu: Add spectacle-analyzer.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 27 May 2020 02:44
(name . Guix patches)(address . guix-patches@gnu.org)
801ede06b909043f31f507696993af64c2c80056.camel@zrythm.org
Hi,

This patch adds spectacle analyzer, an LV2 graphical spectrum analyzer
(audio plugin).

Thanks,
Alex
From 8fa72560cb851d63eff6c8c77a1bc05bd4f5c820 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 27 May 2020 01:41:39 +0100
Subject: [PATCH] gnu: Add spectacle-analyzer.

* gnu/packages/music.scm (spectacle-analyzer): new variable.
---
gnu/packages/music.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9cfda8e88c..4edb4dccf3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4935,6 +4935,47 @@ and debugging of event signal flows inside plugin graphs.")
(home-page "https://open-music-kontrollers.ch/lv2/sherlock/")
(license license:artistic2.0)))
+(define-public spectacle-analyzer
+ (package
+ (name "spectacle-analyzer")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jpcima/spectacle.git")
+ (commit (string-append "v" version))
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xiqa6z8g68lcvnwhws4j7c4py35r9d20cirrili7ycyp3a6149a"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("xxd" ,xxd)))
+ (inputs
+ `(("cairo", cairo)
+ ("fftw", fftw)
+ ("fftwf", fftwf)
+ ("jack", jack-1)
+ ("lv2", lv2)
+ ("mesa", mesa)))
+ (synopsis "Realtime graphical spectrum analyzer")
+ (description "Spectacle is a real-time spectral analyzer using the
+short-time Fourier transform, available as LV2 audio plugin and JACK client.")
+ (home-page "https://github.com/jpcima/spectacle")
+ (license license:isc)))
+
(define-public x42-plugins
(package
(name "x42-plugins")
--
2.26.2
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl7Nt9IACgkQAi6uQjE9
cPPNAAgAtLaBSXOiXKkYPc0lVWCU+SDkF1WY8YVe3GKSDMCRz4ix5R4WSqTVJc+Q
BA1j4kZvuFp2YlgllvsiwmojDuUY+rCS/M0EHT+FVeqQEUdwXw/SIbTpRWO394o8
Z6IbZYwli1+2P8RwJrmZUgNDNzugaR6WP0F6EhAHrqxJLKrWPc3EPKSIdF8Sx/1s
V0AQmUkPANcdXJIo3sfaFeMzv3c+06zFPQStNC2yzHMABqDZigypFURzQiTvaLxF
UbOCJTqztfkgfS1iHOVUK0FcHCIVXojFcAv8Uh2kKFE++fQQnSyeBxJpI/mDKJ7I
mqpV4nqXv4yghUfjcjh8Qej7RpU7xQ==
=j4MS
-----END PGP SIGNATURE-----


M
M
Marius Bakke wrote on 30 May 2020 13:45
87imgd3aut.fsf@gnu.org
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (5 lines)
> Hi,
>
> This patch adds spectacle analyzer, an LV2 graphical spectrum analyzer
> (audio plugin).

Thanks! Applied with the following changes:
Toggle diff (68 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 08b9c19ec9..ac149a804c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -141,6 +141,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
+ #:use-module (gnu packages vim) ;for 'xxd'
#:use-module (gnu packages web)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xml)
@@ -4945,17 +4946,17 @@ and debugging of event signal flows inside plugin graphs.")
(name "spectacle-analyzer")
(version "1.0")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jpcima/spectacle.git")
- (commit (string-append "v" version))
- ;; Bundles a specific commit of the DISTRHO plugin framework.
- (recursive? #t)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0xiqa6z8g68lcvnwhws4j7c4py35r9d20cirrili7ycyp3a6149a"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jpcima/spectacle.git")
+ (commit (string-append "v" version))
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xiqa6z8g68lcvnwhws4j7c4py35r9d20cirrili7ycyp3a6149a"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -4969,17 +4970,19 @@ and debugging of event signal flows inside plugin graphs.")
`(("pkg-config" ,pkg-config)
("xxd" ,xxd)))
(inputs
- `(("cairo", cairo)
- ("fftw", fftw)
- ("fftwf", fftwf)
- ("jack", jack-1)
- ("lv2", lv2)
- ("mesa", mesa)))
+ `(("cairo", cairo)
+ ("fftw", fftw)
+ ("fftwf", fftwf)
+ ("jack", jack-1)
+ ("lv2", lv2)
+ ("mesa", mesa)))
(synopsis "Realtime graphical spectrum analyzer")
(description "Spectacle is a real-time spectral analyzer using the
short-time Fourier transform, available as LV2 audio plugin and JACK client.")
(home-page "https://github.com/jpcima/spectacle")
- (license license:isc)))
+ ;; The project is licensed under the ISC license, and files in
+ ;; sources/plugin carry the Expat license.
+ (license (list license:isc license:expat))))
(define-public x42-plugins
(package
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SR0oACgkQoqBt8qM6
VPo4eQf+OYop/GwauNrCN8h77EFgKrtvlYJh23oWFppG33AVeUZc3WOX/ck72FVH
+ff8VhM5euYhRuYtuEqoAkK94lXXCq0WWSTVBQn5ZpUY3I4wvuNc6E44MPvwazmP
m5rPXJjOVPPbXPDzfXHeOiGuc0QVLIOUfbMDLQMWqWu0A9c+dObUMlgKtciMmV6o
2sHsZyOVK+yIVX4czd+NIkgquVDKFpm+CKkCge6G8/upeFwmBYxKFuQ5miDhIVN9
aYeG+2s2EDceeNdGZxcUOzuKvO+3WE8jVzPCrW4TCpwlmzpdvbrwTQti6o6TeAJ0
2Q1eUt7CmvSv6E0BnlbLdRra1mU7SQ==
=+jYv
-----END PGP SIGNATURE-----

Closed
?