[PATCH] gnu: Add emacs-fountain-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 23 May 2020 02:51
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20200523005141.52709-1-monego@posteo.net
* gnu/packages/emacs-xyz.scm (emacs-fountain-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d952e8ea6c..83e280a21b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -70,6 +70,7 @@
;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 pinoaffe <pinoaffe@airmail.cc>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23014,3 +23015,25 @@ files.")
sources. It features syntax highlighting, autocompletion, preview of buffer
or region and use of locally installed binaries.")
(license license:gpl3+)))
+
+(define-public emacs-fountain-mode
+ (package
+ (name "emacs-fountain-mode")
+ (version "3.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rnkn/fountain-mode")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08giwg0jwk8zzj2i4cm08322qr6znrnv9a49za7c6j47bykpwj6s"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-seq" ,emacs-seq)))
+ (home-page "https://github.com/rnkn/fountain-mode")
+ (synopsis "Major mode for screenwriting in Fountain markup")
+ (description "Fountain Mode is a scriptwriting program for GNU Emacs
+using the Fountain plain text markup format.")
+ (license license:gpl3+)))
--
2.20.1
N
N
Nicolas Goaziou wrote on 23 May 2020 09:20
(name . Vinicius Monego)(address . monego@posteo.net)(address . 41469-done@debbugs.gnu.org)
87y2pjce27.fsf@nicolasgoaziou.fr
Hello,

Vinicius Monego <monego@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-fountain-mode): New variable.

Thank you.

Toggle quote (3 lines)
> + (propagated-inputs
> + `(("emacs-seq" ,emacs-seq)))

I removed this, since the Emacs we package already includes `seq'
library.

Toggle quote (6 lines)
> + (synopsis "Major mode for screenwriting in Fountain markup")
> + (description "Fountain Mode is a scriptwriting program for GNU Emacs
> +using the Fountain plain text markup format.")
> + (license license:gpl3+)))

As a side note, it is best to avoid adding new packages at the end of
the files, since this is more likely to introduce merge conflicts (this
one didn't, tho).

Regards,

--
Nicolas Goaziou
Closed
?