[PATCH] gnu: Add python-flask-restx

  • Done
  • quality assurance status badge
Details
4 participants
  • Edouard Klein
  • Edouard Klein
  • Marius Bakke
  • Marius Bakke
Owner
unassigned
Submitted by
Edouard Klein
Severity
normal
E
E
Edouard Klein wrote on 22 May 2020 17:06
(address . guix-patches@gnu.org)
87a720au0g.fsf@alice.lan
* gnu/packages/python-web.scm (python-flask-restx): New variable.
* gnu/packages/python-check.scm (python-pytest-benchmark): New variable.
* gnu/packages/python-check.scm (python-pytest-flask): New variable.
* gnu/packages/python-xyz.scm (python-py-cpuinfo): New variable.
---
gnu/packages/python-check.scm | 49 +++++++++++++++++++++++++++++++++++
gnu/packages/python-web.scm | 49 +++++++++++++++++++++++++++++++++++
gnu/packages/python-xyz.scm | 20 ++++++++++++++
3 files changed, 118 insertions(+)

Toggle diff (150 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 50911673b2..70db8445ee 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -362,6 +362,55 @@ framework.")
framework.")
(license license:expat)))
+(define-public python-pytest-benchmark
+ (package
+ (name "python-pytest-benchmark")
+ (version "3.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-benchmark" version))
+ (sha256
+ (base32
+ "0a4mpb4j73dsyk47hd1prrjpfk4r458s102cn80rf253jg818hxd"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pathlib2" ,python-pathlib2)
+ ("python-py-cpuinfo" ,python-py-cpuinfo)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/ionelmc/pytest-benchmark")
+ (synopsis
+ "Pytest fixture for benchmarking code")
+ (description
+ "This pytest fixture will group the tests into rounds that are calibrated to
+the chosen timer.")
+ (license license:bsd-2)))
+
+(define-public python-pytest-flask
+ (package
+ (name "python-pytest-flask")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-flask" version))
+ (sha256
+ (base32
+ "1hln7mwgdzfi5ma0kqfsi768l7p24jhkw8l0imhifwy08nh7hmjd"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-flask" ,python-flask)
+ ("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-werkzeug" ,python-werkzeug)))
+ (home-page
+ "https://github.com/pytest-dev/pytest-flask")
+ (synopsis
+ "Pytest fixtures to test Flask applications")
+ (description
+ "This pytest plugin provides some fixtures to simplify app testing.")
+ (license license:expat)))
+
(define-public python-codacy-coverage
(package
(name "python-codacy-coverage")
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 00caf7f229..c1658052d8 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4024,3 +4024,52 @@ request/response web apps to larger, grown applications.")
than 326,000 known user-agents. Users can pick a random one, or select one
based on filters.")
(license license:expat)))
+
+(define-public python-flask-restx
+ (package
+ (name "python-flask-restx")
+ (version "0.2.0")
+ (source
+ ;; We fetch from the Git repo because there are no tests in the PyPI
+ ;; archive.
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/python-restx/flask-restx")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xf2vkmdngp9cv9klznizai4byxjcf0iqh1pr4b83nann0jxqwy7"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-aniso8601" ,python-aniso8601)
+ ("python-flask" ,python-flask)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-pytz" ,python-pytz)))
+ (native-inputs
+ `(("python-blinker" ,python-blinker)
+ ("python-faker" ,python-faker)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-benchmark"
+ ,python-pytest-benchmark)
+ ("python-pytest-flask" ,python-pytest-flask)
+ ("python-pytest-mock" ,python-pytest-mock)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "--benchmark-skip" "-k"
+ ;; Those tests need internet access
+ "not test_check and not test_valid_value_check"))))))
+ (home-page
+ "https://github.com/python-restx/flask-restx")
+ (synopsis
+ "Framework for fast, easy and documented API development with Flask")
+ (description
+ "Flask-RESTX is an extension for Flask that adds support for quickly building
+REST APIs. Flask-RESTX encourages best practices with minimal setup. If you are familiar
+ with Flask, Flask-RESTX should be easy to pick up. It provides a coherent collection of
+decorators and tools to describe your API and expose its documentation properly using
+Swagger.")
+ (license license:bsd-3)))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1b32e7e2a8..d8552276fc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20076,6 +20076,26 @@ It builds upon tmux's target and formats to create an object mapping to traverse
using multi-select lists, confirmations, free text prompts, completion, etc.")
(license license:expat)))
+(define-public python-py-cpuinfo
+ (package
+ (name "python-py-cpuinfo")
+ (version "5.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "py-cpuinfo" version))
+ (sha256
+ (base32
+ "0045y6832gqjg63jmw0qj2jwyypgjwr7sfdq3lfv49b6fxpl5xic"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/workhorsy/py-cpuinfo")
+ (synopsis "Get CPU info with pure Python 2 & 3")
+ (description
+ "This module returns the CPU info by using the best sources of information for
+ your OS.")
+ (license license:expat)))
+
(define-public python-daemux
(package
(name "python-daemux")
--
2.26.2
M
M
Marius Bakke wrote on 30 May 2020 15:04
87mu5p1smg.fsf@gnu.org
Edouard Klein <edk@beaver-labs.com> writes:

Toggle quote (5 lines)
> * gnu/packages/python-web.scm (python-flask-restx): New variable.
> * gnu/packages/python-check.scm (python-pytest-benchmark): New variable.
> * gnu/packages/python-check.scm (python-pytest-flask): New variable.
> * gnu/packages/python-xyz.scm (python-py-cpuinfo): New variable.

Can you split this into four different patches?

Please also fix the indentation on each package.

Toggle quote (25 lines)
> diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
> index 50911673b2..70db8445ee 100644
> --- a/gnu/packages/python-check.scm
> +++ b/gnu/packages/python-check.scm
> @@ -362,6 +362,55 @@ framework.")
> framework.")
> (license license:expat)))
>
> +(define-public python-pytest-benchmark
> + (package
> + (name "python-pytest-benchmark")
> + (version "3.2.3")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "pytest-benchmark" version))
> + (sha256
> + (base32
> + "0a4mpb4j73dsyk47hd1prrjpfk4r458s102cn80rf253jg818hxd"))))
> + (build-system python-build-system)
> + (native-inputs
> + `(("python-pathlib2" ,python-pathlib2)
> + ("python-py-cpuinfo" ,python-py-cpuinfo)
> + ("python-pytest" ,python-pytest)))

py-cpuinfo should probably be propagated according to setup.py.

Toggle quote (4 lines)
> + (synopsis
> + "Pytest fixture for benchmarking code")

This line break is unnecessary.

[...]

Toggle quote (22 lines)
> +(define-public python-pytest-flask
> + (package
> + (name "python-pytest-flask")
> + (version "1.0.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "pytest-flask" version))
> + (sha256
> + (base32
> + "1hln7mwgdzfi5ma0kqfsi768l7p24jhkw8l0imhifwy08nh7hmjd"))))
> + (build-system python-build-system)
> + (native-inputs
> + `(("python-flask" ,python-flask)
> + ("python-pytest" ,python-pytest)
> + ("python-setuptools-scm" ,python-setuptools-scm)
> + ("python-werkzeug" ,python-werkzeug)))
> + (home-page
> + "https://github.com/pytest-dev/pytest-flask")
> + (synopsis
> + "Pytest fixtures to test Flask applications")

These line breaks are unncessary.

Toggle quote (40 lines)
> +(define-public python-flask-restx
> + (package
> + (name "python-flask-restx")
> + (version "0.2.0")
> + (source
> + ;; We fetch from the Git repo because there are no tests in the PyPI
> + ;; archive.
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/python-restx/flask-restx")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0xf2vkmdngp9cv9klznizai4byxjcf0iqh1pr4b83nann0jxqwy7"))))
> + (build-system python-build-system)
> + (propagated-inputs
> + `(("python-aniso8601" ,python-aniso8601)
> + ("python-flask" ,python-flask)
> + ("python-jsonschema" ,python-jsonschema)
> + ("python-pytz" ,python-pytz)))
> + (native-inputs
> + `(("python-blinker" ,python-blinker)
> + ("python-faker" ,python-faker)
> + ("python-pytest" ,python-pytest)
> + ("python-pytest-benchmark"
> + ,python-pytest-benchmark)
> + ("python-pytest-flask" ,python-pytest-flask)
> + ("python-pytest-mock" ,python-pytest-mock)))
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (replace 'check
> + (lambda _
> + (invoke "pytest" "--benchmark-skip" "-k"
> + ;; Those tests need internet access
> + "not test_check and not test_valid_value_check"))))))
> + (home-page
> + "https://github.com/python-restx/flask-restx")

This line break is unnecessary.

Toggle quote (15 lines)
> +(define-public python-py-cpuinfo
> + (package
> + (name "python-py-cpuinfo")
> + (version "5.0.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "py-cpuinfo" version))
> + (sha256
> + (base32
> + "0045y6832gqjg63jmw0qj2jwyypgjwr7sfdq3lfv49b6fxpl5xic"))))
> + (build-system python-build-system)
> + (home-page
> + "https://github.com/workhorsy/py-cpuinfo")

This line break is unnecessary.

Toggle quote (2 lines)
> + (synopsis "Get CPU info with pure Python 2 & 3")

Maybe just "Get CPU info with Python"

Toggle quote (4 lines)
> + (description
> + "This module returns the CPU info by using the best sources of information for
> + your OS.")

s/OS/operating system/

Can you send updated patches? Please also make sure they are in the
correct order, i.e. this last package must come before
'python-pytest-benchmark'.

Thanks in advance!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7SWdcACgkQoqBt8qM6
VPpOUwf+OnayXWnOq+2/NKkocRHaML9VNQH9JCwbbO+bFkdihL6UBYx2yu+X7kID
qrIxGG+Ki2FjhhBsOvGpVlfeCPQXlCUQ06tS4+oStkA2rrKBZdT85O2DRoPnBHL3
2fuY05xNW8/a39EypOpF9xycQ35gBwN+bHhACUP8xzlUENo2ug76PCa8jcUZfT4d
9Zh/HxTkld5MxRsssnS0K4QdEowsDdAzEEzj8w/pGVKD4NBXTuQRLc3UCrhxb76e
10STPvEwF22RDyAkkALUnmgR5gKmWZsnk7QnWjHLGuxYa82bJq3B3u1o4su9+FVe
bCIE0zDvWBbs0neAYk1htweKlX0vOQ==
=F/a1
-----END PGP SIGNATURE-----

E
E
Edouard Klein wrote on 2 Jun 2020 11:41
[PATCH 1/4] gnu: Add python-py-cpuinfo
(address . 41459@debbugs.gnu.org)
87o8q1dcug.fsf@alice.lan
* gnu/packages/python-xyz.scm (python-py-cpuinfo): New variable.
---
gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6aa666430a..5cd3abd956 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19458,6 +19458,25 @@ using “=” characters. However this conveys no benefit so many protocols
choose to use Base64 without the “=” padding.")
(license license:asl2.0)))
+(define-public python-py-cpuinfo
+ (package
+ (name "python-py-cpuinfo")
+ (version "5.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "py-cpuinfo" version))
+ (sha256
+ (base32
+ "0045y6832gqjg63jmw0qj2jwyypgjwr7sfdq3lfv49b6fxpl5xic"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/workhorsy/py-cpuinfo")
+ (synopsis "Get CPU info with Python")
+ (description
+ "This module returns the CPU info by using the best sources of information for
+ your Operating System.")
+ (license license:expat)))
+
(define-public python-canonicaljson
(package
(name "python-canonicaljson")
--
2.26.2
E
E
Edouard Klein wrote on 2 Jun 2020 11:44
[PATCH 2/4] gnu: Add python-pytest-benchmark
(address . 41459@debbugs.gnu.org)
87img9dcpj.fsf@alice.lan
* gnu/packages/python-check.scm (python-pytest-benchmark): New variable.
---
gnu/packages/python-check.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1071abdbad..b13b750bbd 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -360,6 +360,30 @@ framework.")
for the @code{pytest} framework.")
(license license:expat)))
+(define-public python-pytest-benchmark
+ (package
+ (name "python-pytest-benchmark")
+ (version "3.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-benchmark" version))
+ (sha256
+ (base32
+ "0a4mpb4j73dsyk47hd1prrjpfk4r458s102cn80rf253jg818hxd"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-py-cpuinfo" ,python-py-cpuinfo)))
+ (native-inputs
+ `(("python-pathlib2" ,python-pathlib2)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/ionelmc/pytest-benchmark")
+ (synopsis "Pytest fixture for benchmarking code")
+ (description
+ "This pytest fixture will group the tests into rounds that are calibrated to
+the chosen timer.")
+ (license license:bsd-2)))
+
(define-public python-codacy-coverage
(package
(name "python-codacy-coverage")
--
2.26.2

Date: Tue, 02 Jun 2020 11:44:08 +0200
Message-ID: <87k10pdcpj.fsf@alice.lan>
E
E
Edouard Klein wrote on 2 Jun 2020 11:44
(no subject)
(address . 41459@debbugs.gnu.org)
87ftbddco7.fsf@alice.lan
Subject: [PATCH 3/4] gnu: Add python-pytest-flask
* gnu/packages/python-check.scm (python-pytest-flask): New variable.
---
gnu/packages/python-check.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index b13b750bbd..d7bed91a04 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -384,6 +384,30 @@ for the @code{pytest} framework.")
the chosen timer.")
(license license:bsd-2)))
+(define-public python-pytest-flask
+ (package
+ (name "python-pytest-flask")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-flask" version))
+ (sha256
+ (base32
+ "1hln7mwgdzfi5ma0kqfsi768l7p24jhkw8l0imhifwy08nh7hmjd"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-flask" ,python-flask)
+ ("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-werkzeug" ,python-werkzeug)))
+ (home-page
+ "https://github.com/pytest-dev/pytest-flask")
+ (synopsis "Pytest fixtures to test Flask applications")
+ (description
+ "This pytest plugin provides some fixtures to simplify app testing.")
+ (license license:expat)))
+
(define-public python-codacy-coverage
(package
(name "python-codacy-coverage")
--
2.26.2

Date: Tue, 02 Jun 2020 11:44:56 +0200
Message-ID: <87h7vtdco7.fsf@alice.lan>
E
E
Edouard Klein wrote on 2 Jun 2020 11:45
(address . 41459@debbugs.gnu.org)
87d06hdcnl.fsf@alice.lan
Subject: [PATCH 4/4] gnu: Add python-flask-restx
From 38a64901c9dcf53b4b32dd83bd6b50c4e4ea4d52 Mon Sep 17 00:00:00 2001
* gnu/packages/python-web.scm (python-flask-restx): New variable.
---
gnu/packages/python-web.scm | 48 +++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 61d21418d4..f8c61b8a53 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4024,3 +4024,51 @@ request/response web apps to larger, grown applications.")
than 326,000 known user-agents. Users can pick a random one, or select one
based on filters.")
(license license:expat)))
+
+(define-public python-flask-restx
+ (package
+ (name "python-flask-restx")
+ (version "0.2.0")
+ (source
+ ;; We fetch from the Git repo because there are no tests in the PyPI
+ ;; archive.
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/python-restx/flask-restx")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xf2vkmdngp9cv9klznizai4byxjcf0iqh1pr4b83nann0jxqwy7"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-aniso8601" ,python-aniso8601)
+ ("python-flask" ,python-flask)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-pytz" ,python-pytz)))
+ (native-inputs
+ `(("python-blinker" ,python-blinker)
+ ("python-faker" ,python-faker)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-benchmark"
+ ,python-pytest-benchmark)
+ ("python-pytest-flask" ,python-pytest-flask)
+ ("python-pytest-mock" ,python-pytest-mock)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "--benchmark-skip" "-k"
+ ;; Those tests need internet access
+ "not test_check and not test_valid_value_check"))))))
+ (home-page "https://github.com/python-restx/flask-restx")
+ (synopsis
+ "Framework for fast, easy and documented API development with Flask")
+ (description
+ "Flask-RESTX is an extension for Flask that adds support for quickly building
+REST APIs. Flask-RESTX encourages best practices with minimal setup. If you are familiar
+ with Flask, Flask-RESTX should be easy to pick up. It provides a coherent collection of
+decorators and tools to describe your API and expose its documentation properly using
+Swagger.")
+ (license license:bsd-3)))
--
2.26.2

Date: Tue, 02 Jun 2020 11:45:18 +0200
Message-ID: <87eeqxdcnl.fsf@alice.lan>
E
E
Edouard Klein wrote on 2 Jun 2020 12:06
Re: [bug#41459] [PATCH] gnu: Add python-flask-restx
(address . 41459@debbugs.gnu.org)
875zc9dbos.fsf@alice.lan
Hi,

Thank you for reviewing the commits.

For the indentation, I highlighted the changes in emacs and M-x
indent-region, but it did not change anything. Is something wrong with
my emacs config ?

Cheers,

Edouard

Marius Bakke writes:

Toggle quote (144 lines)
> Edouard Klein <edk@beaver-labs.com> writes:
>
>> * gnu/packages/python-web.scm (python-flask-restx): New variable.
>> * gnu/packages/python-check.scm (python-pytest-benchmark): New variable.
>> * gnu/packages/python-check.scm (python-pytest-flask): New variable.
>> * gnu/packages/python-xyz.scm (python-py-cpuinfo): New variable.
>
> Can you split this into four different patches?
>
> Please also fix the indentation on each package.
>
>> diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
>> index 50911673b2..70db8445ee 100644
>> --- a/gnu/packages/python-check.scm
>> +++ b/gnu/packages/python-check.scm
>> @@ -362,6 +362,55 @@ framework.")
>> framework.")
>> (license license:expat)))
>>
>> +(define-public python-pytest-benchmark
>> + (package
>> + (name "python-pytest-benchmark")
>> + (version "3.2.3")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (pypi-uri "pytest-benchmark" version))
>> + (sha256
>> + (base32
>> + "0a4mpb4j73dsyk47hd1prrjpfk4r458s102cn80rf253jg818hxd"))))
>> + (build-system python-build-system)
>> + (native-inputs
>> + `(("python-pathlib2" ,python-pathlib2)
>> + ("python-py-cpuinfo" ,python-py-cpuinfo)
>> + ("python-pytest" ,python-pytest)))
>
> py-cpuinfo should probably be propagated according to setup.py.
>
>> + (home-page "https://github.com/ionelmc/pytest-benchmark")
>> + (synopsis
>> + "Pytest fixture for benchmarking code")
>
> This line break is unnecessary.
>
> [...]
>
>> +(define-public python-pytest-flask
>> + (package
>> + (name "python-pytest-flask")
>> + (version "1.0.0")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (pypi-uri "pytest-flask" version))
>> + (sha256
>> + (base32
>> + "1hln7mwgdzfi5ma0kqfsi768l7p24jhkw8l0imhifwy08nh7hmjd"))))
>> + (build-system python-build-system)
>> + (native-inputs
>> + `(("python-flask" ,python-flask)
>> + ("python-pytest" ,python-pytest)
>> + ("python-setuptools-scm" ,python-setuptools-scm)
>> + ("python-werkzeug" ,python-werkzeug)))
>> + (home-page
>> + "https://github.com/pytest-dev/pytest-flask")
>> + (synopsis
>> + "Pytest fixtures to test Flask applications")
>
> These line breaks are unncessary.
>
>> +(define-public python-flask-restx
>> + (package
>> + (name "python-flask-restx")
>> + (version "0.2.0")
>> + (source
>> + ;; We fetch from the Git repo because there are no tests in the PyPI
>> + ;; archive.
>> + (origin
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url "https://github.com/python-restx/flask-restx")
>> + (commit version)))
>> + (file-name (git-file-name name version))
>> + (sha256
>> + (base32 "0xf2vkmdngp9cv9klznizai4byxjcf0iqh1pr4b83nann0jxqwy7"))))
>> + (build-system python-build-system)
>> + (propagated-inputs
>> + `(("python-aniso8601" ,python-aniso8601)
>> + ("python-flask" ,python-flask)
>> + ("python-jsonschema" ,python-jsonschema)
>> + ("python-pytz" ,python-pytz)))
>> + (native-inputs
>> + `(("python-blinker" ,python-blinker)
>> + ("python-faker" ,python-faker)
>> + ("python-pytest" ,python-pytest)
>> + ("python-pytest-benchmark"
>> + ,python-pytest-benchmark)
>> + ("python-pytest-flask" ,python-pytest-flask)
>> + ("python-pytest-mock" ,python-pytest-mock)))
>> + (arguments
>> + `(#:phases
>> + (modify-phases %standard-phases
>> + (replace 'check
>> + (lambda _
>> + (invoke "pytest" "--benchmark-skip" "-k"
>> + ;; Those tests need internet access
>> + "not test_check and not test_valid_value_check"))))))
>> + (home-page
>> + "https://github.com/python-restx/flask-restx")
>
> This line break is unnecessary.
>
>> +(define-public python-py-cpuinfo
>> + (package
>> + (name "python-py-cpuinfo")
>> + (version "5.0.0")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (pypi-uri "py-cpuinfo" version))
>> + (sha256
>> + (base32
>> + "0045y6832gqjg63jmw0qj2jwyypgjwr7sfdq3lfv49b6fxpl5xic"))))
>> + (build-system python-build-system)
>> + (home-page
>> + "https://github.com/workhorsy/py-cpuinfo")
>
> This line break is unnecessary.
>
>> + (synopsis "Get CPU info with pure Python 2 & 3")
>
> Maybe just "Get CPU info with Python"
>
>> + (description
>> + "This module returns the CPU info by using the best sources of information for
>> + your OS.")
>
> s/OS/operating system/
>
> Can you send updated patches? Please also make sure they are in the
> correct order, i.e. this last package must come before
> 'python-pytest-benchmark'.
>
> Thanks in advance!
M
M
Marius Bakke wrote on 22 Jun 2020 21:33
Re: [bug#41459] [PATCH 1/4] gnu: Add python-py-cpuinfo
874kr2dhew.fsf@gnu.org
Edouard Klein <edk@beaver-labs.com> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-py-cpuinfo): New variable.

Applied with a minor tweak to the description.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7xB5cACgkQoqBt8qM6
VPqJyQf/QiW2MkbB1r75g7oi3Wpq7wIIf5XM7/fhZAIomuy8Y4Mw2CCYFtvBQRTu
nZTnaCsGjaiAzOKT4TL9tqYflss1q2VlQjC4gmcmALv2AFh5vajYPolTHSlZTiJ0
gb0AaImfSxuVt70MO2/4ix+wgUiQZEfy8F8PwzxNjiCYOUsbV7kOovoiOlQgzPra
F+M9mdCBqYzQ1FiZUK2rpYnOrqB0Y/L9IpdsIlsl5Eg2NG6UhU0XNnawrc6iaQrI
9/bA6Nt0/9HoRO+Gnp65y+jBPQ7OFKKy6MM6uhZuNrobUju1oV/BTTUlrqCPtSqE
1dSnbHXtZhdoGax4HcJ6iVvWnSfgnw==
=cSy6
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 22 Jun 2020 21:36
Re: [bug#41459] [PATCH 2/4] gnu: Add python-pytest-benchmark
871rm6dhal.fsf@gnu.org
Edouard Klein <edk@beaver-labs.com> writes:

Toggle quote (2 lines)
> * gnu/packages/python-check.scm (python-pytest-benchmark): New variable.

Applied with this minor change:

(description
- "This pytest fixture will group the tests into rounds that are calibrated to
-the chosen timer.")
+ "This package provides a pytest fixture that will group the tests into
+rounds that are calibrated to the chosen timer.")
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7xCDIACgkQoqBt8qM6
VPp2Owf/b+KwlKUqXLTVECW75i9cTDkbuZRksSwoU1gjaeM0X/nyzdI2LKmy3cxM
iwRZqOJ+iXUKwvI5tK98Bg5gJWcT/dDXrQcT2yLDWbyghtDXa607fRc5SaUr7NlG
c1w3dnMSsvZZcoWjeO3dg4Bz+FRZJTxZFfnjBECXu7g9BKdk0z7oIIRuy/jeo+LL
EdEyGB7aflzeA+tRtxw2OVt9IXFK03i3kW0QnJM63KhEcoTgOsi8hjiSqKAnwY8M
+l8pSOAPwMA8xsD7VQGeflsvnGrakLv6xWX0dW1RheB7Of1A+7KUvEgdg/dKW3Ts
yJV0aV8HIb/yMAYmAJbMq184VK9X4A==
=+GV4
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 22 Jun 2020 21:39
Re: [bug#41459] (no subject)
87y2oec2kh.fsf@gnu.org
Edouard Klein <edk@beaver-labs.com> writes:

Toggle quote (3 lines)
> Subject: [PATCH 3/4] gnu: Add python-pytest-flask
> * gnu/packages/python-check.scm (python-pytest-flask): New variable.

Applied with a minor tweak to the description.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7xCP4ACgkQoqBt8qM6
VPoG4AgAw13ymyH7lc9MyaXKdiR43al8z2sItVGKnjuzCa8LkQ1+KggLLAiKate8
SDP6yWLmTazxBSJLtVeN7kzFZOEMX3VOi6CM4naun8pCfMokx8OmSu3Wiok8RSG7
jeHSK5RDEhjRg7bDL+hUCfsJIir0pAJKETDPjdgbmg8OTZeB4hlsiE3Chbw0GH83
IsLjbTAWL/478VTpvz5IESwqc82gpvSM07xtlY4hZez0FaSzjlI9lf3oniJkENkc
kXMk3VG82hYBaNhdIMggGPHlbS983+mT2Uboe47yie5eX2hn5ENXXyScWVvE5kQG
+PxmJN+sSOO9xS2K1leuvjuxonc7QA==
=BfBU
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 22 Jun 2020 21:43
87v9jic2ey.fsf@gnu.org
Edouard Klein <edk@beaver-labs.com> writes:

Toggle quote (4 lines)
> Subject: [PATCH 4/4] gnu: Add python-flask-restx
>>From 38a64901c9dcf53b4b32dd83bd6b50c4e4ea4d52 Mon Sep 17 00:00:00 2001
> * gnu/packages/python-web.scm (python-flask-restx): New variable.

Applied, thanks!

I added punctuation in the commit message for all four patches.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7xCcUACgkQoqBt8qM6
VPpaRwgAj3k6iwD9RdM+kAj3PjC9RLStA+nee+gRFpVMw7+zhX/idi/iXq1TcHqe
1SV6QyXeITOv59D1QISP/qYa2K0HxF+5YXNEzvE0GU8LJHuJ/u4rRuUAqtkuv5ky
HX950dHjU2tw7X0b7Lx5u8lRBdmlOXokSM560Hc5KFiNDgIsSatkO7su67dbxUkv
N76YLEy/U6mJli82qdM2lD1byEQ1Of44ueMLJ1d/0rUbZvcNL8AcZWJH8F4mXtrt
uuaPg8QVZ7HdQ4i5dp9DSG2ZT3gIK62Ecqp0cZauTMLM6JQpOwYnWsJQwBlkPB2G
EJGXwO187IBOSOu+5XFyVl7ASZtQWA==
=mqck
-----END PGP SIGNATURE-----

Closed
?