[PATCH 0/3] upower: Enable tests

  • Done
  • quality assurance status badge
Details
2 participants
  • Brice Waegeneire
  • Marius Bakke
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
B
B
Brice Waegeneire wrote on 22 May 2020 10:18
(address . guix-patches@gnu.org)
20200522081817.31570-1-brice@waegenei.re
Brice Waegeneire (3):
gnu: umockdev: Add 'gobject-introspection'.
gnu: umockdev: Update to 0.14.1.
gnu: upower: Enable tests.

gnu/packages/check.scm | 5 +++--
gnu/packages/gnome.scm | 18 ++++++++++++++----
2 files changed, 17 insertions(+), 6 deletions(-)

--
2.26.2
B
B
Brice Waegeneire wrote on 22 May 2020 10:22
[PATCH 1/3] gnu: umockdev: Add 'gobject-introspection'.
(address . guix-patches@gnu.org)
20200522082243.2160-1-brice@waegenei.re
* gnu/packages/check.scm (umockdev)[native-inuputs]: Add
'gobject-introspection'.
---
gnu/packages/check.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 12e01795ee..b279dc149d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2538,6 +2538,7 @@ provides a simple way to achieve this.")
#t)))))
(native-inputs
`(("vala" ,vala)
+ ("gobject-introspection" ,gobject-introspection)
("gtk-doc" ,gtk-doc)
("pkg-config" ,pkg-config)
--
2.26.2
B
B
Brice Waegeneire wrote on 22 May 2020 10:22
[PATCH 2/3] gnu: umockdev: Update to 0.14.1.
(address . guix-patches@gnu.org)
20200522082243.2160-2-brice@waegenei.re
* gnu/packages/check.scm (umockdev) Update to 0.14.1.
---
gnu/packages/check.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b279dc149d..7d7fd189bc 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2518,7 +2518,7 @@ provides a simple way to achieve this.")
(define-public umockdev
(package
(name "umockdev")
- (version "0.13.2")
+ (version "0.14.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/martinpitt/umockdev/"
@@ -2526,7 +2526,7 @@ provides a simple way to achieve this.")
"umockdev-" version ".tar.xz"))
(sha256
(base32
- "095v3abc321s584sga04y16lcmdzsdi88h24wcrm78v7vq484g74"))))
+ "1g78jcrvb7yyh0q5kv5409wjqf8nlfqnw1rknm3a247mcx317dpz"))))
(build-system gnu-build-system)
(arguments
`(#:phases
--
2.26.2
B
B
Brice Waegeneire wrote on 22 May 2020 10:22
[PATCH 3/3] gnu: upower: Enable tests.
(address . guix-patches@gnu.org)
20200522082243.2160-3-brice@waegenei.re
* gnu/packages/gnome.scm (upower)[arguments]: Enable tests and add
phases 'pre-check'.
[native-inputs]: Add 'python-pygobject', 'python-dbus',
'python-dbusmock' and 'umockdev'.
---
gnu/packages/gnome.scm | 18 ++++++++++++++----
1 file changed, 14 insertions(+), 4 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 803ac8fe5a..afd40ac725 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4156,10 +4156,14 @@ faster results and to avoid unnecessary server load.")
#t))))
(build-system glib-or-gtk-build-system)
(arguments
- '( ;; The tests want to contact the system bus, which can't be done in the
- ;; build environment. The integration test can run, but the last of
- ;; the up-self-tests doesn't. Disable tests for now.
- #:tests? #f
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((umockdev (string-append (assoc-ref inputs "umockdev")
+ "/lib")))
+ (setenv "LD_LIBRARY_PATH" umockdev))
+ #t)))
#:configure-flags (list "--localstatedir=/var"
(string-append "--with-udevrulesdir="
(assoc-ref %outputs "out")
@@ -4170,6 +4174,12 @@ faster results and to avoid unnecessary server load.")
("intltool" ,intltool)
("python" ,python)
+ ;; For tests.
+ ("python-dbus" ,python-dbus)
+ ("python-dbusmock" ,python-dbusmock)
+ ("python-pygobject" ,python-pygobject)
+ ("umockdev" ,umockdev)
+
;; For man pages.
("libxslt" ,libxslt) ;for 'xsltproc'
("libxml2" ,libxml2) ;for 'XML_CATALOG_FILES'
--
2.26.2
M
M
Marius Bakke wrote on 23 May 2020 19:58
Re: [bug#41447] [PATCH 0/3] upower: Enable tests
875zcm8re7.fsf@devup.no
Brice Waegeneire <brice@waegenei.re> writes:

Toggle quote (5 lines)
> Brice Waegeneire (3):
> gnu: umockdev: Add 'gobject-introspection'.
> gnu: umockdev: Update to 0.14.1.
> gnu: upower: Enable tests.

LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7JZFAACgkQoqBt8qM6
VPokeQgAgmZiu53hsYXOO6BIZnWs3wZQ8MfHe6gnaW57EbULm9QLqaJI/lDJST2o
YoCx2cXdt8O9jwGQE+B0QDcIrcAsuSsZjboVZVxcwz2lmhC+nJpA1e/V6FzpU/wh
jh41dbLUpjw8CAcWFOIVBQmZxT9oHGWbvxqTjPF5+qTQcThGmiGFc00GNtwbuXbX
TE/BRQiat9xF1+/htbh2LiAmzX3leBiQdtHC1hlxIRB+F8zWqK0TOeJNtfOJDaWY
zWRfzh59rWfVkwu+lmO7iBCyqD2RPWWp3r62W6IcOCcx8SxJGYJFXNB1iWV1Bv22
3oXx4mjKR8+sIhGFjBfy7haoQZ/YaQ==
=9WLC
-----END PGP SIGNATURE-----

B
B
Brice Waegeneire wrote on 23 May 2020 21:53
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 41447-done@debbugs.gnu.org)
c81a3dc9268d174053b4d48179042be1@waegenei.re
On 2020-05-23 17:58, Marius Bakke wrote:
Toggle quote (9 lines)
> Brice Waegeneire <brice@waegenei.re> writes:
>
>> Brice Waegeneire (3):
>> gnu: umockdev: Add 'gobject-introspection'.
>> gnu: umockdev: Update to 0.14.1.
>> gnu: upower: Enable tests.
>
> LGTM.

Pushed as 6039031a1a5e1cabd380b8715334d5a8f600055f.
Closed
?