[PATCH 0/8] gnu: Add python-pyramid

  • Done
  • quality assurance status badge
Details
2 participants
  • Holger Peters
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Holger Peters
Severity
normal
Merged with
H
H
Holger Peters wrote on 20 May 2020 09:02
(address . guix-patches@gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200520070224.6676-1-holger.peters@posteo.de
This patch series is provided in order to add python-pyramid to the guix
package distribution.

Holger Peters (8):
gnu: python-webob: Update to 1.8.6
gnu: Add python-venusian
gnu: Add python-zope-deprecation
gnu: Add python-translationstring
gnu: Add python-plaster
gnu: Add python-plaster-pastedeploy
gnu: Add python-hupper
gnu: Add python-pyramid

gnu/packages/python-web.scm | 173 +++++++++++++++++++++++++++++++++++-
1 file changed, 171 insertions(+), 2 deletions(-)

--
2.26.0
H
H
Holger Peters wrote on 20 May 2020 09:07
[PATCH 1/8] gnu: python-webob: Update to 1.8.6
(address . 41416@debbugs.gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200520070710.6999-1-holger.peters@posteo.de
* gnu/packages/python-web.scm (python-webob): Update to 1.8.6.
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2cd37c8bcf..a554f598e2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1035,14 +1035,14 @@ your Web app.")
(define-public python-webob
(package
(name "python-webob")
- (version "1.8.3")
+ (version "1.8.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "WebOb" version))
(sha256
(base32
- "1cpqskanmvwia8wqlpcr3ykyxysynjdnbl5namvpg8vw6jnkv1dh"))))
+ "026i3z99nr3px75isa9mbnky5i7rffiv4d124h5kxfjjsxz92fma"))))
(build-system python-build-system)
(native-inputs
`(("python-nose" ,python-nose)))
--
2.26.0
H
H
Holger Peters wrote on 20 May 2020 09:07
[PATCH 2/8] gnu: Add python-venusian
(address . 41416@debbugs.gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200520070710.6999-2-holger.peters@posteo.de
* gnu/packages/python-web.scm (python-venusian): New variable
---
gnu/packages/python-web.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a554f598e2..0dff9610bc 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3836,3 +3836,28 @@ major web browsers.")
(synopsis "Python wrapper around rapidjson")
(description "This package provides a python wrapper around rapidjson.")
(license license:expat)))
+
+(define-public python-venusian
+ (package
+ (name "python-venusian")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "venusian" version))
+ (sha256
+ (base32 "0f7f67dkgxxcjfhpdd5frb9pszkf04lyzzpn5069q0xi89r2p17n"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-runner" ,python-pytest-runner)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (arguments '(#:test-target "pytest"))
+ (home-page "https://docs.pylonsproject.org/projects/venusian")
+ (synopsis "Library for defering decorator actions")
+ (description
+ "Venusian is a library which allows framework authors to defer decorator
+actions. Instead of taking actions when a function (or class) decorator is
+executed at import time, you can defer the action usually taken by the
+decorator until a separate scan phase.")
+ (license license:repoze)))
--
2.26.0
H
H
Holger Peters wrote on 20 May 2020 09:07
[PATCH 3/8] gnu: Add python-zope-deprecation
(address . 41416@debbugs.gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200520070710.6999-3-holger.peters@posteo.de
* gnu/packages/python-web.scm Added several packages:
(python-zope-deprecation): New variable
---
gnu/packages/python-web.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0dff9610bc..da0726ae99 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3861,3 +3861,23 @@ actions. Instead of taking actions when a function (or class) decorator is
executed at import time, you can defer the action usually taken by the
decorator until a separate scan phase.")
(license license:repoze)))
+
+(define-public python-zope-deprecation
+ (package
+ (name "python-zope-deprecation")
+ (version "4.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "zope.deprecation" version))
+ (sha256
+ (base32
+ "1pz2cv7gv9y1r3m0bdv7ks1alagmrn5msm5spwdzkb2by0w36i8d"))))
+ (build-system python-build-system)
+ (native-inputs `())
+ (propagated-inputs `())
+ (home-page "https://zopedeprecation.readthedocs.io/")
+ (synopsis "Provides a function for marking deprecations")
+ (description "The zope.deprecation module provides a function for marking
+modules, classes, functions, methods and properties as deprecated, displaying
+warnings when usaged in application code.")
+ (license license:zpl2.1)))
--
2.26.0
H
H
Holger Peters wrote on 20 May 2020 09:07
[PATCH 4/8] gnu: Add python-translationstring
(address . 41416@debbugs.gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200520070710.6999-4-holger.peters@posteo.de
* gnu/packages/python-web.scm (python-translationstring): New variable
---
gnu/packages/python-web.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index da0726ae99..38334c1bc5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3881,3 +3881,20 @@ decorator until a separate scan phase.")
modules, classes, functions, methods and properties as deprecated, displaying
warnings when usaged in application code.")
(license license:zpl2.1)))
+
+(define-public python-translationstring
+ (package
+ (name "python-translationstring")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "translationstring" version))
+ (sha256
+ (base32
+ "0bdpcnd9pv0131dl08h4zbcwmgc45lyvq3pa224xwan5b3x4rr2f"))))
+ (build-system python-build-system)
+ (home-page "http://docs.pylonsproject.org/projects/translationstring")
+ (synopsis "Internationalization tooling for the Pylons project")
+ (description "Library used by various Pylons project packages for
+internationalization (i18n) duties related to translation.")
+ (license license:repoze)))
--
2.26.0
H
H
Holger Peters wrote on 20 May 2020 09:07
[PATCH 5/8] gnu: Add python-plaster
(address . 41416@debbugs.gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200520070710.6999-5-holger.peters@posteo.de
* gnu/packages/python-web.scm (python-plaster): New Variable
---
gnu/packages/python-web.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 38334c1bc5..df9c29ecb7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3898,3 +3898,27 @@ warnings when usaged in application code.")
(description "Library used by various Pylons project packages for
internationalization (i18n) duties related to translation.")
(license license:repoze)))
+
+(define-public python-plaster
+ (package
+ (name "python-plaster")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "plaster" version))
+ (sha256
+ (base32
+ "1hy8k0nv2mxq94y5aysk6hjk9ryb4bsd13g83m60hcyzxz3wflc3"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://docs.pylonsproject.org/projects/plaster/en/latest/")
+ (synopsis "Configuration loader for multiple config file formats")
+ (description
+ "Plaster is a loader interface around multiple config file formats. It
+exists to define a common API for applications to use when they wish to load
+configuration. The library itself does not aim to handle anything except a
+basic API that applications may use to find and load configuration settings.
+Any specific constraints should be implemented in a pluggable loader which can
+be registered via an entrypoint.")
+ (license license:repoze)))
--
2.26.0
H
H
Holger Peters wrote on 20 May 2020 09:07
[PATCH 6/8] gnu: Add python-plaster-pastedeploy
(address . 41416@debbugs.gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200520070710.6999-6-holger.peters@posteo.de
* gnu/packages/python-web.scm (python-plaster-pastedeploy): New Variable
---
gnu/packages/python-web.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index df9c29ecb7..79cb0424ff 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3922,3 +3922,27 @@ basic API that applications may use to find and load configuration settings.
Any specific constraints should be implemented in a pluggable loader which can
be registered via an entrypoint.")
(license license:repoze)))
+
+(define-public python-plaster-pastedeploy
+ (package
+ (name "python-plaster-pastedeploy")
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "plaster_pastedeploy" version))
+ (sha256
+ (base32
+ "1zg7gcsvc1kzay1ry5p699rg2qavfsxqwl17mqxzr0gzw6j9679r"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-plaster" ,python-plaster)
+ ("python-pastedeploy" ,python-pastedeploy)))
+ (home-page "https://github.com/Pylons/plaster_pastedeploy")
+ (synopsis "Plugin for `python-plaster' adds PasteDeploy syntax")
+ (description
+ "This plugin for `python-plaster' adds support for PasteDeploy syntax, it
+provides a plaster Loader object that can parse ini files according to the
+standard set by PasteDeploy ")
+ (license license:expat)))
--
2.26.0
H
H
Holger Peters wrote on 20 May 2020 09:07
[PATCH 7/8] gnu: Add python-hupper
(address . 41416@debbugs.gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200520070710.6999-7-holger.peters@posteo.de
* gnu/packages/python-web.scm (python-hupper): New variable
---
gnu/packages/python-web.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 79cb0424ff..84aeaed869 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3946,3 +3946,33 @@ be registered via an entrypoint.")
provides a plaster Loader object that can parse ini files according to the
standard set by PasteDeploy ")
(license license:expat)))
+
+(define-public python-hupper
+ (package
+ (name "python-hupper")
+ (version "1.10.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hupper" version))
+ (sha256
+ (base32
+ "0am0p6g5cz6xmcaf04xq8q6dzdd9qz0phj6gcmpsckf2mcyza61q"))))
+ (build-system python-build-system)
+ (arguments '(#:test-target "pytest"))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-watchdog" ,python-watchdog)
+ ("python-mock" ,python-mock)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (propagated-inputs
+ `(("python-pytz" ,python-pytz)))
+ (home-page "https://readthedocs.org/projects/hupper")
+ (synopsis
+ "Integrated process monitor tracking changes to imported
+ Python files")
+ (description
+ "Hupper is an integrated process monitor that will track changes to any
+imported Python files in sys.modules as well as custom paths. When files are
+changed the process is restarted.")
+ (license license:expat)))
--
2.26.0
H
H
Holger Peters wrote on 20 May 2020 09:07
[PATCH 8/8] gnu: Add python-pyramid
(address . 41416@debbugs.gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20200520070710.6999-8-holger.peters@posteo.de
* gnu/packages/python-web.scm (python-pyramid): New variable
---
gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 84aeaed869..bfeefc0420 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3976,3 +3976,32 @@ standard set by PasteDeploy ")
imported Python files in sys.modules as well as custom paths. When files are
changed the process is restarted.")
(license license:expat)))
+
+(define-public python-pyramid
+ (package
+ (name "python-pyramid")
+ (version "1.10.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyramid" version))
+ (sha256
+ (base32
+ "0rkxs1ajycg2zh1c94xlmls56mx5m161sn8112skj0amza6cn36q"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-hupper" ,python-hupper)
+ ("python-plaster-pastedeploy" ,python-plaster-pastedeploy)
+ ("python-translationstring" ,python-translationstring)
+ ("python-venusian" ,python-venusian)
+ ("python-webob" ,python-webob)
+ ("python-zope-deprecation" ,python-zope-deprecation)
+ ("python-zope-interface" ,python-zope-interface)
+ ("python-webtest" ,python-webtest)
+ ("python-zope-component" ,python-zope-component)
+ ("python-plaster" ,python-plaster)))
+ (home-page "https://trypyramid.com/")
+ (synopsis "Python web-framework suitable for small and large sites")
+ (description
+ "Pyramid makes it easy to write web applications. From minimal
+request/response web apps to larger, grown applications.")
+ (license license:repoze)))
--
2.26.0
R
R
Ricardo Wurmus wrote on 20 May 2020 09:34
merge issues
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
877dx7f4ax.fsf@elephly.net
merge 41416 41331
quit
R
R
Ricardo Wurmus wrote on 20 May 2020 09:42
Re: [bug#41416] [PATCH 8/8] gnu: Add python-pyramid
(name . Holger Peters)(address . holger.peters@posteo.de)(address . 41416-done@debbugs.gnu.org)
874ksbf3x2.fsf@elephly.net
Hi Holger,

thank you for your patches!

I’ve made very minor changes (adding trailing periods, removing a typo,
etc) and pushed them with 90f44ee4967c6d387e82abf88fd2c39d94415daf to
the master branch.

Thanks again!

--
Ricardo
Closed
?