[PATCH 0/2] Update julius

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Timotej Lazar
Owner
unassigned
Submitted by
Timotej Lazar
Severity
normal
T
T
Timotej Lazar wrote on 16 May 2020 22:39
(address . guix-patches@gnu.org)
87blmnr4w8.fsf@araneo.si
Hi,

this updates julius to latest version and removes (most) bundled libs.

Thanks!

Timotej Lazar (2):
gnu: julius: Update to 1.4.0.
gnu: julius: Remove unused bundled libraries.

gnu/packages/games.scm | 15 +++++++++++----
1 file changed, 11 insertions(+), 4 deletions(-)

--
2.26.2
T
T
Timotej Lazar wrote on 16 May 2020 22:53
[PATCH 1/2] gnu: julius: Update to 1.4.0.
(address . 41337@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
20200516205317.19589-1-timotej.lazar@araneo.si
* gnu/packages/games.scm (julius): Update to 1.4.0.
[inputs]: Add new dependency libpng.
---
gnu/packages/games.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f7b21ce44f..2933267629 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -978,7 +978,7 @@ automata. The following features are available:
(define-public julius
(package
(name "julius")
- (version "1.3.0")
+ (version "1.4.0")
(source
(origin
(method git-fetch)
@@ -987,10 +987,11 @@ automata. The following features are available:
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1ws5lmwdhla73676fj0w26v859n47s0wyxa0mgd0dmkx0x91qriy"))))
+ (base32 "01rygr592ar530qv1flmaiq8icl0qdxgc8lhkcdyn1g09941z47v"))))
(build-system cmake-build-system)
(inputs
- `(("sdl2" ,sdl2)
+ `(("libpng" ,libpng)
+ ("sdl2" ,sdl2)
("sdl2-mixer" ,sdl2-mixer)))
(home-page "https://github.com/bvschaik/julius")
(synopsis "Re-implementation of Caesar III game engine")
--
2.26.2
T
T
Timotej Lazar wrote on 16 May 2020 22:53
[PATCH 2/2] gnu: julius: Remove unused bundled libraries.
(address . 41337@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
20200516205317.19589-2-timotej.lazar@araneo.si
* gnu/packages/games.scm (julius)[source](snippet): Remove
ext/{dirent,png,SDL2,zlib}.
---
gnu/packages/games.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2933267629..d84841b0b7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -987,7 +987,14 @@ automata. The following features are available:
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "01rygr592ar530qv1flmaiq8icl0qdxgc8lhkcdyn1g09941z47v"))))
+ (base32 "01rygr592ar530qv1flmaiq8icl0qdxgc8lhkcdyn1g09941z47v"))
+ ;; Remove unused bundled libraries.
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (with-directory-excursion "ext"
+ (for-each delete-file-recursively '("dirent" "png" "SDL2" "zlib")))
+ #t))))
(build-system cmake-build-system)
(inputs
`(("libpng" ,libpng)
@@ -1001,7 +1008,6 @@ Julius includes some UI enhancements while preserving the logic (including
bugs) of the original game, so that saved games are compatible. This package
does not include game data.")
(license (list license:agpl3
- license:expat ; ext/dirent
license:zlib)))) ; ext/tinyfiledialogs
(define-public meandmyshadow
--
2.26.2
N
N
Nicolas Goaziou wrote on 17 May 2020 01:11
Re: [bug#41337] [PATCH 0/2] Update julius
(name . Timotej Lazar)(address . timotej.lazar@araneo.si)(address . 41337-done@debbugs.gnu.org)
87y2prtqyu.fsf@nicolasgoaziou.fr
Hello,

Timotej Lazar <timotej.lazar@araneo.si> writes:

Toggle quote (2 lines)
> this updates julius to latest version and removes (most) bundled libs.

I applied both patches. Thank you!

Regards,

--
Nicolas Goaziou
Closed
?