[PATCH] gnu: Add emacs-vcsh.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
M
M
Michael Rohleder wrote on 16 May 2020 18:05
(address . guix-patches@gnu.org)
87ftbz986g.fsf@rohleder.de
From f18c71cbad9860ae15907c5a74367b8ac55cb122 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sat, 16 May 2020 18:01:49 +0200
Subject: [PATCH] gnu: Add emacs-vcsh.

* gnu/packages/emacs-xyz.scm (emacs-vcsh): New variable.
---
gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 45ccced99e..ac299b34ce 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14918,6 +14918,36 @@ repository, @code{magit-org-todos} will create a section in your Magit status
buffer with each of your todos.")
(license license:gpl3+))))
+(define-public emacs-vcsh
+ (package
+ (name "emacs-vcsh")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/stepnem/vcsh-el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "183pffdiqb7qqmjq31wxl3fpv8qswqgg99gb716rddiyk15ysri7"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/stepnem/vcsh-el")
+ (synopsis "Emacs vcsh integration")
+ (description
+ "This library only provides basic \"enter\" functionality
+(`vcsh-link', `vcsh-unlink') and a few convenience commands
+(`vcsh-new' to init a repo and add files to it,
+`vcsh-write-gitignore').
+Please note that this library works by creating a regular file
+named \".git\" inside $VCSH_BASE directory (typically $HOME) and does
+not remove this file automatically, so don't be surprised if your
+shell suddenly behaves as after \"vcsh enter\" when inside that
+directory. You can use `vcsh-unlink' or simply remove the file to
+get rid of it.")
+ (license license:public-domain)))
+
(define-public emacs-f3
(package
(name "emacs-f3")
--
2.26.2
--
Gehen Sie mit einem guten Buch ins Bett.
Oder wenigstens mit jemandem, der kürzlich eins gelesen hat.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl7AD1gACgkQfHr/vv7y
yyXlygf/QpzIAd9l93dE1b5YKnPkzOSyWEUBP/Txfi3BP+CJSYYC6jtrJt586Qkc
IPMhVrTMq9Bb/zySHCQ7LGu4KtrUwU5BZcZ966pyB9Re1IkkSDbvGrcSjdfVHMOL
Bbg4RSwHspErmkfuI45hh6qgwqxVNAsAnm5bQAaHn5UOdkW4xelBTeovLxwJhCnC
GzHDAbyqUI+N1omDsCmOGxubQPLW/FQ4PXHZMPEqSE7jB/fmxcrb+Umrn+YwzK0A
iq+iHRDEaRrsSZX7L1E2vPw7et0fJm1cM+hVlDTWCz8EhhFuoM4nwvKgYUTcSHTO
m2WTRaTtzW5A6lxCWwmMRTC4425XEA==
=2vj3
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 16 May 2020 19:19
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 41327@debbugs.gnu.org)
87367zx0f9.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (5 lines)
> From f18c71cbad9860ae15907c5a74367b8ac55cb122 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Sat, 16 May 2020 18:01:49 +0200
> Subject: [PATCH] gnu: Add emacs-vcsh.

Thank you for the patch. Some comments follow.

Toggle quote (15 lines)
> +(define-public emacs-vcsh
> + (package
> + (name "emacs-vcsh")
> + (version "0.4.4")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.com/stepnem/vcsh-el.git")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "183pffdiqb7qqmjq31wxl3fpv8qswqgg99gb716rddiyk15ysri7"))))

Nitpick: could you move the string on the line above?

Toggle quote (9 lines)
> + (build-system emacs-build-system)
> + (home-page "https://gitlab.com/stepnem/vcsh-el")
> + (synopsis "Emacs vcsh integration")
> + (description
> + "This library only provides basic \"enter\" functionality
> +(`vcsh-link', `vcsh-unlink') and a few convenience commands
> +(`vcsh-new' to init a repo and add files to it,
> +`vcsh-write-gitignore').

Without writing too many details, I suggest

This library provides basic ``enter'' functionality and a few
convenience commands to init a repository and add files to it.

However, it may be useful to write somewhere what is "vcsh". As a user,
do I need/want that?

Toggle quote (7 lines)
> +Please note that this library works by creating a regular file
> +named \".git\" inside $VCSH_BASE directory (typically $HOME) and does
> +not remove this file automatically, so don't be surprised if your
> +shell suddenly behaves as after \"vcsh enter\" when inside that
> +directory. You can use `vcsh-unlink' or simply remove the file to
> +get rid of it."

I don't think this part is really useful as a description, i.e., it does
belong to a manual instead. As a side note, descriptions use Texinfo
syntax, so `vcsh-unlink' is written @code{vcsh-unlink}, etc.


Could you send an updated patch?

Regards,

--
Nicolas Goaziou
M
M
Michael Rohleder wrote on 19 May 2020 15:31
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 41327@debbugs.gnu.org)
875zcsxd92.fsf@rohleder.de
Hi Nicolas,

thank you for reviewing the patch.

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
Toggle quote (5 lines)
>> + (base32
>> + "183pffdiqb7qqmjq31wxl3fpv8qswqgg99gb716rddiyk15ysri7"))))
>
> Nitpick: could you move the string on the line above?

done.

Toggle quote (14 lines)
>> + (description
>> + "This library only provides basic \"enter\" functionality
>> +(`vcsh-link', `vcsh-unlink') and a few convenience commands
>> +(`vcsh-new' to init a repo and add files to it,
>> +`vcsh-write-gitignore').
>
> Without writing too many details, I suggest
>
> This library provides basic ``enter'' functionality and a few
> convenience commands to init a repository and add files to it.
>
> However, it may be useful to write somewhere what is "vcsh". As a user,
> do I need/want that?

I modified the description to your suggesting and added a short
sentence, why/how this package could be useful.

e.g. I use it in this function (that i call from a hydra):
Attachment: file
Toggle quote (1 lines)
> Could you send an updated patch?
From 43a46ffd415ff780eda5dfeb5bd8de8ebaa04259 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Tue, 19 May 2020 15:05:16 +0200
Subject: [PATCH] gnu: Add emacs-vcsh.

* gnu/packages/emacs-xyz.scm (emacs-vcsh): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 69786f335b..77ab2977ee 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14919,6 +14919,28 @@ repository, @code{magit-org-todos} will create a section in your Magit status
buffer with each of your todos.")
(license license:gpl3+))))
+(define-public emacs-vcsh
+ (package
+ (name "emacs-vcsh")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/stepnem/vcsh-el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "183pffdiqb7qqmjq31wxl3fpv8qswqgg99gb716rddiyk15ysri7"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/stepnem/vcsh-el")
+ (synopsis "Emacs vcsh integration")
+ (description
+ "This library provides basic \"enter\" functionality and a few
+convenience commands to init a repo and add files to it. This is useful to
+use @code{magit} with a @code{vcsh} repo.")
+ (license license:public-domain)))
+
(define-public emacs-f3
(package
(name "emacs-f3")
--
2.26.2
Regards,
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl7D36kACgkQfHr/vv7y
yyVV6Qf/SrKRwwHiPXi/QzrT0WEicYWp3K6lB8GH/u8S+WPWNy18vMIZ/Wbjv+nI
uCbopIoLSl8N3kQHapovP615slFvWRY8Pvy2DbDwEfwTBHtlIm1C+p522WPjdrbq
xwMaLC7Ms0sGagQ+eeE/5M69sJ1UHWak6iSmq9u86SYMpt1rfyWlAstpwkclYN3F
gKy0NJekUKGW3tv911MglX8UDRIqQPJxO2E6RkybaKrr0hRQDcse2or1NO8PNoLb
Ivyrsmmulq3K8hWFFPd215uH73Gjei0Xxh2IT3plandq0Xvd4mGUTndqjjkSjxbs
dGE7+tAkNJFOxI/JT94Tg0WQ/FgpKw==
=4wee
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 20 May 2020 12:44
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 41327-done@debbugs.gnu.org)
87y2pmhon8.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-vcsh): New variable.

I tweaked the description and applied your patch.

Thank you!

Regards,

--
Nicolas Goaziou
Closed
?