[PATCH 0/5] Fix and update udisks

  • Done
  • quality assurance status badge
Details
3 participants
  • Brice Waegeneire
  • Efraim Flashner
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
B
B
Brice Waegeneire wrote on 14 May 2020 00:24
(address . guix-patches@gnu.org)
20200513222409.28811-1-brice@waegenei.re
This patchset update udisks and fix a startup error.

Brice Waegeneire (5):
gnu: udisks: Update to 2.8.4.
gnu: udisks: Appease guix lint.
gnu: libblockdev: Appease guix lint.
gnu: libblockdev: Add input 'xfsprogs'.
gnu: libblockdev: Set default configuration directory.

gnu/packages/disk.scm | 15 +++++++++++----
gnu/packages/freedesktop.scm | 5 ++---
2 files changed, 13 insertions(+), 7 deletions(-)

--
2.26.2
B
B
Brice Waegeneire wrote on 14 May 2020 00:25
[PATCH 1/5] gnu: udisks: Update to 2.8.4.
(address . guix-patches@gnu.org)
20200513222542.29411-1-brice@waegenei.re
* gnu/packages/freedesktop.scm (udisks): Update to 2.8.4.
---
gnu/packages/freedesktop.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 7e7e8350ea..cec3b9ef4d 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -897,7 +897,7 @@ Analysis and Reporting Technology) functionality.")
(define-public udisks
(package
(name "udisks")
- (version "2.7.7")
+ (version "2.8.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -905,7 +905,7 @@ Analysis and Reporting Technology) functionality.")
version "/udisks-" version ".tar.bz2"))
(sha256
(base32
- "1dnlxqgy9v0mjdknv3b1s64szdykyk3hk0rxj3chwhpd415lrwgs"))))
+ "06cq52kp1nyy15qzylywy9s7hhhqc45k0s3y68crf0zsmjyng0yj"))))
(build-system gnu-build-system)
(native-inputs
`(("docbook-xml" ,docbook-xml-4.3) ; to build the manpages
--
2.26.2
B
B
Brice Waegeneire wrote on 14 May 2020 00:25
[PATCH 2/5] gnu: udisks: Appease guix lint.
(address . guix-patches@gnu.org)
20200513222542.29411-2-brice@waegenei.re
The line is too long and HTML docs are build fine without it.

* gnu/packages/freedesktop.scm (udisks)[arguments]: Remove configure
flag '--enable-gtk-doc'.
---
gnu/packages/freedesktop.scm | 1 -
1 file changed, 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index cec3b9ef4d..fc0a005ee8 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -934,7 +934,6 @@ Analysis and Reporting Technology) functionality.")
#:disallowed-references ("doc") ;enforce separation of "doc"
#:configure-flags
(list "--enable-man"
- "--enable-gtk-doc" ; Without this the HTML doc does not seem to build automatically.
"--enable-available-modules" ; Such as lvm2, btrfs, etc.
"--localstatedir=/var"
"--enable-fhs-media" ;mount devices in /media, not /run/media
--
2.26.2
B
B
Brice Waegeneire wrote on 14 May 2020 00:25
[PATCH 4/5] gnu: libblockdev: Add input 'xfsprogs'.
(address . guix-patches@gnu.org)
20200513222542.29411-4-brice@waegenei.re
* gnu/packages/disk.scm (libblockdev)[inputs]: Add 'xfsprogs'.
---
gnu/packages/disk.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index e410e29e88..346a912cf4 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -823,8 +823,7 @@ to create devices with respective mappings for the ATARAID sets discovered.")
("nss" ,nss)
("parted" ,parted)
("volume-key" ,volume-key)
- ;; ("xfsprogs" ,xfsprogs) ; TODO: Package?
- ))
+ ("xfsprogs" ,xfsprogs)))
(home-page "https://github.com/storaged-project/libblockdev")
(synopsis "Library for manipulating block devices")
(description
--
2.26.2
B
B
Brice Waegeneire wrote on 14 May 2020 00:25
[PATCH 3/5] gnu: libblockdev: Appease guix lint.
(address . guix-patches@gnu.org)
20200513222542.29411-3-brice@waegenei.re
* gnu/packages/disk.scm (libblockdev)[inputs]: Move
'gobject-introspection' to ...
[native-inputs]: ... here.
---
gnu/packages/disk.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 5c82ccd577..e410e29e88 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -803,7 +803,8 @@ to create devices with respective mappings for the ATARAID sets discovered.")
"15c7g2gbkahmy8c6677pvbvblan5h8jxcqqmn6nlvqwqynq2mkjm"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)
("python" ,python-wrapper)
("util-linux" ,util-linux)))
(inputs
@@ -813,7 +814,6 @@ to create devices with respective mappings for the ATARAID sets discovered.")
("dmraid" ,dmraid)
("eudev" ,eudev)
("glib" ,glib)
- ("gobject-introspection" ,gobject-introspection)
("kmod" ,kmod)
("libbytesize" ,libbytesize)
("libyaml" ,libyaml)
--
2.26.2
B
B
Brice Waegeneire wrote on 14 May 2020 00:25
[PATCH 5/5] gnu: libblockdev: Set default configuration directory.
(address . guix-patches@gnu.org)
20200513222542.29411-5-brice@waegenei.re
Fix error from 'udisks': “Failed to get contents of the config
dir (/etc/libblockdev/conf.d/)Error opening directory
"/etc/libblockdev/conf.d/": No such file or directory.”

* gnu/packages/disk.scm (libblockdev)[arguments]: Add phase
'patch-configuration-directory'.
---
gnu/packages/disk.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 346a912cf4..a5f4d4f7a6 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -802,6 +802,14 @@ to create devices with respective mappings for the ATARAID sets discovered.")
(base32
"15c7g2gbkahmy8c6677pvbvblan5h8jxcqqmn6nlvqwqynq2mkjm"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-configuration-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "src/lib/blockdev.c"
+ (("/etc/libblockdev/conf.d/" path) (string-append out path)))))))))
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
--
2.26.2
E
E
Efraim Flashner wrote on 14 May 2020 10:25
Re: [bug#41247] [PATCH 0/5] Fix and update udisks
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 41247@debbugs.gnu.org)
20200514082511.GO918@E5400
On Thu, May 14, 2020 at 12:24:09AM +0200, Brice Waegeneire wrote:
Toggle quote (17 lines)
> This patchset update udisks and fix a startup error.
>
> Brice Waegeneire (5):
> gnu: udisks: Update to 2.8.4.
> gnu: udisks: Appease guix lint.
> gnu: libblockdev: Appease guix lint.
> gnu: libblockdev: Add input 'xfsprogs'.
> gnu: libblockdev: Set default configuration directory.
>
> gnu/packages/disk.scm | 15 +++++++++++----
> gnu/packages/freedesktop.scm | 5 ++---
> 2 files changed, 13 insertions(+), 7 deletions(-)
>
> --
> 2.26.2
>

$ guix gc --references /gnu/store/g6pv8jfhi3m6a2wnvlwjcx4i3hjihnra-libblockdev-2.23 | grep xfs

it doesn't look like it actually links in xfs support. I see from the
configure output that the FS plugin is built and installed in %out/lib.
Does it work on xfs formatted partitions without linking to xfsprogs?

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl69AGcACgkQQarn3Mo9
g1FcyRAAsaGyLwQ9gmCOJ/Ztlg4DRoQD12ZADsw9/Qjqvb2NYza/l9Em2I0/mmIH
ohO7IRFWOX9aj5GrLqIxu3ebV8wdD4apVDjtfHA+/gA0C0Dmf1PpivJmIDRTmG7T
3i6MQvlIdGonNs6OINHPe4qTXnSqOlODJI1uYcTb/LDIBTyUSqc0wkg7XPiYkC8G
3v1eVSexOnQeI/9kUU/ghPFskRZD6h143+eBaXuApSg6QdmI3NgQlJXqD87d49wo
X7KxiD744hr2q9ewQfHzHe95BZSe/Bur1v2RDhP3+mi4/PRMRf+9avNt3z7FJ8BE
GiUlekEFb5VW4eZLMdDfos+UQdmsWMbdK8XWotWqyhzDm4NnyByRQKi3TdXj76J5
/AiWtkGGRE/GJ6+o/o9ryiO+KEuS10I/3kMg6L9mUwjrhEWD1+EV7Qd71WHisYF0
XKLxwoAnSJBEz2ygrLy8vGvebiCbtLnzNph4kagrYY9zA7A9huQRE5b38jSd3KXB
bMFCq038VATVaxtyg49raS8mR4Gqm7+0DAH8FUpsIXMvRvLN1ARGdSdEZVkZP6Ts
Su+XZL6cgBx5NYB7wL49EbfIFGneUYdvONQ9VVj28B5zPAo27YT8F/jGCnZOOBzX
I4DN4eqWXJ86PveSH6McaOPhBl/qRTZR/sD784SlK3BaqiS7xrg=
=4gW7
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 14 May 2020 10:34
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 41247@debbugs.gnu.org)
20200514083415.GP918@E5400
I pushed all the patches except for the xfs one. Let me know if it works
:)

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl69AocACgkQQarn3Mo9
g1EojQ//Z2w8ykPq+9zLAd9igwHJIPqg9fgAEnyb2lWRWZ2crex6j7x7lNgVb37R
qpWsUWyOgnWSu6liG0KCVuMyURS1If61bR6Y1NTQpYKnnSyTyCCVeUQCU7OBUM27
Uo+0K2LBV0txb7TgiHbR6gtqXbPYR6R8V2wvwKfvNHpPmzBHe7vSWnsreMr0ag96
xsQm4Fu+d7c7E4cSM3lvKgajrvyPeJy6Iaun6Nv51fjPqF099hZoRnlQUzt2MUkc
uqC9t9G+xnYOKqmfZpdnCJq3LAu4jaxUuBPSBpete3mRQBbrejGfxZ/HQvDN1+XG
GpFBp+/RXA7p05+WPffcIKBZ8uWIFYI9nPwpLkHCkwLf/cd46TVcDqbrerZ+u1vG
jOieV40bocevnHxC7UNeZ1UmTlXmiiujqzwJJg4mwRPzYXTR/ln3xAnsMAgho4ru
3usfSh0v1QaKSA3hb8HzBW+SnjyXNDsus9iCUlcCs/R+MZ/wZ0EMrAxTw8Hr0Eue
qj2EZlzpyD051qWNZOMqIz/Rnw+e1NazTC68AqnVu8V/62PXjGKVoPHp4nkh0O+3
9T29jZuPyg/6u1/5/gigCxGzY9NEh6e8TFk34XK7FNXdkoTO32/C9LaKVSqrR2gW
POLqSQbRiJyF8+uAx78Lr6GwdX2DMOAF+6FXGncB0NdfnIy6ya4=
=eNo1
-----END PGP SIGNATURE-----


B
B
Brice Waegeneire wrote on 14 May 2020 15:50
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 41247@debbugs.gnu.org)
0b6fad5ea8de541c864fe882d246d3ff@waegenei.re
Hello Efraim,

On 2020-05-14 08:25, Efraim Flashner wrote:
Toggle quote (7 lines)
> $ guix gc --references
> /gnu/store/g6pv8jfhi3m6a2wnvlwjcx4i3hjihnra-libblockdev-2.23 | grep xfs
>
> it doesn't look like it actually links in xfs support. I see from the
> configure output that the FS plugin is built and installed in %out/lib.
> Does it work on xfs formatted partitions without linking to xfsprogs?

Listing all the references, 'btrfs-progs', 'dosfstools' and 'mdam' are
also
not linked but are present as inputs.

Toggle snippet (30 lines)
/gnu/store/01b4w3m6mp55y531kyi1g8shh722kwqm-gcc-7.5.0-lib
/gnu/store/33y7wsvfh3i6mq9h7812pwagj8p2lrfd-libyaml-0.2.4
/gnu/store/35afkywncrr5xsb4cxcljf6rpjcb7f61-gmp-6.2.0
/gnu/store/5jf395qa3v4amdi60850rz2a15zlsrza-mpfr-4.0.2
/gnu/store/5ydgg6rd9vqw0hf4a7ji65y4yw3ja665-lvm2-2.03.09
/gnu/store/7ykddq56ssyqm1win3jlxm3ran94kq3q-libbytesize-2.2
/gnu/store/9g1nq7qf5mkhbyjcyc0d7g9j02x3sdl2-argon2-20190702
/gnu/store/9rk1sdzb9lqsi38knfi2pq5gqxfxi8d0-libgpg-error-1.37
/gnu/store/9rvf68qxkq14sxajdp4gf8qqa026bjj2-kmod-26
/gnu/store/a45p39mgqvfd8kjwibyr0q42k1mw7gmf-util-linux-2.35.1-lib
/gnu/store/bjp2vcbdsmckv2b4f69bci1z9n0i43b6-eudev-3.2.9
/gnu/store/cbrx0nl7qwrz1j3r19ylahrgilyr1n83-json-c-0.13.1
/gnu/store/dh5klm7h2nh930lj3kgiaqkqd8vpvjaa-parted-3.3
/gnu/store/dp0q63a7ykqwsfwn1c1wx81ak51l0vp3-ndctl-68
/gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-2.31
/gnu/store/g6pv8jfhi3m6a2wnvlwjcx4i3hjihnra-libblockdev-2.23
/gnu/store/gfpgqvwrixhf3sf1bnzsfxzvld0nd8b7-nss-3.50
/gnu/store/j9agmxk8iyjba4wvvam056s4n3phlg6h-gpgme-1.13.1
/gnu/store/n2r0q34y5bjj3vd65p6nb64dghbgka01-volume-key-0.3.12
/gnu/store/p2hkmh8rfw9qaspxlf0yd4qp1hzj0bc8-cryptsetup-2.2.2
/gnu/store/q7hba8fqpix98qwcpf64izsf4wqhv1ij-libassuan-2.5.3
/gnu/store/qc3k3kd458pgrqsc7ih641160q81npwq-libgcrypt-1.8.5
/gnu/store/qvahafxrr2mcl4anjxdkkprrvd4k0xjj-pcre2-10.34
/gnu/store/r7k859hmcnkazf492fasqvk25jflnfk6-xz-5.2.4
/gnu/store/rmbxm1fg47b347kv1h5fb2w04nxqbsj6-glib-2.62.6
/gnu/store/rykm237xkmq7rl1p0nwass01p090p88x-zlib-1.2.11
/gnu/store/sdh81ijcxqlkns1c48lsdripfj34fmwq-dmraid-1.0.0.rc16-3
/gnu/store/vqajm09by8dxxfl1fd7n45blfhzyg1gm-nspr-4.25

libblockdev seems to use the commands provided by those packages[0].
They, including 'xfs', should be in the propagated-inputs field, right?

[0]:

- Brice
B
B
Brice Waegeneire wrote on 14 May 2020 18:16
[PATCH v2] gnu: libblockdev: Move filesystems utilities to 'propagated-inputs'
(address . guix-patches@gnu.org)(address . efraim@flashner.co.il)
20200514161612.24372-1-brice@waegenei.re
* gnu/packages/disk.scm (libblockdev)[inputs]: Move 'btrfs'progs',
'dosfstools', 'mdadm' to ...
[propagated-inputs]: ... here and add 'xfsprogs'.
---
gnu/packages/disk.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 6b86f6ff76..aec2519c74 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -810,15 +810,18 @@ to create devices with respective mappings for the ATARAID sets discovered.")
(let ((out (assoc-ref outputs "out")))
(substitute* "src/lib/blockdev.c"
(("/etc/libblockdev/conf.d/" path) (string-append out path)))))))))
+ (propagated-inputs
+ `(("btrfs-progs" ,btrfs-progs)
+ ("dosfstools" ,dosfstools)
+ ("mdadm" ,mdadm)
+ ("xfsprogs" ,xfsprogs)))
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)
("util-linux" ,util-linux)))
(inputs
- `(("btrfs-progs" ,btrfs-progs)
- ("cryptsetup" ,cryptsetup)
- ("dosfstools" ,dosfstools)
+ `(("cryptsetup" ,cryptsetup)
("dmraid" ,dmraid)
("eudev" ,eudev)
("glib" ,glib)
@@ -826,13 +829,10 @@ to create devices with respective mappings for the ATARAID sets discovered.")
("libbytesize" ,libbytesize)
("libyaml" ,libyaml)
("lvm2" ,lvm2)
- ("mdadm" ,mdadm)
("ndctl" ,ndctl)
("nss" ,nss)
("parted" ,parted)
- ("volume-key" ,volume-key)
- ;; ("xfsprogs" ,xfsprogs) ; TODO: Package?
- ))
+ ("volume-key" ,volume-key)))
(home-page "https://github.com/storaged-project/libblockdev")
(synopsis "Library for manipulating block devices")
(description
--
2.26.2
E
E
Efraim Flashner wrote on 19 May 2020 10:24
Re: [bug#41247] [PATCH 0/5] Fix and update udisks
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 41247@debbugs.gnu.org)
20200519082451.GK18220@E5400
On Thu, May 14, 2020 at 01:50:50PM +0000, Brice Waegeneire wrote:
Toggle quote (51 lines)
> Hello Efraim,
>
> On 2020-05-14 08:25, Efraim Flashner wrote:
> > $ guix gc --references
> > /gnu/store/g6pv8jfhi3m6a2wnvlwjcx4i3hjihnra-libblockdev-2.23 | grep xfs
> >
> > it doesn't look like it actually links in xfs support. I see from the
> > configure output that the FS plugin is built and installed in %out/lib.
> > Does it work on xfs formatted partitions without linking to xfsprogs?
>
> Listing all the references, 'btrfs-progs', 'dosfstools' and 'mdam' are also
> not linked but are present as inputs.
>
> --8<---------------cut here---------------start------------->8---
> /gnu/store/01b4w3m6mp55y531kyi1g8shh722kwqm-gcc-7.5.0-lib
> /gnu/store/33y7wsvfh3i6mq9h7812pwagj8p2lrfd-libyaml-0.2.4
> /gnu/store/35afkywncrr5xsb4cxcljf6rpjcb7f61-gmp-6.2.0
> /gnu/store/5jf395qa3v4amdi60850rz2a15zlsrza-mpfr-4.0.2
> /gnu/store/5ydgg6rd9vqw0hf4a7ji65y4yw3ja665-lvm2-2.03.09
> /gnu/store/7ykddq56ssyqm1win3jlxm3ran94kq3q-libbytesize-2.2
> /gnu/store/9g1nq7qf5mkhbyjcyc0d7g9j02x3sdl2-argon2-20190702
> /gnu/store/9rk1sdzb9lqsi38knfi2pq5gqxfxi8d0-libgpg-error-1.37
> /gnu/store/9rvf68qxkq14sxajdp4gf8qqa026bjj2-kmod-26
> /gnu/store/a45p39mgqvfd8kjwibyr0q42k1mw7gmf-util-linux-2.35.1-lib
> /gnu/store/bjp2vcbdsmckv2b4f69bci1z9n0i43b6-eudev-3.2.9
> /gnu/store/cbrx0nl7qwrz1j3r19ylahrgilyr1n83-json-c-0.13.1
> /gnu/store/dh5klm7h2nh930lj3kgiaqkqd8vpvjaa-parted-3.3
> /gnu/store/dp0q63a7ykqwsfwn1c1wx81ak51l0vp3-ndctl-68
> /gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-2.31
> /gnu/store/g6pv8jfhi3m6a2wnvlwjcx4i3hjihnra-libblockdev-2.23
> /gnu/store/gfpgqvwrixhf3sf1bnzsfxzvld0nd8b7-nss-3.50
> /gnu/store/j9agmxk8iyjba4wvvam056s4n3phlg6h-gpgme-1.13.1
> /gnu/store/n2r0q34y5bjj3vd65p6nb64dghbgka01-volume-key-0.3.12
> /gnu/store/p2hkmh8rfw9qaspxlf0yd4qp1hzj0bc8-cryptsetup-2.2.2
> /gnu/store/q7hba8fqpix98qwcpf64izsf4wqhv1ij-libassuan-2.5.3
> /gnu/store/qc3k3kd458pgrqsc7ih641160q81npwq-libgcrypt-1.8.5
> /gnu/store/qvahafxrr2mcl4anjxdkkprrvd4k0xjj-pcre2-10.34
> /gnu/store/r7k859hmcnkazf492fasqvk25jflnfk6-xz-5.2.4
> /gnu/store/rmbxm1fg47b347kv1h5fb2w04nxqbsj6-glib-2.62.6
> /gnu/store/rykm237xkmq7rl1p0nwass01p090p88x-zlib-1.2.11
> /gnu/store/sdh81ijcxqlkns1c48lsdripfj34fmwq-dmraid-1.0.0.rc16-3
> /gnu/store/vqajm09by8dxxfl1fd7n45blfhzyg1gm-nspr-4.25
> --8<---------------cut here---------------end--------------->8---
>
> libblockdev seems to use the commands provided by those packages[0].
> They, including 'xfs', should be in the propagated-inputs field, right?
>
> [0]: https://github.com/storaged-project/libblockdev/blob/master/src/plugins/fs/xfs.c#L45-L51
>
> - Brice

So to summarize some of our conversation yesterday on IRC, we don't need
to have some of the filesystem utilities as build inputs while building
libblockdev. Libblockdev shells out to the different utilities to make
use of their programs while interacting with the file systems.

We'd rather not propagate all the file system utilities. We could patch
the code itself in libblockdev so that when it shells out we give it the
a path to the store where that program lives. We could add a note to
libblockdev or udisks in the description telling people to install other
programs if they need more functionality. Another option is to wrap
udisks in the various filesystem programs so that they're available for
use by libblockdev.

I don't like the magic of "it works with udisks but not when I try it
manually", but I do like it when packages just work. I don't like the
idea of adding the note to libblockdev's description. I know I wouldn't
look there if udisks didn't work the way I expected. If udisks didn't
work the way I expected I don't know I'd check the description of the
package.

Currently udisks is the only package that uses libblockdev so
functionally there's not a lot of difference between wrapping udisks or
patching libblockdev, but that would change if other programs started
using libbockdev. I'm concerned about the maintenance cost of patching
libblockdev and making sure that the substitutions would need to be
re-checked on each update, but it seems like the best method for making
sure everything will just work.

I think our best option is to patch libblockdev to provide absolute
paths to the different binaries so that any program using libblockdev
will just work.

What do you think about that change?

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl7Dl9AACgkQQarn3Mo9
g1FRRw/+J50XdhVayxj2hpk/HQIBaFs3FpUC3yzPJW7NiM5M+cvepLicPCe5lVI9
walb+1MuKJSGeQD1JXWj5/pJecvYbg7UFXFB9mfusoI9+x6kGdR+mK0St8MPy1bb
HMTKjCLaxCnEDHDd2wgbcwBYLR2bKXKYLf/bsGxVPhPoxc43+q0TdpcIyHJesQpS
WBK04PqfihANN51Gui326NPBZumiuTBYjIJeGqcunt568yIJr/uuwn4d+6mrmTmy
Ctesit6NL8ym4KN+cJ6EKesKL70KiVfy3p1l5WnZJ/S8dI+w8YDk6VT4XljOHM6t
3uWt9C/gYwEl3oPcOvHMBYuPPvBCCOd3s88L1bWe1njW2c7CtxSzKAsWLzsRLyw3
bTvQiyyBLJJLlf4BgnwaccWdH2Su/i5Po9Vf7zhx3PrcmhcOrEDcS9fpt1vvfLnK
64uyZav5fzO7cwSoOWc6VkYFMq2pocbDWI85WdjHQB5npkx+NSn/Nk5x60QjNIPH
IGPos74LZiLtqYWqaOv8HC9pxVzU7WSCz/kJeNivZI6h6qQ9OtS00xpnnENsnRM0
TKZmP11VnJrSKDnh0bhsZv76lH8FKB7qN3nF1wErXiTGa85gcCpXA6sjNa2Pkntj
f5eFn6rJ/OMUi40/YNW4meFYeVdGMrZYREyYqXvDS9pTBKXH6U4=
=/qQz
-----END PGP SIGNATURE-----


M
M
Maxim Cournoyer wrote on 28 Sep 2022 22:09
Re: bug#41247: [PATCH 0/5] Fix and update udisks
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87pmffs1ll.fsf_-_@gmail.com
Hello,

Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (3 lines)
> I pushed all the patches except for the xfs one. Let me know if it works
> :)

I see xfsprogs is now an input to libblockdev. Closing.

Thanks,

Maxim
Closed
?