xorg-configuration->file doesn't honor xorg-configuration-server

  • Done
  • quality assurance status badge
Details
2 participants
  • Caleb Ristvedt
  • Ludovic Courtès
Owner
unassigned
Submitted by
Caleb Ristvedt
Severity
normal
C
C
Caleb Ristvedt wrote on 24 Apr 2020 03:14
(address . bug-guix@gnu.org)
87blnh4rck.fsf@cune.org
Suppose that one specifies a custom xorg-server package to use in an
<xorg-configuration> record, like so:

(xorg-configuration
(server xorg-server-for-debugging))

the correct bin/X will be run, but the wrong modules will be specified
in xserver.conf - the default xorg-server will always be used for
these. This is because in gnu/services/xorg.scm, in
xorg-configuration->file, we simply hard-code xorg-server to refer to
the one from (gnu packages xorg) and ignore the one specified in the
configuration entirely.

We shouldn't do this. It should be enough to just wrap the current
contents with

(let ((xorg-server (xorg-configuration-server config)))
...)

to make it work.

Then I can improve my xorg bug report :-)

- reepca
C
C
Caleb Ristvedt wrote on 2 Jun 2020 14:01
(address . 40806@debbugs.gnu.org)
87blm17k3j.fsf@cune.org
If it helps, here's a patch that makes the trivial change.

- reepca
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdNapMPRLm4SepVYGwWaqSV9/GJwFAl7WP4AACgkQwWaqSV9/
GJwBTwf/cykuoXqmdIcCipWE1crV1HXMtMFLqGuxjP2F77CqE00gXVYUFoMCvJyn
fr6CxWU/gYvRPL4+90XRx43dm8HdF8N3EOkbhtMxeSVMF+Na16CRkJaegmgsgycS
oVkS8YknRvuNCjNUdIjd2VYAJ0nwB3VPgBoO8sopg9LytvRJd0HYhY2bHdpPyu4G
mX6fXu8ycif6m28furu4c3x7tnVROmxKlqr2csYhKrROJ3Wkpo5x2l2jcFDnNtw2
Rrey39ImibrnIRng0KkGIEFwDU2xKDd5fmNsRQKq5roS49GerHMka8uHGrbGkOy/
Rmm3pppbvdvYMgt8InX5zKGUqsN24Q==
=HEeo
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 4 Jun 2020 14:11
(name . Caleb Ristvedt)(address . caleb.ristvedt@cune.org)(address . 40806@debbugs.gnu.org)
871rmvc9on.fsf@gnu.org
Hi,

Caleb Ristvedt <caleb.ristvedt@cune.org> skribis:

Toggle quote (6 lines)
> From e1071c830ce511eecd57617a3f188740fd49d703 Mon Sep 17 00:00:00 2001
> From: Caleb Ristvedt <caleb.ristvedt@cune.org>
> Date: Tue, 2 Jun 2020 06:28:46 -0500
> Subject: [PATCH] xorg: honor xorg-configuration-server in
> xorg-configuration->file

Please add “Fixes https://bugs.gnu.org/40806.”

Toggle quote (9 lines)
> Previously the xorg-server package specified in the configuration was ignored
> entirely in xorg-configuration->file. This had the effect that while the X
> program of the configured package would be executed, the modules of the
> configured package would be ignored in favor of the default xorg-server
> package's modules. This fixes that.
>
> * gnu/services/xorg.scm (xorg-configuration->file): honor
> xorg-configuration-server.

LGTM, thanks!

Ludo’.
C
C
Caleb Ristvedt wrote on 4 Jun 2020 14:33
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 40806@debbugs.gnu.org)
87wo4n57tu.fsf@cune.org
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (12 lines)
> Hi,
>
> Caleb Ristvedt <caleb.ristvedt@cune.org> skribis:
>
>> From e1071c830ce511eecd57617a3f188740fd49d703 Mon Sep 17 00:00:00 2001
>> From: Caleb Ristvedt <caleb.ristvedt@cune.org>
>> Date: Tue, 2 Jun 2020 06:28:46 -0500
>> Subject: [PATCH] xorg: honor xorg-configuration-server in
>> xorg-configuration->file
>
> Please add “Fixes <https://bugs.gnu.org/40806>.”

Done.

Toggle quote (11 lines)
>> Previously the xorg-server package specified in the configuration was ignored
>> entirely in xorg-configuration->file. This had the effect that while the X
>> program of the configured package would be executed, the modules of the
>> configured package would be ignored in favor of the default xorg-server
>> package's modules. This fixes that.
>>
>> * gnu/services/xorg.scm (xorg-configuration->file): honor
>> xorg-configuration-server.
>
> LGTM, thanks!

Pushed as 8b158e8b2cd0293eeebe73f5a71f0c513a89d606.

- reepca
C
C
Caleb Ristvedt wrote on 4 Jun 2020 14:34
done
(address . 40806-done@debbugs.gnu.org)
87sgfb57sx.fsf@cune.org
done
Closed
L
L
Ludovic Courtès wrote on 5 Jun 2020 18:10
Re: bug#40806: xorg-configuration->file doesn't honor xorg-configuration-server
(name . Caleb Ristvedt)(address . caleb.ristvedt@cune.org)(address . 40806-done@debbugs.gnu.org)
874krp4ho8.fsf@gnu.org
Caleb Ristvedt <caleb.ristvedt@cune.org> skribis:

Toggle quote (29 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hi,
>>
>> Caleb Ristvedt <caleb.ristvedt@cune.org> skribis:
>>
>>> From e1071c830ce511eecd57617a3f188740fd49d703 Mon Sep 17 00:00:00 2001
>>> From: Caleb Ristvedt <caleb.ristvedt@cune.org>
>>> Date: Tue, 2 Jun 2020 06:28:46 -0500
>>> Subject: [PATCH] xorg: honor xorg-configuration-server in
>>> xorg-configuration->file
>>
>> Please add “Fixes <https://bugs.gnu.org/40806>.”
>
> Done.
>
>>> Previously the xorg-server package specified in the configuration was ignored
>>> entirely in xorg-configuration->file. This had the effect that while the X
>>> program of the configured package would be executed, the modules of the
>>> configured package would be ignored in favor of the default xorg-server
>>> package's modules. This fixes that.
>>>
>>> * gnu/services/xorg.scm (xorg-configuration->file): honor
>>> xorg-configuration-server.
>>
>> LGTM, thanks!
>
> Pushed as 8b158e8b2cd0293eeebe73f5a71f0c513a89d606.

Great, closing!
Closed
?