gnu: font-gnu-freefont: Add otf and woff font types.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Christopher Baines
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
Raghav Gururajan wrote on 19 Apr 2020 06:13
(address . guix-patches@gnu.org)
20200419001305.427681a9.raghavgururajan@disroot.org

From 0708899aef39921a338b77ebc772607963b89ca4 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sun, 19 Apr 2020 00:06:35 -0400
Subject: [PATCH] gnu: font-gnu-freefont: Add otf and woff font types.

* gnu/packages/fonts.scm (font-gnu-freefont): Add otf and woff font types.
---
gnu/packages/fonts.scm | 34 ++++++++++++++++++++++++++--------
1 file changed, 26 insertions(+), 8 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index dbc0c4f9d6..f06f5bcc60 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -230,9 +230,9 @@ The Lato 2.010 family supports more than 100 Latin-based languages, over
50 Cyrillic-based languages as well as Greek and IPA phonetics.")
(license license:silofl1.1)))
-(define-public font-gnu-freefont-ttf
+(define-public font-gnu-freefont
(package
- (name "font-gnu-freefont-ttf")
+ (name "font-gnu-freefont")
(version "20120503")
(source (origin
(method url-fetch)
@@ -249,18 +249,36 @@ The Lato 2.010 family supports more than 100 Latin-based languages, over
(lambda _
(let ((doc-dir (string-append %output "/share/doc/"
,name "-" ,version))
- (font-dir (string-append %output
- "/share/fonts/truetype")))
+ (ttf-font-dir (string-append %output
+ "/share/fonts/ttf"))
+ (otf-font-dir (string-append %output
+ "/share/fonts/otf"))
+ (woff-font-dir (string-append %output
+ "/share/fonts/woff")))
(mkdir-p doc-dir)
(substitute* "Makefile"
(("\\$\\(TMPDIR\\)") doc-dir)
- (("sfd/\\*.ttf") ""))
- (system* "make" "ttftar")
- (mkdir-p font-dir)
+ (("sfd/\\*.ttf") "")
+ (("sfd/\\*.otf") "")
+ (("sfd/\\*.woff") ""))
+ (system* "make" "ttftar" "otftar" "wofftar")
+ (mkdir-p ttf-font-dir)
+ (mkdir-p otf-font-dir)
+ (mkdir-p woff-font-dir)
(for-each (lambda (file)
- (install-file file font-dir))
+ (install-file file ttf-font-dir))
(filter
(lambda (file) (string-suffix? "ttf" file))
+ (find-files "." "")))
+ (for-each (lambda (file)
+ (install-file file otf-font-dir))
+ (filter
+ (lambda (file) (string-suffix? "otf" file))
+ (find-files "." "")))
+ (for-each (lambda (file)
+ (install-file file woff-font-dir))
+ (filter
+ (lambda (file) (string-suffix? "woff" file))
(find-files "." "")))))))
#:test-target "tests"))
;; replace python 3 with python 2
--
2.26.1
R
R
Raghav Gururajan wrote on 19 Apr 2020 06:51
gnu: Add otf and woff font formats for GNU Freefont. (v2)
(address . 40707@debbugs.gnu.org)
20200419005154.311cf90e.raghavgururajan@disroot.org

From 43fa86b94a4f814b5607113e91aa0f82a33ec8f5 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Sun, 19 Apr 2020 00:47:03 -0400
Subject: [PATCH] gnu: Add otf and woff font formats for GNU Freefont.

* gnu/packages/fonts.scm (font-gnu-freefont): Add otf and woff font formats.
* gnu/packages/genealogy.scm (gramps): Change input name of GNU Freefont.
---
gnu/packages/fonts.scm | 35 +++++++++++++++++++++++++++--------
gnu/packages/genealogy.scm | 2 +-
2 files changed, 28 insertions(+), 9 deletions(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index dbc0c4f9d6..0356d50c7c 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2020 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -230,9 +231,9 @@ The Lato 2.010 family supports more than 100 Latin-based languages, over
50 Cyrillic-based languages as well as Greek and IPA phonetics.")
(license license:silofl1.1)))
-(define-public font-gnu-freefont-ttf
+(define-public font-gnu-freefont
(package
- (name "font-gnu-freefont-ttf")
+ (name "font-gnu-freefont")
(version "20120503")
(source (origin
(method url-fetch)
@@ -249,18 +250,36 @@ The Lato 2.010 family supports more than 100 Latin-based languages, over
(lambda _
(let ((doc-dir (string-append %output "/share/doc/"
,name "-" ,version))
- (font-dir (string-append %output
- "/share/fonts/truetype")))
+ (ttf-font-dir (string-append %output
+ "/share/fonts/ttf"))
+ (otf-font-dir (string-append %output
+ "/share/fonts/otf"))
+ (woff-font-dir (string-append %output
+ "/share/fonts/woff")))
(mkdir-p doc-dir)
(substitute* "Makefile"
(("\\$\\(TMPDIR\\)") doc-dir)
- (("sfd/\\*.ttf") ""))
- (system* "make" "ttftar")
- (mkdir-p font-dir)
+ (("sfd/\\*.ttf") "")
+ (("sfd/\\*.otf") "")
+ (("sfd/\\*.woff") ""))
+ (system* "make" "ttftar" "otftar" "wofftar")
+ (mkdir-p ttf-font-dir)
+ (mkdir-p otf-font-dir)
+ (mkdir-p woff-font-dir)
(for-each (lambda (file)
- (install-file file font-dir))
+ (install-file file ttf-font-dir))
(filter
(lambda (file) (string-suffix? "ttf" file))
+ (find-files "." "")))
+ (for-each (lambda (file)
+ (install-file file otf-font-dir))
+ (filter
+ (lambda (file) (string-suffix? "otf" file))
+ (find-files "." "")))
+ (for-each (lambda (file)
+ (install-file file woff-font-dir))
+ (filter
+ (lambda (file) (string-suffix? "woff" file))
(find-files "." "")))))))
#:test-target "tests"))
;; replace python 3 with python 2
diff --git a/gnu/packages/genealogy.scm b/gnu/packages/genealogy.scm
index 869f69add8..79b24ed048 100644
--- a/gnu/packages/genealogy.scm
+++ b/gnu/packages/genealogy.scm
@@ -55,7 +55,7 @@
("intltool" ,intltool)))
(inputs
`(("cairo" ,cairo)
- ("font-gnu-freefont-ttf" ,font-gnu-freefont-ttf)
+ ("font-gnu-freefont" ,font-gnu-freefont)
("geocode-glib" ,geocode-glib)
("gexiv2" ,gexiv2)
("ghostscript" ,ghostscript)
--
2.26.1
R
L
L
Leo Famulari wrote on 22 Apr 2020 21:12
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40707@debbugs.gnu.org)
20200422191203.GA22123@jasmine.lan
On Wed, Apr 22, 2020 at 03:07:01PM -0400, Raghav Gururajan wrote:
Toggle quote (2 lines)
> + (system* "make" "ttftar" "otftar" "wofftar")

As discussed on IRC, this command actually fails, like this:

------
tar czvf freefont-ttf-20200422.tar.gz freefont-20200422/
tar: freefont-20200422: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors
make: *** [Makefile:64: ttftar] Error 2
phase `install' succeeded after 0.2 seconds
------

The issue is uncovered when running (invoke "make" ...).

Can you take a look?
C
C
Christopher Baines wrote on 21 Nov 2020 11:29
(name . Raghav Gururajan)(address . raghavgururajan@disroot.org)(address . 40707@debbugs.gnu.org)
875z5zhukn.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (17 lines)
> On Wed, Apr 22, 2020 at 03:07:01PM -0400, Raghav Gururajan wrote:
>> + (system* "make" "ttftar" "otftar" "wofftar")
>
> As discussed on IRC, this command actually fails, like this:
>
> ------
> tar czvf freefont-ttf-20200422.tar.gz freefont-20200422/
> tar: freefont-20200422: Cannot stat: No such file or directory
> tar: Exiting with failure status due to previous errors
> make: *** [Makefile:64: ttftar] Error 2
> phase `install' succeeded after 0.2 seconds
> ------
>
> The issue is uncovered when running (invoke "make" ...).
>
> Can you take a look?

It's been a few months, is this patch still relevant?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+46/hfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfctA/8Cyt3Y96tKv/6rDZKimHzaUxc3O5YDIe7
GC4+enMTM9DAFkQ394tXCzEJlZuBvz+RM+gHk0tUcvwzZ/Kb205Ys2ATrfYFCC+l
Pwg5o1/oMnLHck60CpQWXDreEmGOiTRcenpGk0jO6LRLIwTqdfTXIpkSBnm8wm4/
G/Q54YOR9OIkhQZbdf7DkFpMPmWScXEo4vUi+MjpJlnSb9UfPbaAAgs5n7D4tPK6
aiIXu6N5DVqqEgavOA7zhTWet3QcRlGbNF87e3eAmkyTXo/G+2SY5BF3V2qpzdXn
WNyJ7fEiITcYfBsUwTjzIP/YA+oa9Qc80GU/vABJYoUueTZQ5Fou0hbuH4MQ9P3K
30y9PWKm+/HZ6FptmYUQgPmBBhGJKdSuezPGWpp938W49HJak3aa3GBB3S05GXaY
j3q2J0KJWVzasqdsueVy70qqg3e0rtBI5rwE79qvt6JIWanux/0WZV3IFhIbHl41
6NTxXKCa0n7nOIBI8o1p6I7+PmvqiCJ0tXes2DYCNzqkeKj6kU+F0eUsZF3ylj9+
juC2C7lOHwPLpsJX2dVX8WQOaaIScfrO323VZ6t0IAYu+IwEfmzLSrFdTePeMKrX
TEenJOIBmEWIZh0itESPHfDkEHc0B2IW/3/WOXk9LZnD60xuPEuEPo+rYCgcSkbI
bQGm5WmRTi0=
=ptVp
-----END PGP SIGNATURE-----

R
R
Raghav Gururajan wrote on 21 Nov 2020 22:31
(name . Christopher Baines)(address . mail@cbaines.net)(address . 40707@debbugs.gnu.org)
97ecb8076894fe2e22102fb2a271754d@disroot.org
Hi Chris!

Toggle quote (3 lines)
>
> It's been a few months, is this patch still relevant?

Nah! It's not relevant anymore. I'll close it.

Regards,
RG.
R
R
Raghav Gururajan wrote on 21 Nov 2020 22:32
(address . control@debbugs.gnu.org)
410285e2804354d7b6919d8740209baf@disroot.org
close 40707
?