[PATCH] gnu: Add emacs-xclip.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 19 Apr 2020 05:30
(address . guix-patches@gnu.org)
874ktgi23q.fsf@asu.edu
Hi Guix!

If you run Emacs in a terminal emulator then emacs-xclip will help with
clipboard integration. It transparently allows copy and pasting to and
from the system clipboard and the terminal Emacs.

Thanks!

John
From c7a1819ea3f2a57fd914f742a2f05a2acaf32731 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sat, 18 Apr 2020 20:11:07 -0700
Subject: [PATCH] gnu: Add emacs-xclip.

* gnu/packages/emacs-xyz.scm (emacs-xclip): New variable.
---
gnu/packages/emacs-xyz.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a9550ee112..c167b7838f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20264,6 +20264,28 @@ commands in @code{evil-mode}.")
Emacs windows and tmux panes.")
(license license:expat)))
+(define-public emacs-xclip
+ (package
+ (name "emacs-xclip")
+ (version "1.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/xclip-" version ".el"))
+ (sha256
+ (base32
+ "0i3i9kwfg8qmhcmqhhnrb1kljgwkccv63s9q1mjwqfjldyfh8j8i"))))
+ (build-system emacs-build-system)
+ (home-page
+ "http://elpa.gnu.org/packages/xclip.html")
+ (synopsis
+ "Copy and paste GUI clipboard from terminal Emacs")
+ (description
+ "Copy to and paste from the GUI clipboard when running Emacs in text
+terminal.")
+ (license license:gpl3+)))
+
(define-public emacs-xterm-color
(package
(name "emacs-xterm-color")
@@ -22534,4 +22556,3 @@ personal wiki.")
ASCII UML sequence diagrams in Emacs, which can be embedded in source code,
comments or emails.")
(license license:gpl3+))))
-
--
2.26.0
N
N
Nicolas Goaziou wrote on 22 Apr 2020 23:49
(name . John Soo)(address . jsoo1@asu.edu)(address . 40705-done@debbugs.gnu.org)
87zhb3kx77.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (2 lines)
> Subject: [PATCH] gnu: Add emacs-xclip.

Applied as 541ec4d6e80110a640eefa4e1041bb83f4f12421, thank you.

Toggle quote (4 lines)
> + (description
> + "Copy to and paste from the GUI clipboard when running Emacs in text
> +terminal.")

I reworded the description as it needs to contain full sentences.

Regards,

--
Nicolas Goaziou
Closed
?