[PATCH v2] gnu: add wf-recorder

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex McGrath
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Alex McGrath
Severity
normal
A
A
Alex McGrath wrote on 16 Apr 2020 22:55
(address . guix-patches@gnu.org)(name . Alex McGrath)(address . amk@amk.ie)
20200416205527.22890-1-amk@amk.ie
A v2 patch as i forgot to add a copyright notice, and forgot to change the homepage

---
gnu/packages/video.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 62cc423c09..72746ea2fb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Alex McGrath <amk@amk.ie>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3920,3 +3921,33 @@ work-in-progress, aiming to support video-on-demand and live streaming
applications. It only supports Intel-compatible CPUs (x86).")
(home-page "https://github.com/OpenVisualCloud/SVT-AV1")
(license license:bsd-2)))
+
+(define-public wf-recorder
+ (package
+ (name "wf-recorder")
+ (version "0.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ammen99/wf-recorder.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cw6kpcbl33wh95pvy32xrsrm6kkk1awccr3phyh885xjs3b3iim"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("pulseaudio" ,pulseaudio)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)
+ ("libx264" ,libx264)))
+ (home-page "https://github.com/ammen99/wf-recorder.git")
+ (synopsis "Screen recorder for wlroots-based compositors")
+ (description
+ "wf-recorder is a utility program for screen recording of wlroots-based
+compositors (more specifically, those that support wlr-screencopy-v1 and
+xdg-output)")
+ (license license:mit)))
--
2.26.0
M
M
Mathieu Othacehe wrote on 27 Apr 2020 18:24
(name . Alex McGrath)(address . amk@amk.ie)(address . 40673-done@debbugs.gnu.org)
878sigx5fa.fsf@gmail.com
Hello Alex,

Sorry for the delay. I changed the license, edited a bit the
description, added a Change-log compatible commit message and pushed!

Thanks,

Mathieu
Closed
?