[PATCH] installer: Fix backtrace display.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
M
M
Mathieu Othacehe wrote on 16 Apr 2020 19:33
(address . guix-patches@gnu.org)(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
20200416173354.11807-1-m.othacehe@gmail.com
The 'syslog' macro cannot be resolved in the pre-unwind-handler
context. Failed to resolve 'syslog' in this context resulted in the swallowing
of all installation errors.

Fixes 5c04b00cf463a543b8ffc9eb55991f6b4cc145dd.

* gnu/installer.scm (installer-program): Do not try to resolve 'syslog' macro
in the pre-unwind-handler.
---

Hello,

Since the commit 5c04b00c, error reporting in the installer is broken. Sadly
this means that every error happening in the 1.1.0 release will result in an
installer restart, without any error information reporting.

Thanks,

Mathieu

gnu/installer.scm | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/installer.scm b/gnu/installer.scm
index 1051ee1e5f..eba8a7d428 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -436,8 +436,9 @@ selected keymap."
#f)))
(const #f)
(lambda (key . args)
- (syslog "crashing due to uncaught exception: ~s ~s~%"
- key args)
+ ((@@ (gnu installer utils) syslog)
+ "crashing due to uncaught exception: ~s ~s~%"
+ key args)
(let ((error-file "/tmp/last-installer-error"))
(call-with-output-file error-file
(lambda (port)
--
2.26.0
L
L
Ludovic Courtès wrote on 17 Apr 2020 23:07
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(address . 40668@debbugs.gnu.org)
87imhxakjq.fsf@gnu.org
Hello,

Mathieu Othacehe <m.othacehe@gmail.com> skribis:

Toggle quote (9 lines)
> The 'syslog' macro cannot be resolved in the pre-unwind-handler
> context. Failed to resolve 'syslog' in this context resulted in the swallowing
> of all installation errors.
>
> Fixes 5c04b00cf463a543b8ffc9eb55991f6b4cc145dd.
>
> * gnu/installer.scm (installer-program): Do not try to resolve 'syslog' macro
> in the pre-unwind-handler.

[...]

Toggle quote (4 lines)
> Since the commit 5c04b00c, error reporting in the installer is broken. Sadly
> this means that every error happening in the 1.1.0 release will result in an
> installer restart, without any error information reporting.

Oh, that’s terrible. :-/ Sorry about that.

Toggle quote (6 lines)
> - (syslog "crashing due to uncaught exception: ~s ~s~%"
> - key args)
> + ((@@ (gnu installer utils) syslog)
> + "crashing due to uncaught exception: ~s ~s~%"
> + key args)

Please add (gnu installer utils) to the list of use-modules.
‘@@’ should only be used in extreme situations.

Thanks,
Ludo’.
M
M
Mathieu Othacehe wrote on 18 Apr 2020 17:46
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 40668-done@debbugs.gnu.org)
87d084pzjd.fsf@gmail.com
Hey,

Toggle quote (3 lines)
> Please add (gnu installer utils) to the list of use-modules.
> ‘@@’ should only be used in extreme situations.

Fixed and pushed!

Thanks,

Mathieu
Closed
?