[PATCH] gnu: Add emacs-moody.

  • Done
  • quality assurance status badge
Details
3 participants
  • Alberto Eleuterio Flores Guerrero
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Alberto Eleuterio Flores Guerrero
Severity
normal
A
A
Alberto Eleuterio Flores Guerrero wrote on 15 Apr 2020 07:04
(address . guix-patches@gnu.org)
20200415050447.14598-1-barbanegra+guix@posteo.mx
* gnu/packages/emacs-xyz.scm (emacs-moody): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a9550ee112..364cec47da 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -507,6 +507,33 @@ Alternatively the menu can be bound globally, for example:
@code{(global-set-key [S-down-mouse-3] 'minions-minor-modes-menu)}.")
(license license:gpl3+)))
+(define-public emacs-moody
+ (let ((commit "2751d36152abcc2ac1479225392182b53f1e02dd")
+ (revision "1"))
+ (package
+ (name "emacs-moody")
+ ;; version 4.0 is a bit old (2018)
+ (version (git-version "0.5.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tarsius/moody.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xyw4l42053595r76lj8safsx6pj25as0107wd96by3h7dg9m586"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tarsius/moody")
+ (synopsis "Tabs and ribbons for Emacs mode-line")
+ (description
+ "@code{emacs-moody} provides utilities for displaying elements of
+the mode line as tabs and ribbons. It also provides replacements for a few
+built-in elements. The biggest differences to similar packages is that
+this one is much simpler and much more consistent. When using this package,
+then only the color of the mode line changes when a window becomes in-/active.")
+ (license license:gpl3+))))
+
(define-public emacs-treepy
(package
(name "emacs-treepy")
--
2.26.0
T
T
Tobias Geerinckx-Rice wrote on 15 Apr 2020 23:18
(address . 40635@debbugs.gnu.org)
87wo6gzbvh.fsf@nckx
Alberto,

Alberto Eleuterio Flores Guerrero ???
Toggle quote (20 lines)
> * gnu/packages/emacs-xyz.scm (emacs-moody): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
> 1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm
> b/gnu/packages/emacs-xyz.scm
> index a9550ee112..364cec47da 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -507,6 +507,33 @@ Alternatively the menu can be bound
> globally, for example:
> @code{(global-set-key [S-down-mouse-3]
> 'minions-minor-modes-menu)}.")
> (license license:gpl3+)))
>
> +(define-public emacs-moody
> + (let ((commit "2751d36152abcc2ac1479225392182b53f1e02dd")
> + (revision "1"))

There's a ‘v0.5.3’ tag so we can just use that:

(version "0.5.3")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://…")
;; ‘Commit’ can really be any git identifier.
(commit (string-append "v" version))))
…))

and drop the (let …).

Toggle quote (4 lines)
> + (package
> + (name "emacs-moody")
> + ;; version 4.0 is a bit old (2018)

Nitpick: ;;-comments are sentences, so capitalise and end with a
full stop.

However, IMO no comment is needed. The top release at
grown to ignore the ‘latest release’ badge on GitHub unless there
are reasons not to. Too many upstreams forget to move it.

Toggle quote (16 lines)
> + (version (git-version "0.5.3" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url
> "https://github.com/tarsius/moody.git")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> +
> "1xyw4l42053595r76lj8safsx6pj25as0107wd96by3h7dg9m586"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/tarsius/moody")
> + (synopsis "Tabs and ribbons for Emacs mode-line")

More nitpicks: ‘…the Emacs mode line’.

Toggle quote (8 lines)
> + (description
> + "@code{emacs-moody} provides utilities for displaying
> elements of
> +the mode line as tabs and ribbons. It also provides
> replacements for a few
> +built-in elements. The biggest differences to similar packages
> is that

‘…difference[singular] with…’.

Toggle quote (3 lines)
> +this one is much simpler and much more consistent. When using
> this package,

I don't know enough about other extensions to judge whether that's
true, so I'll give it the benefit of the doubt.

In general: feel free to remove content-free marketing from
upstream descriptions.

Toggle quote (3 lines)
> +then only the color of the mode line changes when a window
> becomes in-/active.")

You can drop ‘then’ here. I'd write ‘(in)active’ but that might
be purely a matter of taste.

No need to send an updated patch; I'll make above changes and push
if that's all right with you. I might give others time to chime
in if I'm feeling laz^Wgenerous.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl6XeiIACgkQ2Imw8BjF
STwawhAAlfkD8jvxvMeb+Ndz5KG3O8s8C0QYaUA4RCTiumPgcmtvCNa79QcjJ97W
SoN4ZgAHJfzG6HzPOZijrcloP0+lUAFPu3G7i519aBNv9nle8K427N1Du023T0D/
6HT26FjP0F6ycyyyJEVhpcTsgLG4i1HxTwgBaHZC+TYhOn89KygFTIPeJTQ/58au
ARqFre/tTZLb/cDzwfw73+S/SvNh0DbOFZ/p14RUZVnwWAfZaVvbmzpy8/1VKu5j
YjgcXBkUsVaIezsaogPtzFMtQY2+ifMFjq3jNo20xg047HEtNz2OZ4za7ynwDSzO
DcqLyNei6/pCXD1T1waX+qJmi+SU+Zwbc4xq23abceQkOYc528cwk/ESQ9B8eMp6
qjdwpDef8zgMENf2j59jabOoQ1K/kTPLfq0chYCPcAGZuqxmYeQMZEzvJxu2sTyo
V2LcGeLftzJ/i7v8foFbsbX9pTBihCSxvBhMz20sSVXx0LMBp/GY2CLIEy/w+k5c
V4FyVwz0djvfaF574kTLMI/5A8x2Z64Ow5BNnQfKU+njlHNFLmDgvRbu6+IRvGxN
ww5vkh9PHezYpaATQgoVcxz5z/6GwePpn851BZsR/bwCuSY/2xMASaf7YG/rvnzZ
RxFV6hfSLlMbwntS1LintS3DUQcDUX197brsWNV8GMKgovgzWkM=
=qxc7
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 10 Sep 2020 08:50
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 40635-done@debbugs.gnu.org)
871rjaktw5.fsf@gnu.org
Hi!

I went ahead and pushed the patch with the changes you proposed, Tobias
(though I just noticed I have forgotten a couple of them, oops!).

Ludo’.
Closed
?