[PATCH] gnu: Add blobwars.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alberto Eleuterio Flores Guerrero
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Alberto Eleuterio Flores Guerrero
Severity
normal
A
A
Alberto Eleuterio Flores Guerrero wrote on 14 Apr 2020 08:34
(address . guix-patches@gnu.org)
20200414063409.8701-1-barbanegra+guix@posteo.mx
* gnu/packages/games.scm (blobwars): New variable.
---
gnu/packages/games.scm | 51 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ba3a199b97..a345e2fece 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -397,6 +397,57 @@ Playing bastet can be a painful experience, especially if you usually make
canyons and wait for the long I-shaped block to clear four rows at a time.")
(license license:gpl3+)))
+(define-public blobwars
+ (package
+ (name "blobwars")
+ (version "2.00")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://downloads.sourceforge.net/project/"
+ name "/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "16aagvkx6azf75gm5kaa94bh5npydvhqp3fvdqyfsanzdjgjf1n4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (let* ((out (assoc-ref %outputs "out")))
+ (list (string-append "PREFIX=" out)
+ (string-append "BINDIR=" out "/bin/")
+ "USEPAK=1"
+ "RELEASE=1"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'werror-begone
+ (lambda _ (substitute* "Makefile" (("-Werror") ""))))
+ ;; No configure script.
+ (delete 'configure))
+ ;; there are no tests
+ #:tests? #f))
+ (inputs
+ `(("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("sdl" ,(sdl-union (list sdl2
+ sdl2-image
+ sdl2-mixer
+ sdl2-ttf
+ sdl2-net)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("gettext" ,gettext-minimal)))
+ (home-page "https://sourceforge.net/projects/blobwars/")
+ (synopsis "Platform action game featuring a blob with a lot of weapons")
+ (description "Blobwars: Metal Blob Solid is a 2D platform game, the first
+in the Blobwars series. You take on the role of a fearless Blob agent. Your
+mission is to infiltrate various enemy bases and rescue as many MIAs as possible,
+while battling many vicious aliens.")
+ (license (list license:gpl2 ; For code and graphics
+ license:cc0 ; Music and sounds have specific licenses
+ license:cc-by3.0 ; see /doc/readme
+ license:cc-by-sa3.0
+ license:lgpl2.1+
+ license:bsd-2))))
+
(define-public cataclysm-dda
(package
(name "cataclysm-dda")
--
2.26.0
N
N
Nicolas Goaziou wrote on 14 Apr 2020 10:30
(name . Alberto Eleuterio Flores Guerrero)(address . barbanegra+guix@posteo.mx)(address . 40621-done@debbugs.gnu.org)
87d08awju8.fsf@nicolasgoaziou.fr
Hello,

Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx> writes:

Toggle quote (2 lines)
> * gnu/packages/games.scm (blobwars): New variable.

Thank you! I applied your patch (as
dcf9a7dc017a626113fb670298d6103d8b78e37c) with the following changes:

Toggle quote (4 lines)
> + name "/" name "-"
> + version ".tar.gz"))

I used Sourceforge mirrors:

(uri (string-append "mirror://sourceforge/blobwars/"
"blobwars-" version ".tar.gz"))

Toggle quote (3 lines)
> + (add-after 'unpack 'werror-begone
> + (lambda _ (substitute* "Makefile" (("-Werror") ""))))

I added #t at the end of the phase.

Toggle quote (4 lines)
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("gettext" ,gettext-minimal)))

I re-ordered the inputs.

Regards,

--
Nicolas Goaziou
Closed
?