[PATCH] gnu: Add emacs-typing.

  • Done
  • quality assurance status badge
Details
4 participants
  • Alberto Eleuterio Flores Guerrero
  • Nicolas Goaziou
  • Maxim Cournoyer
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Alberto Eleuterio Flores Guerrero
Severity
normal
A
A
Alberto Eleuterio Flores Guerrero wrote on 14 Apr 2020 02:11
(address . bug-guix@gnu.org)
20200414001124.12373-1-barbanegra+guix@posteo.mx
* gnu/packages/emacs-xyz.scm (emacs-typing): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d3631535da..6acbee00d3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22499,3 +22499,25 @@ which can be embedded in source code, comments or emails.")
@code{4clojure.com} problems, you can open an specific question and move
the next or previos. You can also check you answers.")
(license license:gpl3)))
+
+(define-public emacs-typing
+ (package
+ (name "emacs-typing")
+ (version "1.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kensanata/typing.git")
+ (commit "a2ef25dde2d8eb91bd9c0c6164cb5208208647fa")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dbh0srbf54lgd60ia79y9cfnq3kxlgw01qzdjs9mk3nfazzpgnv"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/kensanata/typing/")
+ (synopsis "Emacs game where you have to type fast")
+ (description "@code{emacs-typing} is a game for Emacs that
+forces you to type words correctly as fast as possible, otherwise
+you will die. The game builds the list of words from the active buffer")
+ (license license:gpl2)))
--
2.26.0
T
T
Tobias Geerinckx-Rice wrote on 14 Apr 2020 02:55
(no subject)
87eesqnaxl.fsf@nckx
For the record (and any reviewers), these patches should be
applied in order:

#40591 emacs-org-roam
#40593 emacs-uml-mode
#40616 emacs-4clojure
#40613 emacs-typing

They're not interdependent, just patch-context-dependent.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl6VCeYACgkQ2Imw8BjF
STzvPRAAmz3Ip8iGI7j9TmNef1IJMKkLervFzK8TW0OXbHgnLI4O2Ux6ChUXRsZ5
VkFk4jwsiZTe5q0tJNMynOz1rI3NIifYIY+n/zxUxHeoGGlSlOdSUHxjYGiSn1mC
/Qpr0WHmCdRGAxYghqOlcfdmwQ1wPC/EQydD011sfLhOMpHearifZjWkVJ9lYcj3
l8QOzcuAu+z1bwNgSw0JqJSTsj8u2D6eIs+1YM3xFZ2xRa72omTMDaVZt1ebclm8
oKniR2j1QKUZgBBPIERBwGNiRUZRwUQ22arfaissF7yA8gmLSQN5qobzwriWORqI
tBiSundwKe2AfT31Lk4vMTwm4Jdvne+t6r5ujbt4jEZfRbp0grKlJH9kdAlOE7Wi
tYB+fCrBolpUkmWiUrDiOJ1Q93FnGi8nHY/zS/EYn1Aa71QHQ1E0gvxJiPA+w+LB
f99YXOmzk22erTONQvhVcm/UNKB0hPdND+w2VnL2hXqXPw4pu8WcNynoTWsnbpDF
FMbc+UzOtPZ3FnNztK12Y+we9jsUE+JHBAYldqBTBAwPv26u/qI8tHasmv5sHA4A
Aw2Ip4roMOXFer3tBLQ3tw26u4IjqvmUMu9WzxuzEmanPOuVYB3rbT9OiSfWFS3F
sQWkCDmvRsoFV4rISCed1pp5wyWq0Mf59jxCsIOIkkJz9lCzth8=
=prpp
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 14 Apr 2020 23:47
Re: bug#40613: [PATCH] gnu: Add emacs-typing.
(name . Alberto Eleuterio Flores Guerrero)(address . barbanegra+guix@posteo.mx)(address . 40613@debbugs.gnu.org)
875ze13fkh.fsf@nicolasgoaziou.fr
Hello,

Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-typing): New variable.

Thank you.

Toggle quote (5 lines)
> +(define-public emacs-typing
> + (package
> + (name "emacs-typing")
> + (version "1.1.4")

This is not a regular release, this is extracted from the main file. We
need to provide a commit and a revision. See, e.g., "emacs-dhall-mode".

Toggle quote (2 lines)
> + (description "@code{emacs-typing} is a game for Emacs that

I would write "The Typing of Emacs" instead of emacs-typing, i.e., the
name of the game instead of the symbol.

Toggle quote (3 lines)
> +forces you to type words correctly as fast as possible, otherwise
> +you will die. The game builds the list of words from the active buffer")

The description is missing a final dot.

Toggle quote (2 lines)
> + (license license:gpl2)))

The license is gpl2+.

Could you send an updated patch?

Regards,

--
Nicolas Goaziou
M
M
Maxim Cournoyer wrote on 22 Oct 2020 23:33
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
87mu0ec5eq.fsf@gmail.com
Hello Nicolas, Alberto,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (32 lines)
> Hello,
>
> Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-typing): New variable.
>
> Thank you.
>
>> +(define-public emacs-typing
>> + (package
>> + (name "emacs-typing")
>> + (version "1.1.4")
>
> This is not a regular release, this is extracted from the main file. We
> need to provide a commit and a revision. See, e.g., "emacs-dhall-mode".
>
>> + (description "@code{emacs-typing} is a game for Emacs that
>
> I would write "The Typing of Emacs" instead of emacs-typing, i.e., the
> name of the game instead of the symbol.
>
>> +forces you to type words correctly as fast as possible, otherwise
>> +you will die. The game builds the list of words from the active buffer")
>
> The description is missing a final dot.
>
>> + (license license:gpl2)))
>
> The license is gpl2+.
>
> Could you send an updated patch?

I modified the original definition with your above suggestions and
pushed as commit a49bfa1f6c22363c9e495070f51b82e60b1495af.

Closing.

Thank you!

Maxim
Closed
?