[PATCH] system: Automatically adjust linux-module packages to use the operating-system's kernel.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brice Waegeneire
  • Danny Milosavljevic
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 13 Apr 2020 13:43
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20200413114359.26652-1-dannym@scratchpost.org
* gnu/system.scm (package-for-kernel): New procedure.
(operating-system-directory-base-entries): Use it.
* gnu/tests/linux-module.scm: Test it.
---
gnu/system.scm | 18 +++++++++++++++++-
gnu/tests/linux-modules.scm | 11 ++++++++++-
2 files changed, 27 insertions(+), 2 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/system.scm b/gnu/system.scm
index fd456c6206..53c16233a1 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -32,6 +32,7 @@
#:use-module (guix derivations)
#:use-module (guix profiles)
#:use-module (guix ui)
+ #:use-module (guix utils)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages guile)
@@ -472,6 +473,16 @@ OS."
(file-append (operating-system-kernel os)
"/" (system-linux-image-file-name)))
+(define (package-for-kernel target-kernel module-package)
+ "Return a package like MODULE-PACKAGE, adapted for TARGET-KERNEL, if
+possible (that is if there's a LINUX keyword argument in the build system)."
+ (package
+ (inherit module-package)
+ (arguments
+ (substitute-keyword-arguments (package-arguments module-package)
+ ((#:linux kernel #f)
+ target-kernel)))))
+
(define* (operating-system-directory-base-entries os)
"Return the basic entries of the 'system' directory of OS for use as the
value of the SYSTEM-SERVICE-TYPE service."
@@ -486,7 +497,12 @@ value of the SYSTEM-SERVICE-TYPE service."
(kernel
(profile-derivation
(packages->manifest
- (cons kernel modules))
+ (cons kernel
+ (map (lambda (module)
+ (if (package? module)
+ (package-for-kernel kernel module)
+ module))
+ modules)))
#:hooks (if has-modules?
(list linux-module-database)
'())))
diff --git a/gnu/tests/linux-modules.scm b/gnu/tests/linux-modules.scm
index 788bdc848a..953b132ef7 100644
--- a/gnu/tests/linux-modules.scm
+++ b/gnu/tests/linux-modules.scm
@@ -28,8 +28,10 @@
#:use-module (guix derivations)
#:use-module (guix gexp)
#:use-module (guix modules)
+ #:use-module (guix packages)
#:use-module (guix monads)
#:use-module (guix store)
+ #:use-module (guix utils)
#:export (%test-loadable-kernel-modules-0
%test-loadable-kernel-modules-1
%test-loadable-kernel-modules-2))
@@ -118,5 +120,12 @@ with one extra module.")
(description "Tests loadable kernel modules facility of <operating-system>
with two extra modules.")
(value (run-loadable-kernel-modules-test
- (list acpi-call-linux-module ddcci-driver-linux)
+ (list acpi-call-linux-module
+ (package
+ (inherit ddcci-driver-linux)
+ (arguments
+ `(#:linux #f
+ ,@(strip-keyword-arguments '(#:linux)
+ (package-arguments
+ ddcci-driver-linux))))))
'("acpi_call" "ddcci")))))
B
B
Brice Waegeneire wrote on 14 Apr 2020 09:39
Re: [PATCH] system: Automatically adjust linux-module packages to use the
(address . 40595@debbugs.gnu.org)
d8161d91f151446e3f6378379246442a@waegenei.re
Hello Danny,

Thanks for the patch, I needed such feature.
It works well and the test pass; LGTM!

- Brice
B
B
Brice Waegeneire wrote on 22 Apr 2020 20:57
#40595 Need a rebase
(address . 40595@debbugs.gnu.org)
519959959ea79cd1dcafb869320313a9@waegenei.re
Hello Danny,

Looks like this patch need to be rebased.

Cheers,
- Brice
D
D
Danny Milosavljevic wrote on 22 Apr 2020 22:59
Re: [bug#40595] [PATCH] system: Automatically adjust linux-module packages to use the
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 40595-done@debbugs.gnu.org)
20200422225957.652aad1d@scratchpost.org
Hi Brice,

yes, indeed.

Thanks.

I've rebased it and pushed it to guix master as commit f91ad0b13d8d3d5b1ae92e209b1be6e8473385ba.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl6gsE0ACgkQ5xo1VCww
uqWPGQgAoiKhBlNn4OXZWMDZ6UonsVJa+5C3DdwZyM07vvUPyWJKiP4MwOKBMD0R
fTy6wD5tHmj7R9c+rBN8Sp5E0L9LxsThh0CdPzNSYxR1pNfa/GicxSCpvTXMedP9
kGdytULoQS6LOkLjphig+jSX1TPArdd16rS7PDPAgmhhNwpnCR8QLnRwV1iF7/6t
IYiAArnGAZ1d3UJmeU59ShG4NxoUu/75r5yxYZDDXRyaQDVr6iRSHI85b08BkxJo
dKTj9yGlGYnzesM+ZpNBrdX7qoZa0OyHJoMT+ZKrVua4FU11fOZS15RV8Evv+RZl
dUD6nnX3s7nDgg7vqjzY6e4me0MJyA==
=NwzB
-----END PGP SIGNATURE-----


Closed
?