[PATCH] services: dnsmasq: Support the --address flag.

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • Pierre Langlois
Owner
unassigned
Submitted by
Pierre Langlois
Severity
normal
P
P
Pierre Langlois wrote on 10 Apr 2020 19:59
(address . guix-patches@gnu.org)
87wo6np6hh.fsf@gmx.com
Hello Guix!

Here's a patch that allows passing the --address flag multiple times to
dnsmasq. WDYT?

Thanks,
Pierre
From 407265e5d9b0f863a8b14d74f6240ed102f9a907 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Fri, 10 Apr 2020 17:00:47 +0100
Subject: [PATCH] services: dnsmasq: Support the --address flag.

Introduce a new `addresses' field that translates to passing `--address='
multiple times to dnsmasq.

* gnu/services/dns.scm (<dnsmasq-configuration>): Add an addresses field.
(dnsmasq-shepherd-service): Match the addresses field and translate it to
multiple '--address=' flags.
* doc/guix.texi (DNS Services): Document it.
---
doc/guix.texi | 20 ++++++++++++++++++++
gnu/services/dns.scm | 7 ++++++-
2 files changed, 26 insertions(+), 1 deletion(-)

Toggle diff (79 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 891e2693f6..7ca4bd6ef3 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -77,6 +77,7 @@ Copyright @copyright{} 2020 Jakub K?dzio?ka@*
Copyright @copyright{} 2020 Jack Hill@*
Copyright @copyright{} 2020 Naga Malleswari@*
Copyright @copyright{} 2020 Brice Waegeneire@*
+Copyright @copyright{} 2020 Pierre Langlois@*
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.3 or
@@ -21772,6 +21773,25 @@ When true, don't read @var{resolv-file}.
@item @code{servers} (default: @code{'()})
Specify IP address of upstream servers directly.
+@item @code{addresses} (default: @code{'()})
+For each entry, specify an IP address to return for any host in the
+given domains. Queries in the domains are never forwarded and always
+replied to with the specified IP address.
+
+This is useful for redirecting hosts locally, for example:
+
+@lisp
+(service dnsmasq-service-type
+ (dnsmasq-configuration
+ (addresses
+ '(; Redirect to a local web-server.
+ "/example.org/127.0.0.1"
+ ; Redirect subdomain to a specific IP.
+ "/subdomain.example.org/192.168.1.42"))))
+@end lisp
+
+Note that rules in @file{/etc/hosts} take precedence over this.
+
@item @code{cache-size} (default: @code{150})
Set the size of dnsmasq's cache. Setting the cache size to zero
disables caching.
diff --git a/gnu/services/dns.scm b/gnu/services/dns.scm
index a07946d085..478c837d13 100644
--- a/gnu/services/dns.scm
+++ b/gnu/services/dns.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -748,6 +749,8 @@ cache.size = 100 * MB
(default #f)) ;boolean
(servers dnsmasq-configuration-servers
(default '())) ;list of string
+ (addresses dnsmasq-configuration-addresses
+ (default '())) ;list of string
(cache-size dnsmasq-configuration-cache-size
(default 150)) ;integer
(negative-cache? dnsmasq-configuration-negative-cache?
@@ -759,7 +762,7 @@ cache.size = 100 * MB
no-hosts?
port local-service? listen-addresses
resolv-file no-resolv? servers
- cache-size negative-cache?)
+ addresses cache-size negative-cache?)
(shepherd-service
(provision '(dnsmasq))
(requirement '(networking))
@@ -783,6 +786,8 @@ cache.size = 100 * MB
'())
#$@(map (cut format #f "--server=~a" <>)
servers)
+ #$@(map (cut format #f "--address=~a" <>)
+ addresses)
#$(format #f "--cache-size=~a" cache-size)
#$@(if negative-cache?
'()
--
2.26.0
P
P
Pierre Langlois wrote on 22 Apr 2020 20:16
(address . 40545@debbugs.gnu.org)
87zhb3per7.fsf@gmx.com
Hi all,

Pierre Langlois writes:

Toggle quote (5 lines)
> Hello Guix!
>
> Here's a patch that allows passing the --address flag multiple times to
> dnsmasq. WDYT?

Any comment on this patch? Let me know if I should attempt at adding
some service tests for dnsmasq, that might be useful.

Thanks,
Pierre
?
(name . Pierre Langlois)(address . pierre.langlois@gmx.com)(address . 40545-done@debbugs.gnu.org)
87bln76i79.fsf@member.fsf.org
Pierre Langlois <pierre.langlois@gmx.com> writes:

Toggle quote (9 lines)
> Hi all,
>
> Pierre Langlois writes:
>
>> Hello Guix!
>>
>> Here's a patch that allows passing the --address flag multiple times to
>> dnsmasq. WDYT?

Hello Pierre, this patch looks good to me, and I pushed it to master
now, thank you!

Toggle quote (4 lines)
>
> Any comment on this patch? Let me know if I should attempt at adding
> some service tests for dnsmasq, that might be useful.

Yes, I think adding a system test for dnsmasq is welcomed too :-)
Closed
?