[PATCH] Add taisei, and spirv-cross

  • Done
  • quality assurance status badge
Details
2 participants
  • Vitaliy Shatrov
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Vitaliy Shatrov
Severity
normal
V
V
Vitaliy Shatrov wrote on 7 Apr 2020 21:52
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
jZkvxKPG3fdbqhUupvY_Q8AqB9plnxUshnYZxzubWH1q3jMfdBbErjtrCb3wMAZI8wQI2-voDbET4rcZc4jlfreWlYzbpLkAquavgn1rq0E=@protonmail.com
Hi; taisei is a game, it has three renderers: gl33, gles20, and gles30. To support later two it need a SPIRV-Cross tool.

I was told on IRC that the game wasn't playable due to graphics issues, but it worked fine on my machine; testing and help are welcome.

Game build is "developer" build; it enables cheats, but greatly improves the diagnostics (output to console). If configured as "debugoptimized" with "-Ddeveloper=false", then it's diagnostics are same as for "release". I didn't notice any impact on performance with my 7-years old laptop, from those options.

SPIRV-Cross seem to have tests, but i didn't get how to start them yet.

Sent with [ProtonMail](https://protonmail.com) Secure Email.
Attachment: file
From aa3c292907ac78b3df095867f39289b4a7497472 Mon Sep 17 00:00:00 2001
From: Vitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>
Date: Wed, 8 Apr 2020 02:28:20 +0700
Subject: [PATCH] gnu: Add taisei, and spirv-cross

* gnu/packages/games.scm (taisei): new variable
* gnu/packages/vulkan.scm (spirv-cross): new variable
---
gnu/packages/games.scm | 56 +++++++++++++++++++++++++++++++++++++++++
gnu/packages/vulkan.scm | 31 +++++++++++++++++++++++
2 files changed, 87 insertions(+)

Toggle diff (108 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1efc50e6d1..711f4779c7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10471,3 +10471,59 @@ and shovers to get to the goal. Race against the clock to collect coins to
earn extra balls. Also included is Neverputt, which is a 3D miniature golf
game.") ;thanks to Debian for description
(license license:gpl2+))))
+
+(define-public taisei
+ (package
+ (name "taisei")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/taisei-project/"
+ "taisei/releases/download/v" version
+ "/taisei-v" version ".tar.xz"))
+ (sha256
+ (base32
+ "11f9mlqmzy1lszwcc1nsbar9q1hs4ml6pbm52hqfd4q0f4x3ln46"))))
+ (build-system meson-build-system)
+ (arguments
+ `(;;configure option developer=true enables the diagnostics
+ ;;needed for bug reports. it is 'true' if not "release"
+ ;;#:build-type "release"
+ #:configure-flags
+ (list "-Dr_gles30=true"
+ "-Dshader_transpiler=true"
+ "-Dr_gles20=true")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python" ,python)
+ ("python-docutils" ,python-docutils)
+ ("python-pygments" ,python-pygments)))
+ (inputs
+ `(("freetype" ,freetype)
+ ("libpng" ,libpng)
+ ("libwebp" ,libwebp)
+ ("libzip" ,libzip)
+ ("mesa" ,mesa)
+ ("openssl" ,openssl)
+ ("opusfile" ,opusfile)
+ ("sdl2" ,sdl2)
+ ("sdl2-mixer" ,sdl2-mixer)
+ ("shaderc" ,shaderc)
+ ("spirv-cross" ,spirv-cross)
+ ("zlib" ,zlib)))
+ (home-page "https://taisei-project.org/")
+ (synopsis "Fangame and libre clone of Touhou Project")
+ (description
+ "Taisei is a shoot-em-up game: The player controls a character (one of
+three: \"Good\", \"Bad\", and \"Dead\"), dodges the missiles (lots of it cover
+the screen, but the character's \"hitbox\" is very small), and shoot at the
+adversaries that keep appear on the screen. At the same time, player lose one
+\"life\" when being hit. If player are out of \"lives\", it’s a Game Over.
+Player have a few \"Continues\" to keep playing (but without scores).")
+ (license (list license:expat ;game
+ license:cc-by4.0 ;resources/00-taisei.pkgdir/bgm/
+ ;atlas/portraits/
+ ;;miscellaneous
+ license:cc0
+ license:public-domain))))
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 6a2c219aac..e0a031141f 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -107,6 +107,37 @@ SPIR-V modules. The project includes an assembler, binary module
parser,disassembler, validator, and optimizer for SPIR-V.")
(license license:asl2.0)))
+(define-public spirv-cross
+ (package
+ (name "spirv-cross")
+ (version "2020-04-03")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KhronosGroup/SPIRV-Cross")
+ (commit (string-append version))))
+ (sha256
+ (base32 "0489s29kqgq20clxqg22y299yxz23p0yjh87yhka705hm9skx4sa"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments ;TODO: solve "No tests were found!!!"
+ `(#:configure-flags
+ (list "-DSPIRV_CROSS_SHARED=YES")))
+ (inputs `(("spirv-headers" ,spirv-headers)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page "https://github.com/KhronosGroup/SPIRV-Cross")
+ (synopsis "Parser for and converter of SPIR-V to other shader languages")
+ (description
+ "SPIRV-Cross tries hard to emit readable and clean output from the
+SPIR-V. The goal is to emit GLSL or MSL that looks like it was written by a
+human and not awkward IR/assembly-like code. NOTE: Individual features are
+expected to be mostly complete, but it is possible that certain obscure GLSL
+features are not yet supported. However, most missing features are expected
+to be \"trivial\" improvements at this stage.")
+ (license license:asl2.0)))
+
(define-public glslang
(package
(name "glslang")
--
2.25.1
V
V
Vitaliy Shatrov wrote on 8 Apr 2020 08:54
(name . 40495@debbugs.gnu.org)(address . 40495@debbugs.gnu.org)
W2pidgP4wvOzdZ9y3LOMQyLlZn9c1Rn_TlkPBRIBqBHsOAUECAMOJB6lYn85yNBZ9zEKIlbVSwrtONuKZU5et0GZ_qhy3BPq67zWTyeST-c=@protonmail.com
UPDATE: Game reported playable with gles30 instead of default gl33 (both work for me, so maybe we need to change the default?)

Sent with [ProtonMail](https://protonmail.com) Secure Email.
Attachment: file
N
N
Nicolas Goaziou wrote on 10 Apr 2020 19:13
(name . Vitaliy Shatrov via Guix-patches via)(address . guix-patches@gnu.org)
87o8rz2rin.fsf@nicolasgoaziou.fr
Hello,

Vitaliy Shatrov via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (3 lines)
> UPDATE: Game reported playable with gles30 instead of default gl33 (both work for me, so maybe we need to change the default?)
> http://logs.guix.gnu.org/2020-04-07.log#163939

FWIW gl33 works fine here.

Some notes: you can drop quotes from descrption. They are not needed an
"..." is not a correct quoting in Texinfo.

Also, I'm not sure the last part of the description is useful. I mean,
this is the same for many arcade games, isn't it?

OOC, don't use need to add (recursive? #t) to `url'?

Regards,

--
Nicolas Goaziou
V
V
Vitaliy Shatrov wrote on 11 Apr 2020 09:31
Update
(name . 40495@debbugs.gnu.org)(address . 40495@debbugs.gnu.org)
xvmcZaxxcOsLfmgDf8h-F9yNPr2wjQnaJjiXhSg-1CSF5AYV4c8zF2V3vCoxt1m2lsqKDrcp8INWRBICoXW6d2VdoQ0SidECG_YAYhPDWNo=@protonmail.com
(substitute* "CMakeLists.txt" with assoc-refs of respective tools enable tests... will refine further. Thanks for a kick.

Sent with [ProtonMail](https://protonmail.com) Secure Email.
Attachment: file
V
V
Vitaliy Shatrov wrote on 11 Apr 2020 13:11
v2, spirv tests steel fail
(name . 40495@debbugs.gnu.org)(address . 40495@debbugs.gnu.org)
8gkWhyC3kxgwDJZBCBNOP_75zxyfYdPVtIzV3S_VTGXyLbh3ygvTNJkjVm5l1b7_wiVm36km0eH13nlB9vvBfAlcTT3FEiHlUTbguEWoFMc=@protonmail.com
Toggle quote (1 lines)
>>> gl33 works
Please also test with gles30 (it's default now).

Toggle quote (1 lines)
>>> quotes, description
removed, cut.

Toggle quote (1 lines)
>>> (recursive? #t)
spirv-cross: gives nothing (to me at least). I'd used `substitute*` to make tests work, but they're fail.
spirv-tools is a dependency for spirv-cross tests, and spirv-tools tests also fails. Tests fails, idk how to fix them.

Sent with [ProtonMail](https://protonmail.com) Secure Email.
Attachment: file
V
V
Vitaliy Shatrov wrote on 11 Apr 2020 14:29
v3-- fixed indentation
(name . 40495@debbugs.gnu.org)(address . 40495@debbugs.gnu.org)
YzYUluYRyjbN7XNaC6-XZa4G5dFix4yxWu6KjaUEQjjNgml0MH2u76bo_E_O8Ld48PadLcQm6eFOvS_0Ud2YSI-DE6gs8rxd4UBn2-puk6Q=@protonmail.com
i'm sorry.

Sent with [ProtonMail](https://protonmail.com) Secure Email.
Attachment: file
N
N
Nicolas Goaziou wrote on 11 Apr 2020 22:23
(name . Vitaliy Shatrov via Guix-patches via)(address . guix-patches@gnu.org)
875ze53h6l.fsf@nicolasgoaziou.fr
Hello,

Vitaliy Shatrov via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> Subject: [PATCH] gnu: Add taisei, and spirv-cross
>
> * gnu/packages/games.scm (taisei): new variable
> * gnu/packages/vulkan.scm (spirv-cross): new variable

It works nicely, thank you.

Toggle quote (4 lines)
> + `(;;configure option developer=true enables the diagnostics
> + ;;needed for bug reports. it is 'true' if not "release"
> + ;;#:build-type "release"

So, what do you suggest here? Use release or developer build?

Toggle quote (2 lines)
> + (synopsis "Fangame and libre clone of Touhou Project")

I would suggest something like

Shoot'em up game set in a world full of Japanese folklore

Toggle quote (14 lines)
> + (description
> + "Taisei is a shoot-em-up game: The player controls a character (one of
> +three: Good, Bad, and Dead), dodges the missiles (lots of it cover the screen,
> +but the character's hitbox is very small), and shoot at the adversaries that
> +keep appear on the screen.")


> + (license (list license:expat ;game
> + license:cc-by4.0 ;resources/00-taisei.pkgdir/bgm/
> + ;atlas/portraits/
> + ;;miscellaneous
> + license:cc0
> + license:public-domain))))

It would be clearer to explain in a comment above the license field what
is subject to what terms.

Toggle quote (7 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/KhronosGroup/SPIRV-Cross")
> + (commit (string-append version))))

You can remove the `string-append' here.

Toggle quote (8 lines)
> + (sha256
> + (base32
> + "0489s29kqgq20clxqg22y299yxz23p0yjh87yhka705hm9skx4sa"))
> + (file-name (git-file-name name version))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f ;FIXME: Tests fail.

IMO, this is not a blocker. However, if you have more information than
"Tests fail", it would be nice to add it in a comment.

Toggle quote (11 lines)
> + #:configure-flags
> + (list "-DSPIRV_CROSS_SHARED=YES")
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'fix-tests-to-find-deps
> + (lambda* (#:key inputs #:allow-other-keys)
> + (substitute* "CMakeLists.txt"
> + (((string-append "PATHS "
> + "\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}"
> + "/external/glslang-build/output/bin"))

Why do you need this? What about simply writing the full string without
`string-append'?

Toggle quote (5 lines)
> + (substitute* "CMakeLists.txt"
> + (((string-append "PATHS "
> + "\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}"
> + "/external/spirv-tools-build/output/bin"))

Ditto.

Toggle quote (5 lines)
> + (native-inputs `(("glslang" ,glslang)
> + ("python" ,python)
> + ("spirv-headers" ,spirv-headers)
> + ("spirv-tools" ,spirv-tools)))

Nitpick: I would move the inputs below the `native-inputs' line.

Toggle quote (5 lines)
> + (description
> + "SPIRV-Cross tries hard to emit readable and clean output from the
> +SPIR-V. The goal is to emit GLSL or MSL that looks like it was written by a
> +human and not awkward IR/assembly-like code. NOTE: Individual features are

You can drop the "NOTE:" prefix.

Actually, I think you can drop everything after "NOTE:". Is it useful
information for someone looking at the package?

Toggle quote (4 lines)
> +expected to be mostly complete, but it is possible that certain obscure GLSL
> +features are not yet supported. However, most missing features are expected
> +to be \"trivial\" improvements at this stage.")

If you disagree with my suggestion, you need to remove these double
quotes. Texinfo uses ``trivial'', but you could also write
@emph{trivial}.

Regards,

--
Nicolas Goaziou
V
V
Vitaliy Shatrov wrote on 12 Apr 2020 06:10
update
(name . 40495@debbugs.gnu.org)(address . 40495@debbugs.gnu.org)
BW8sagR6kOM_CyTwBeVmzOXrfi8LkboaHPEfcAnFRkLXZK4t2QegueiFr0mqQ1dY7wm1Blk8X65fSkimdUByl-mO1ZfJgMuMdblNyAcdy60=@protonmail.com
### taisei ###
Toggle quote (1 lines)
>>> 'release' or 'developer'?
IDK how valuable those diagnostics is, but during testing found the 'developer' mode cheat-keys to easy to hit. Changed to 'release'.

Toggle quote (1 lines)
>>> (synopsis "Shoot'em up game set in a world full of Japanese folklore")
I know nothing about Japan (seen this variant too). Changed to "Shoot'em up fangame and libre clone of Touhou Project"..?

Toggle quote (1 lines)
>>> comments in '(license'
done

### spirv-cross ###
Toggle quote (1 lines)
>>> remove '(string-append' from '(commit'
done

Toggle quote (1 lines)
>>> tests fail, more info
("-cross yet have a multiple failures").

Toggle quote (1 lines)
>>> (substitute*
Why: 'fix-tests-to-find-deps, i can't fix tests myself, thought i'm prepare the ground.
'(string-append' is to stay < 80 cols.

Toggle quote (1 lines)
>>> (native-inputs, (inputs order
seems done

Toggle quote (1 lines)
>>> drop 'note:', \"
done
________

Sent with [ProtonMail](https://protonmail.com) Secure Email.
Attachment: file
N
N
Nicolas Goaziou wrote on 30 Jun 2020 17:27
(name . Vitaliy Shatrov via Guix-patches via)(address . guix-patches@gnu.org)
87bll0infg.fsf@nicolasgoaziou.fr
Hello,

Vitaliy Shatrov via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> Subject: [PATCH] gnu: Add taisei, and spirv-cross

Sorry for the looong delay!

spirv-cross was recently updated and added to Guix. I pushed taisei.

Thank you!

Regards,
--
Nicolas Goaziou
?