[PATCH] gnu: Add fdroidcl.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Ludovic Courtès
  • Glenn Morris
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal
S
S
Sergey Trofimov wrote on 7 Apr 2020 06:57
5e8c1249.1c69fb81.5b84a.0583@mx.google.com
* gnu/packages/android (fdroidcl): New variable.
---
gnu/packages/android.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 17f5f41fcb..4d1a591686 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Sergey Trofimov <sarg@sarg.org.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system android-ndk)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module ((guix licenses) #:prefix license:)
@@ -41,6 +43,7 @@
#:use-module (gnu packages docker)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages pcre)
@@ -946,6 +949,39 @@ publishing, or to assist in creating, testing and submitting metadata to the
main repository.")
(license license:agpl3+)))
+(define-public fdroidcl
+ (package
+ (name "fdroidcl")
+ (version "0.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mvdan/fdroidcl/archive/"
+ "v" version ".tar.gz"))
+ (sha256
+ (base32 "0ybqxklhrp23xm89l4g6ms5qxm08db00kx4g6w9vyv11jd68qajk"))))
+ (build-system go-build-system)
+
+ (inputs
+ `(("go-github-com-kr-pretty"
+ ,go-github-com-kr-pretty)
+ ;; used in tests
+ ;; ("go-github-com-rogpeppe-go-internal-testscript"
+ ;; ,go-github-com-rogpeppe-go-internal-testscript)
+ ("go-gopkg.in-check.v1"
+ ,go-gopkg.in-check.v1)))
+ (arguments
+ `(#:import-path "mvdan.cc/fdroidcl"
+ #:tests? #f ; TODO.
+ #:install-source? #f))
+ (synopsis "F-Droid desktop client")
+ (description
+ "While the Android client integrates with the system with regular update
+checks and notifications, this is a simple command line client that talks to
+connected devicesvia ADB.")
+ (home-page "https://github.com/mvdan/fdroidcl")
+ (license license:bsd-3)))
+
(define-public enjarify
(package
(name "enjarify")
--
2.25.1
G
G
Glenn Morris wrote on 7 Apr 2020 18:29
control message for bug 40479
(address . control@debbugs.gnu.org)
E1jLr6P-00072K-Em@fencepost.gnu.org
reassign 40479 guix-patches
E
E
Efraim Flashner wrote on 20 Apr 2020 11:16
[PATCH]: Add fdroidcl.
(address . 40479@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20200420091653.GE7353@E5400
I made a couple of changes to the patch. It now downloads the source
using git-fetch and I updated the inputs a bit.

For the tests, I'm afraid you're going to need to package the
missing package.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
From efd8708885f451b34cbb712ef6a7d97e8ea598c4 Mon Sep 17 00:00:00 2001
From: Sergey Trofimov <sarg@sarg.org.ru>
Date: Tue, 7 Apr 2020 06:57:13 +0200
Subject: [PATCH] gnu: Add fdroidcl.

* gnu/packages/android (fdroidcl): New variable.
---
gnu/packages/android.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 17f5f41fcb..a32d6c570c 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Sergey Trofimov <sarg@sarg.org.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system android-ndk)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module ((guix licenses) #:prefix license:)
@@ -41,6 +43,7 @@
#:use-module (gnu packages docker)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages pcre)
@@ -946,6 +949,39 @@ publishing, or to assist in creating, testing and submitting metadata to the
main repository.")
(license license:agpl3+)))
+(define-public fdroidcl
+ (package
+ (name "fdroidcl")
+ (version "0.5.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mvdan/fdroidcl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rxcdyy2j34z0ql9d62w7ivsch9xihjnpb1z9kgy9q46vl8zhhy0"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "mvdan.cc/fdroidcl"
+ #:tests? #f ; TODO.
+ #:install-source? #f))
+ (inputs
+ `(("go-github-com-kr-pretty"
+ ,go-github-com-kr-pretty)))
+ (native-inputs
+ `(;; used in tests
+ ;; ("go-github-com-rogpeppe-go-internal-testscript"
+ ;; ,go-github-com-rogpeppe-go-internal-testscript)
+ ))
+ (synopsis "F-Droid desktop client")
+ (description
+ "While the Android client integrates with the system with regular update
+checks and notifications, this is a simple command line client that talks to
+connected devices via ADB.")
+ (home-page "https://github.com/mvdan/fdroidcl")
+ (license license:bsd-3)))
+
(define-public enjarify
(package
(name "enjarify")
--
2.26.1
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl6daIIACgkQQarn3Mo9
g1Gqfg//SnqbS2XrfhJngrNZYGDHpPKTyHmFz9CMDk0TwJnrrfueqWqlxvk1sK0T
/5IUT5xd2cepnX+XA+ujdT3RxM8VxkthJ7Lu2GJpH+GVfInm4JKTUiOsHTZqD34C
IrUpHCsL6eysxxbMT+3mtieEP4d2jqVu+kPs8oCzC2hhNWve9L69Am22JrKXFSQ1
HUH7X5Mf+PBryuVpvImv6pFtZDJ8W9lZp++vvDn6GwnAD+LJCbpLYRV2uUonj8Gk
8D9dBgCRPCCLarRZkQiuAzl7T5rkXdNiyiQHiXmLYVjVJW1u0GC30PU++NcCJk+R
eaoZJje03EDteKDefwxIgIPVOm9TjncnPYMYKwlfqIswd7iwcbOxdEpo6g0GvTN4
r5f9nfabQRyAVZdliCurLWUB+Z/YfRAiguCQwb00XXrWuwd2/9zNfxZfh04nQuSU
LNvVHvf/4vlfOovMuuo0hyLgSRD2g9e1fUwboEHf1CZulveoNNKQmQ0CZQYauCzI
am94ZfKKMXxlfCjv7qxShn0CUHDGV9V1qFEioRaNZlrX2By4NghCYmK73VeYqb09
sY6PkrayerR2sMLtTH85H4dCOChr3CJfKdqfqJil2Bxt1DJFUHr08FzB7t+qjDix
OV/CJZVFfbxLdCfxNgu2CxRKnwB3QiMFi2oCk+/VFPcsemxp9cs=
=KGJz
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 9 Sep 2020 23:21
(name . Efraim Flashner)(address . efraim@flashner.co.il)
878sdilk88.fsf@gnu.org
Hi,

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (6 lines)
> I made a couple of changes to the patch. It now downloads the source
> using git-fetch and I updated the inputs a bit.
>
> For the tests, I'm afraid you're going to need to package the
> missing package.

[...]

Toggle quote (7 lines)
> From efd8708885f451b34cbb712ef6a7d97e8ea598c4 Mon Sep 17 00:00:00 2001
> From: Sergey Trofimov <sarg@sarg.org.ru>
> Date: Tue, 7 Apr 2020 06:57:13 +0200
> Subject: [PATCH] gnu: Add fdroidcl.
>
> * gnu/packages/android (fdroidcl): New variable.

[...]

Toggle quote (5 lines)
> + (native-inputs
> + `(;; used in tests
> + ;; ("go-github-com-rogpeppe-go-internal-testscript"
> + ;; ,go-github-com-rogpeppe-go-internal-testscript)

Perhaps make the comment a TODO and push?

Thanks,
Ludo’.
E
E
Efraim Flashner wrote on 10 Sep 2020 09:59
(name . Ludovic Courtès)(address . ludo@gnu.org)
20200910075931.GS1643@E5400
On Wed, Sep 09, 2020 at 11:21:27PM +0200, Ludovic Courtès wrote:
Toggle quote (31 lines)
> Hi,
>
> Efraim Flashner <efraim@flashner.co.il> skribis:
>
> > I made a couple of changes to the patch. It now downloads the source
> > using git-fetch and I updated the inputs a bit.
> >
> > For the tests, I'm afraid you're going to need to package the
> > missing package.
>
> [...]
>
> > From efd8708885f451b34cbb712ef6a7d97e8ea598c4 Mon Sep 17 00:00:00 2001
> > From: Sergey Trofimov <sarg@sarg.org.ru>
> > Date: Tue, 7 Apr 2020 06:57:13 +0200
> > Subject: [PATCH] gnu: Add fdroidcl.
> >
> > * gnu/packages/android (fdroidcl): New variable.
>
> [...]
>
> > + (native-inputs
> > + `(;; used in tests
> > + ;; ("go-github-com-rogpeppe-go-internal-testscript"
> > + ;; ,go-github-com-rogpeppe-go-internal-testscript)
>
> Perhaps make the comment a TODO and push?
>
> Thanks,
> Ludo’.

Works for me.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl9Z3OMACgkQQarn3Mo9
g1FzTg//YnWSptlDjYpVth+sOVj32SFhlDJVJF+9yDvcSPVh5vD12ULtwZ/o9GTm
33uwXErAs5MjQ6EfT6hhK7P0rE6+W2Ug+X4Ilhri5hIJh8nSjXIOZYI91gGFYYqp
BOynB5q8+IngyYrK3wI4nk2gcnmgnPWckm5iOF92NXYI7ZT6k3rO8MHamP+hVqOX
TaQUjuiJ+qe03JLie/MPVUfuf+akAQtBeetWD1ck8ByaaYSewgupxrTe/aAi4fjM
UfN3FIEgFAj0gLNdcGuitdejDpZPrY3F/QxRYilFLIkxAcVBZeFyYDKVu0ScCPzy
nuHf6LlqqNabiyV3NZtHD1EIZGgb9x0V7x1nH6gH8RpbIVazmtDsCBdLTTXcDz2v
WS1VQfPCiI6g2puntNUr5QnPq37h4156BV+M09rY7sLzKfQIXWf8U/aM21uIgVEp
PrMc6sw/izGiUgAev2wA9XrooSco6+NLHK9hNi6vxWEAKCjM7OiZPFnIo4RjKqUy
CD/fx+kGs60pHETWk8PRR3gKF1CoqGeohfsKrQ8yhzq7MIWTNHM09minlqDrqLu1
tGQp2M1PzC5pDGzA2rdD3i9ScL7aJ/3Y6QSjlr0JN6I2WhNNwIb3iHwMTCclc+eQ
nzBaKCOlVjs9jTtGwTzuCEc5keELwKr3qYMCz3+ITwLUCz49JK4=
=XSZt
-----END PGP SIGNATURE-----


Closed
?