[PATCH] gnu: Add tap-lv2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Leo Famulari
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 6 Apr 2020 17:04
(name . Guix patches)(address . guix-patches@gnu.org)
3ddca5393440447967d0f17b022577c8265d440c.camel@zrythm.org
Hi,

This patch adds tap-lv2, an LV2 port of the TAP LADSPA plugins. I used
the date as a version because there was no tag.

Thanks,
Alex
From ce383ce1bffefbd41434de97d1756516b9546450 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 6 Apr 2020 16:02:46 +0100
Subject: [PATCH] gnu: Add tap-lv2.

* gnu/packages/music.scm (tap-lv2): new variable.
---
gnu/packages/music.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ee402bad4d..429719bb2d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5380,3 +5380,43 @@ filtered, pitch shifted and ultimately disintegrated. This is an unofficial
port of the Regrader plugin created by Igorski. It is available as an LV2
plugin and a standalone JACK application.")
(license license:expat)))
+
+(define-public tap-lv2
+ (package
+ (name "tap-lv2")
+ (version "0.0.0-20200406")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/moddevices/tap-lv2.git")
+ (commit "cab6e0dfb2ce20e4ad34b067d1281ec0b193598a")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0q480djfqd9g8mzrggc4vl7yclrhdjqx563ghs8mvi2qq8liycw3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:make-flags
+ (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (replace 'install
+ (lambda _
+ (invoke "make"
+ (string-append "INSTALL_PATH="
+ (assoc-ref %outputs "out")
+ "/lib/lv2")
+ "install"))))))
+ (inputs
+ `(("lv2", lv2)))
+ (native-inputs
+ `(("pkg-config", pkg-config)))
+ (synopsis "Audio plugin collection")
+ (description "TAP (Tom's Audio Processing) plugins is a collection of
+audio effect plugins originally released as LADSPA plugins. This package
+offers an LV2 version ported by moddevices.")
+ (home-page "http://tap-plugins.sf.net/")
+ (license license:gpl2)))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6LRREACgkQAi6uQjE9
cPPWRQf+MIle6hY97RxpGd+MOi93v+K6vBMMJxuhzVEpA4AWXQZkGJvJkaIWDGFc
FyjMLzRUnaEXpD02S1cVF0tMZ2sh/3dIxhLns3DvbwsTCvYNkNGLaeb0vQRr0yBq
JqLv+dwKGxQNK2PdYr+pjdlK+CFlOdA+q8qm86qyKxzqoaDjr+iCwyproTQvJH69
YjtTJsMSS/wIWrDsZ20J30C5rR03cj9DIj9Z1wjWak4mOs2R7Ka1Vd+2EnESfXPJ
4Q2MR76znatY48UPzd5UwjgXlkq8jWI1vaAgBi4xSgRz2/pGseGM6gEwm6DN5buT
942oKXuMRzsHRKCsuPKfR2K4G2G+YA==
=x2lv
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 6 Apr 2020 21:02
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40470@debbugs.gnu.org)
20200406190218.GA5958@jasmine.lan
On Mon, Apr 06, 2020 at 04:04:49PM +0100, Alexandros Theodotou wrote:
Toggle quote (5 lines)
> Hi,
>
> This patch adds tap-lv2, an LV2 port of the TAP LADSPA plugins. I used
> the date as a version because there was no tag.

Can you revise the version number stuff based on the guidelines in the
manual section Version Numbers?


Otherwise LGTM
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl6LfLoACgkQJkb6MLrK
fwhf7BAAqDi5ZNcksLfJSZpTv3IG70p1J0vBCoyrEQuxfA4crpTuaGtW1TSZ4NBR
fspT0LC7h117ffICKrGQpA5RR64l2/37Y265bN3VpSMRXJm/a1qsXzpp0czdOD2f
akMZyJhbzuHsWbyvuL6AsTO56MmE6yQDsRdqsB6MwFL/LIQgaoiqdJbzGV1QH7FN
xDcDTD1das/robfVV47f2N37uRHEfl9YNhKAp6JwFMCD/NTSsnSjPyJRER/hwoUs
i+JW1Sn5Fy7ifkhgo9wCY39b/S+cBc2sqkIKsxp4xWt8e13XZjVPNyztdQRmBnp4
tsH1LYqXqEX0ShluBuOVvdH3ALEzqnRLCK2hHZxAtqzPoXatPWbFNLDCiMGHWRcq
3QyBhxSXPkW3Nd1UT9JKHB9Oz5MUmw9tPxwvbcnH8/KCjJryO93MifmtUHTGqmEz
L9sktErb+JlJzFTHNPBJSM7aGdyha5dML2px5cRDfbz/I8qSIxnR/J8g7btcJ1QF
SZGIo8Ie7Z9sU/9jTpBy4BKouFVyeUEHUkvTJH8dm8jXDSjXIz0G1NotQEzyVF0z
lz5gNHp/7ar4iWtwxq9xxCHudfo+abS3kbGzKdw+9W1QeM73yaQLRKjh9WG3uM0N
XqDTiTKwv43BVjCIehcyR9HP8ywdUwxgISv3vQAyl8/9rWic/Pc=
=tVua
-----END PGP SIGNATURE-----


A
A
Alexandros Theodotou wrote on 6 Apr 2020 23:15
(name . Leo Famulari)(address . leo@famulari.name)(address . 40470@debbugs.gnu.org)
3ba843afdbaffde3e3ad49d87de38d6dd39f4e86.camel@zrythm.org
Hi Leo,

Thanks for the review.

Attaching the updated patch.

Thanks,
Alex

On Mon, 2020-04-06 at 15:02 -0400, Leo Famulari wrote:
Toggle quote (14 lines)
> On Mon, Apr 06, 2020 at 04:04:49PM +0100, Alexandros Theodotou wrote:
> > Hi,
> >
> > This patch adds tap-lv2, an LV2 port of the TAP LADSPA plugins. I
> > used
> > the date as a version because there was no tag.
>
> Can you revise the version number stuff based on the guidelines in
> the
> manual section Version Numbers?
>
> https://guix.gnu.org/manual/en/html_node/Version-Numbers.html#Version-Numbers
>
> Otherwise LGTM
From e0945571b911085e7dae599a3657e2ed47837f7e Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 6 Apr 2020 22:14:47 +0100
Subject: [PATCH] gnu: Add tap-lv2.

* gnu/packages/music.scm (tap-lv2): new variable.
---
gnu/packages/music.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ee402bad4d..f8751cf984 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5380,3 +5380,45 @@ filtered, pitch shifted and ultimately disintegrated. This is an unofficial
port of the Regrader plugin created by Igorski. It is available as an LV2
plugin and a standalone JACK application.")
(license license:expat)))
+
+(define-public tap-lv2
+ (let ((commit "cab6e0dfb2ce20e4ad34b067d1281ec0b193598a")
+ (revision "1"))
+ (package
+ (name "tap-lv2")
+ (version (git-version "0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/moddevices/tap-lv2.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0q480djfqd9g8mzrggc4vl7yclrhdjqx563ghs8mvi2qq8liycw3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:make-flags
+ (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (replace 'install
+ (lambda _
+ (invoke "make"
+ (string-append "INSTALL_PATH="
+ (assoc-ref %outputs "out")
+ "/lib/lv2")
+ "install"))))))
+ (inputs
+ `(("lv2", lv2)))
+ (native-inputs
+ `(("pkg-config", pkg-config)))
+ (synopsis "Audio plugin collection")
+ (description "TAP (Tom's Audio Processing) plugins is a collection of
+ audio effect plugins originally released as LADSPA plugins. This package
+ offers an LV2 version ported by moddevices.")
+ (home-page "http://tap-plugins.sf.net/")
+ (license license:gpl2))))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6Lm/wACgkQAi6uQjE9
cPPrHggAktIERzoBzKPmlJXyFF+ZNkggCzO6PgBJwNYJbDekQJEwNgOlpPVH663T
k8xJmiHex92p7JhbXESBS+GXQJBMKyFPKAtJGg2QBSr2uOzsm9TK6274pfTdQxH9
FR1Y2iHp7i9gntQVCi0T6J4lu0Jr6VOaIeU56/tCEZpMzV3zAOvFeltPj701FcRa
uOyUHU1B1bO10yo8S5TG+K9w1MTPt3/g40dnwpuFjlzRrutx3y0SkeC4AtghGeHB
Z+1Qt9MMO++bhaPPisvZHFhaekS1zk4S+nVTFHZK7WWMsZn1AfyBfzMIbibHs1Ar
uT1D3ao2VQqKcGPSWmowdLGVPfhORw==
=WuOV
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 7 Apr 2020 20:18
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40470-done@debbugs.gnu.org)
20200407181848.GA4477@jasmine.lan
On Mon, Apr 06, 2020 at 10:15:40PM +0100, Alexandros Theodotou wrote:
Toggle quote (2 lines)
> * gnu/packages/music.scm (tap-lv2): new variable.

Thanks for the revised patch!

Toggle quote (2 lines)
I amended this link based on feedback from `guix lint`; it permanently
redirects somewhere else.

I also noticed that we could puth INSTALL_PATH in #:make-flags and not
have to replace the 'install' phase, but I didn't make that change.

Pushed as 2aaf76582d0371127a51a4e112a4d9ff5a30dd37
Closed
?