[PATCH] build-system/gnu: Allow overriding of bootstrap scripts.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 3 Apr 2020 07:11
(address . guix-patches@gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)
20200403051133.10138-1-rekado@elephly.net
* guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Accept
bootstrap-scripts keyword argument and pass it to gnu-build.
(%bootstrap-scripts): New variable.
* guix/build/gnu-build-system.scm (%bootstrap-scripts): Remove variable.
(bootstrap): Remove default value for bootstrap-scripts argument.
---
guix/build-system/gnu.scm | 8 ++++++++
guix/build/gnu-build-system.scm | 6 +-----
2 files changed, 9 insertions(+), 5 deletions(-)

Toggle diff (63 lines)
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index 7266fa0009..f28d59cc5e 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -322,10 +322,15 @@ standard packages used as implicit inputs of the GNU build system."
;; Regexp matching license files.
"^(COPYING.*|LICEN[CS]E.*|[Ll]icen[cs]e.*|Copy[Rr]ight(\\.(txt|md))?)$")
+(define %bootstrap-scripts
+ ;; Typical names of Autotools "bootstrap" scripts.
+ '("bootstrap" "bootstrap.sh" "autogen.sh"))
+
(define* (gnu-build store name input-drvs
#:key (guile #f)
(outputs '("out"))
(search-paths '())
+ (bootstrap-scripts %bootstrap-scripts)
(configure-flags ''())
(make-flags ''())
(out-of-source? #f)
@@ -398,6 +403,7 @@ packages that must not be referenced."
search-paths)
#:phases ,phases
#:locale ,locale
+ #:bootstrap-scripts ,bootstrap-scripts
#:configure-flags ,configure-flags
#:make-flags ,make-flags
#:out-of-source? ,out-of-source?
@@ -476,6 +482,7 @@ is one of `host' or `target'."
(search-paths '())
(native-search-paths '())
+ (bootstrap-scripts %bootstrap-scripts)
(configure-flags ''())
(make-flags ''())
(out-of-source? #f)
@@ -557,6 +564,7 @@ platform."
native-search-paths)
#:phases ,phases
#:locale ,locale
+ #:bootstrap-scripts ,bootstrap-scripts
#:configure-flags ,configure-flags
#:make-flags ,make-flags
#:out-of-source? ,out-of-source?
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index 4df0bb4904..72a188955d 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -163,11 +163,7 @@ working directory."
(chdir (first-subdirectory "."))))
#t)
-(define %bootstrap-scripts
- ;; Typical names of Autotools "bootstrap" scripts.
- '("bootstrap" "bootstrap.sh" "autogen.sh"))
-
-(define* (bootstrap #:key (bootstrap-scripts %bootstrap-scripts)
+(define* (bootstrap #:key bootstrap-scripts
#:allow-other-keys)
"If the code uses Autotools and \"configure\" is missing, run
\"autoreconf\". Otherwise do nothing."
--
2.25.1
R
R
Ricardo Wurmus wrote on 4 Apr 2020 21:40
(address . 40399@debbugs.gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)
87a73rvy3p.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (6 lines)
> * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Accept
> bootstrap-scripts keyword argument and pass it to gnu-build.
> (%bootstrap-scripts): New variable.
> * guix/build/gnu-build-system.scm (%bootstrap-scripts): Remove variable.
> (bootstrap): Remove default value for bootstrap-scripts argument.

This is for the next core-updates branch.

--
Ricardo
C
C
Christopher Baines wrote on 18 Dec 2020 12:19
Re: [bug#40399] [PATCH] build-system/gnu: Allow overriding of bootstrap scripts.
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 40399@debbugs.gnu.org)
871rfn2wgd.fsf@cbaines.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (10 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Accept
>> bootstrap-scripts keyword argument and pass it to gnu-build.
>> (%bootstrap-scripts): New variable.
>> * guix/build/gnu-build-system.scm (%bootstrap-scripts): Remove variable.
>> (bootstrap): Remove default value for bootstrap-scripts argument.
>
> This is for the next core-updates branch.

This looks reasonable to me, I believe now is a good time to push to
core-updates as well.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/ckDJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcOoQ/+MRcNQnW1vkhVlgv4CqITbDOO9d82dOwp
G+RF7a6c1fjen4H+Sgcfe5djA0xig7rCKlkzkTPcJ0lll5HRve9/pIDdq6lMxQcz
BaCQRz3TM1Uvc2gjCFQEq/lmv1O1/tCIySJTvHVl3foJKV+wrkfp2ryoBSO315v5
p9sFfYHlcPag44zUTL4amaNhGhVyF5XZ0YEr9UfAfFcUNWtSJdogzV7Ukl9VVYgY
fAsDr3nidjcurJqLjur0FfohdEhixIegqcfMJ7XrUklD2g137AFAhogWlO+cIHzl
2kRvtv0mS5zuvmPsNd+vR5znfV4Pnz5fX+L0Zz8UD8bwFISyFiwu6/LKra80KQ1X
sFeR/ORPOLmAVxj/1GfMPAEonOZKDePH7/+A+wOHtN/fTDL0eI7kBXeHEJ0EZwpJ
6uqValwRp/rXxNBv45qP7JPAY0XG9pq+gdBU0H4P9TycJAh3ahsyGL8DIZ9aOhnP
B8qB9vIJhFuF2ZWa1rXouMdym5dpH6fDuu9e4jOFrOCxD+XrLKKmpANC2i6C12VV
ho0bYXE+8CD4SJIgDKkAoVRQ7mdo+rwqfItXC2S2xP3AxC2hwS0DZKJTEKqst6yy
o15LZ15BEw08oUVZ13tZ7vlDoYjwsiPrPxahGAkFplcuT9mdxdYJxMEU/JEJ+ir5
Pk4bSTPix4I=
=aCqb
-----END PGP SIGNATURE-----

R
R
Ricardo Wurmus wrote on 23 Dec 2020 13:36
(name . Christopher Baines)(address . mail@cbaines.net)(address . 40399-done@debbugs.gnu.org)
87tuscn1hb.fsf@elephly.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (15 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> Ricardo Wurmus <rekado@elephly.net> writes:
>>
>>> * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Accept
>>> bootstrap-scripts keyword argument and pass it to gnu-build.
>>> (%bootstrap-scripts): New variable.
>>> * guix/build/gnu-build-system.scm (%bootstrap-scripts): Remove variable.
>>> (bootstrap): Remove default value for bootstrap-scripts argument.
>>
>> This is for the next core-updates branch.
>
> This looks reasonable to me, I believe now is a good time to push to
> core-updates as well.

Thanks for the review.

I pushed it to core-updates.

--
Ricardo
Closed
?