[PATCH 0/5] Make some inputs native.

  • Done
  • quality assurance status badge
Details
3 participants
  • Mathieu Othacehe
  • Marius Bakke
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal
V
V
Vincent Legoll wrote on 2 Apr 2020 01:20
(address . guix-patches@gnu.org)
CAEwRq=pLfCWkn9VDnm3NK=1VGt_FyFBdvzYNCoXnOkbEvb+BnA@mail.gmail.com
This is the reworked patchset sent yesterday
to guix-devel.

I hope I did not miss any review comment.

I dropped the cgit patch, reworded the commit
messages, added perl to the native-inputs of
darktable, guix linted all (graphviz still has some
lint problems, looks like they moved to gitlab, I'll
let that for another day)

--
Vincent Legoll
V
V
Vincent Legoll wrote on 2 Apr 2020 01:22
[PATCH 1/5] gnu: darktable: Make some inputs native.
(address . 40383@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20200401232225.27766-1-vincent.legoll@gmail.com
* gnu/packages/photo.scm (darktable)[inputs]: Move intltool, perl & pkg-config
from here...
[native-inputs]: ...to here.
---
gnu/packages/photo.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 585289daf1..7cb67dcbe6 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Sebastian Schott <sschott@mailbox.org>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -483,6 +484,10 @@ photographic equipment.")
(string-append (assoc-ref inputs "ilmbase")
"/include/OpenEXR:" (or (getenv "CPATH") "")))
#t)))))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("libxslt" ,libxslt)
("libxml2" ,libxml2)
@@ -502,9 +507,6 @@ photographic equipment.")
("ilmbase" ,ilmbase)
("libsoup" ,libsoup)
("python-jsonschema" ,python-jsonschema)
- ("intltool" ,intltool)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
("libwebp" ,libwebp)
("lensfun" ,lensfun)
("librsvg" ,librsvg)
--
2.25.2
V
V
Vincent Legoll wrote on 2 Apr 2020 01:22
[PATCH 2/5] gnu: graphviz: Make some inputs native.
(address . 40383@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20200401232225.27766-2-vincent.legoll@gmail.com
* gnu/packages/graphviz.scm (graphviz)[inputs]: Move swig from here...
[native-inputs]: ...to here.
---
gnu/packages/graphviz.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 2d2bb11130..051089881a 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -97,7 +98,6 @@
("gts" ,gts)
("gd" ,gd) ; FIXME: Our GD is too old
("guile" ,guile-2.0) ;Guile bindings
- ("swig" ,swig)
("pango" ,pango)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
@@ -108,6 +108,7 @@
("libpng" ,libpng)))
(native-inputs
`(("bison" ,bison)
+ ("swig" ,swig)
("pkg-config" ,pkg-config)))
(outputs '("out" "doc")) ; 5 MiB of html + pdfs
(home-page "http://www.graphviz.org/")
--
2.25.2
V
V
Vincent Legoll wrote on 2 Apr 2020 01:22
[PATCH 3/5] gnu: iwd: Make some inputs native.
(address . 40383@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20200401232225.27766-3-vincent.legoll@gmail.com
* gnu/packages/networking.scm (iwd)[inputs]: Move libtool from here...
[native-inputs]: ...to here.
---
gnu/packages/networking.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index ec2f0b64bd..79b07e23f0 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2712,13 +2712,13 @@ protocol daemons for BGP, IS-IS, LDP, OSPF, PIM, and RIP. ")
(build-system gnu-build-system)
(inputs
`(("dbus" ,dbus)
- ("libtool" ,libtool)
("ell" ,ell)
("readline" ,readline)))
(native-inputs
`(("asciidoc" ,asciidoc)
("autoconf" ,autoconf)
("automake" ,automake)
+ ("libtool" ,libtool)
("pkgconfig" ,pkg-config)
("python" ,python)
("openssl" ,openssl)))
--
2.25.2
V
V
Vincent Legoll wrote on 2 Apr 2020 01:22
[PATCH 4/5] gnu: mailutils: Make some inputs native.
(address . 40383@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20200401232225.27766-4-vincent.legoll@gmail.com
* gnu/packages/mail.scm (mailutils)[inputs]: Move dejagnu from here...
[native-inputs]: ...to here.
---
gnu/packages/mail.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 0cb3eddf15..ed14360066 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -218,11 +219,11 @@
#:parallel-tests? #f))
(native-inputs
- `(("perl" ,perl))) ;for 'gylwrap'
- (inputs
- `(("dejagnu" ,dejagnu)
- ("m4" ,m4)
+ `(("perl" ,perl) ;for 'gylwrap'
("texinfo" ,texinfo)
+ ("dejagnu" ,dejagnu)))
+ (inputs
+ `(("m4" ,m4)
("guile" ,guile-2.2)
("gsasl" ,gsasl)
("gnutls" ,gnutls)
--
2.25.2
V
V
Vincent Legoll wrote on 2 Apr 2020 01:22
[PATCH 5/5] gnu: nethack: Make some inputs native.
(address . 40383@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20200401232225.27766-5-vincent.legoll@gmail.com
* gnu/packages/games.scm (nethack)[inputs]: Move flex & bison from here...
[native-inputs]: ...to this new field.
---
gnu/packages/games.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8a24dad33d..4d4b2b0b05 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
;;; Copyright © 2020 Vitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1293,10 +1294,11 @@ watch your CPU playing while enjoying a cup of tea!")
(string-join (string-split version #\.) "") "-src.tgz"))
(sha256
(base32 "1liyckjp34j354qnxc1zn9730lh1p2dabrg1hap24z6xnqx0rpng"))))
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)))
(inputs
`(("ncurses" ,ncurses)
- ("bison" ,bison)
- ("flex" ,flex)
("less" ,less)))
(build-system gnu-build-system)
(arguments
--
2.25.2
M
M
Mathieu Othacehe wrote on 2 Apr 2020 11:16
Re: [bug#40383] [PATCH 0/5] Make some inputs native.
(address . guix-patches@gnu.org)
877dyycknh.fsf@gmail.com
Hello Vincent,

Toggle quote (8 lines)
> I hope I did not miss any review comment.
>
> I dropped the cgit patch, reworded the commit
> messages, added perl to the native-inputs of
> darktable, guix linted all (graphviz still has some
> lint problems, looks like they moved to gitlab, I'll
> let that for another day)

Thanks for the updated serie. Some of these patches trigger a lot of
rebuilds. If you read this page[1], point 8, you will see that there's a
limit of 300 dependencies for pushing to master.

Graphviz has 1370 dependencies, which makes it a candidate for
core-updates branch that has been frozen recently. Maybe we can start a
'core-updates-next' branch. Marius, WDYT?

Mailutils has 125 dependencies, which is under the 300 limit so I'll
push it on master.

The other patches are fine :)

Thanks,

Mathieu

M
M
Marius Bakke wrote on 2 Apr 2020 18:01
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(address . 40383@debbugs.gnu.org)
87ftdlswpv.fsf@devup.no
Mathieu Othacehe <m.othacehe@gmail.com> writes:

Toggle quote (4 lines)
> Graphviz has 1370 dependencies, which makes it a candidate for
> core-updates branch that has been frozen recently. Maybe we can start a
> 'core-updates-next' branch. Marius, WDYT?

I've been meaning to rework the rebuild limits from the manual as a lot
has changed since that was written. In particular I want to keep "mesa"
on 'staging', but that has crept to almost 2000 rebuilds!

Perhaps we need another tier in between staging and core-updates, or
just aim for slower staging cycles (as has been de facto a while..).

Anyway for now I think this can go to 'staging'.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6GDFwACgkQoqBt8qM6
VPrGcwgAg0evEpRytmmA9U9bmgRwY0tf/NHhAU9pVIRwSUsL2UEZvuKAnDfTgTzq
nyMOn78CQhYMpHerDUkqVbn5o8gYDjPxoeOn81yWJS1c4KZcaBN3nJ6dTpWFf8NF
zoFLvTCeuflwojm3PyugwYgoWBSj0S6pWziOxcu6cq9aBHynln/IS1c8X+2Fhm5U
zo+uXvidJEY2UHkS4aGlND33eNuzJliVe84BSha/zm+j1F1CoZjcSj+xMwvQqhaZ
aBVcOBQePkyNht3O4qSgMqFAYXeqGZCLFPIKLsdl1i6iMgd4jfzjXy/hfPaFPwIh
4lRVGrP8UT0mFFc+4javOGYoW6u89A==
=571Z
-----END PGP SIGNATURE-----

M
M
Mathieu Othacehe wrote on 2 Apr 2020 18:18
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 40383@debbugs.gnu.org)
87k12x275f.fsf@gmail.com
Toggle quote (4 lines)
> I've been meaning to rework the rebuild limits from the manual as a lot
> has changed since that was written. In particular I want to keep "mesa"
> on 'staging', but that has crept to almost 2000 rebuilds!

Yup, an updated documentation section would be great!

Toggle quote (6 lines)
>
> Perhaps we need another tier in between staging and core-updates, or
> just aim for slower staging cycles (as has been de facto a while..).
>
> Anyway for now I think this can go to 'staging'.

Ok, pushed on staging, thanks for your help.

Mathieu
M
M
Mathieu Othacehe wrote on 2 Apr 2020 18:20
(address . guix-patches@gnu.org)(address . 40383-done@debbugs.gnu.org)
87d08p272g.fsf@gmail.com
I pushed the graphviz patch on the staging branch and the other ones on
master.

Thanks,

Mathieu
V
V
Vincent Legoll wrote on 2 Apr 2020 19:44
numerous rebuilds
(address . 40383@debbugs.gnu.org)
CAEwRq=pK5i-jZYqYddcm2cCBQijb4FRp=v5hzrmRmfXYwSX3eg@mail.gmail.com
Mathieu,

I knew about the rebuild limit, and
told about it in the other thread:

Toggle quote (4 lines)
> The graphviz patch may not be for master
> as it may force 2918 packages to be rebuilt.
> The other ones should be OK.

But it has been a long thread.

I should have restated it here, in the repost...

Thanks

--
Vincent Legoll
?