[PATCH] gnu: Add tuir.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Marius Bakke
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 29 Mar 2020 16:23
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20200329142300.26328-1-efraim@flashner.co.il
* gnu/packages/syndication.scm (tuir): New variable.
---
gnu/packages/syndication.scm | 41 +++++++++++++++++++++++++++++++++++-
1 file changed, 40 insertions(+), 1 deletion(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index a84281364f..7e62636835 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -136,3 +136,42 @@ It started life as a fork of the currently unmaintained Newsbeuter.")
"RTV provides a text-based interface to view and interact with Reddit.")
(license (list license:expat
license:gpl3+)))) ; rtv/packages/praw
+
+(define-public tuir
+ (package
+ (name "tuir")
+ (version "1.28.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tuir" version))
+ (sha256
+ (base32
+ "1gpyjrl7jdfjq30m32nzh59ajv91gq19l93jjri2wsv5yrf90hdr"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "py.test" "-v"))))))
+ (propagated-inputs
+ `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-decorator" ,python-decorator)
+ ("python-kitchen" ,python-kitchen)
+ ("python-requests" ,python-requests)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-coveralls" ,python-coveralls)
+ ("python-mock" ,python-mock)
+ ("python-pylint" ,python-pylint)
+ ("python-pytest" ,python-pytest)
+ ("python-vcrpy" ,python-vcrpy)))
+ (home-page "https://gitlab.com/ajak/tuir")
+ (synopsis "Terminal viewer for Reddit (Terminal UI for Reddit)")
+ (description
+ "Tuir provides a simple terminal viewer for Reddit (Terminal UI for Reddit).")
+ (license (list license:expat
+ license:gpl3+)))) ; tuir/packages/praw
--
2.26.0
M
M
Marius Bakke wrote on 2 Apr 2020 19:14
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87h7y1rery.fsf@devup.no
Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (2 lines)
> * gnu/packages/syndication.scm (tuir): New variable.

[...]

Toggle quote (15 lines)
> + (build-system python-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (replace 'check
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (add-installed-pythonpath inputs outputs)
> + (invoke "py.test" "-v"))))))
> + (propagated-inputs
> + `(("python-beautifulsoup4" ,python-beautifulsoup4)
> + ("python-decorator" ,python-decorator)
> + ("python-kitchen" ,python-kitchen)
> + ("python-requests" ,python-requests)
> + ("python-six" ,python-six)))

As this is a terminal application, I guess these inputs can be regular
inputs instead of propagated? The 'wrap' phase should take care of
things automatically.

Also note that "py.test" is deprecated and one is supposed to use just
"pytest" nowadays IIRC.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6GHXEACgkQoqBt8qM6
VPqG0QgAwosbXbONrRNBOOcaUMTAnnJskK9zwZEAJyNCXdzX+Vdub6QToaN2Hec8
glC5RfW9pxofXfSPmIpe6Qw4T1KYRvsKjLMGTCW1sAEwZ5Rw6+/Gjlbg5d/Pj+sI
fBdi0wWaQmExhRLWr/N0zH9bo6c8h5JMRFR2UmDsDHxhqrf4T41+u0FyBVAzR6jL
/Gj4bwOer42a2NOU/dmyIoRnILsfUc88XvDzvfsVtXycBd0CaNLmQVV9FOSLwOA2
D9dfmTbVPxP+to5Tjo+Fyp9gXFVFYvnzVrj/mN70rzvELDlAJ9cVhy+d6JISKf9b
CijSPNkd84UKVlCM59nyCjK8daUkuA==
=j820
-----END PGP SIGNATURE-----

E
E
Efraim Flashner wrote on 5 Apr 2020 08:44
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 40318-done@debbugs.gnu.org)
20200405064449.GA1518@E5400
On Thu, Apr 02, 2020 at 07:14:25PM +0200, Marius Bakke wrote:
Toggle quote (26 lines)
> Efraim Flashner <efraim@flashner.co.il> writes:
>
> > * gnu/packages/syndication.scm (tuir): New variable.
>
> [...]
>
> > + (build-system python-build-system)
> > + (arguments
> > + `(#:phases
> > + (modify-phases %standard-phases
> > + (replace 'check
> > + (lambda* (#:key inputs outputs #:allow-other-keys)
> > + (add-installed-pythonpath inputs outputs)
> > + (invoke "py.test" "-v"))))))
> > + (propagated-inputs
> > + `(("python-beautifulsoup4" ,python-beautifulsoup4)
> > + ("python-decorator" ,python-decorator)
> > + ("python-kitchen" ,python-kitchen)
> > + ("python-requests" ,python-requests)
> > + ("python-six" ,python-six)))
>
> As this is a terminal application, I guess these inputs can be regular
> inputs instead of propagated? The 'wrap' phase should take care of
> things automatically.
>

Good call, I forgot about that one.

Toggle quote (3 lines)
> Also note that "py.test" is deprecated and one is supposed to use just
> "pytest" nowadays IIRC.

TIL. I was working from their test suite command.

Patch pushed.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl6JfmEACgkQQarn3Mo9
g1GKbhAAuU5Ce8ZfnwxSvKhDxg2lBeqM7JfwtK/7t8tl/6VpML5S2XMVWO2zHKJF
DNBJl9j1eHJmVfrjZ9VYkVgqEaKMuqlsSVeMuFidF2R9g5LRoEs/ZbANTWMeCuMT
hhmB6Fa32vwQtlfDNJt8fVdTJq4P56kZJwhpOoLB/NbkqD2bBxFaoZ4gLE7wCXJJ
n6em7GIurAUF0NXRKWglSFaLfe3ac14FpyfGI61kWKYm2GkI2QhfVvQfWd2B3FQm
TexEfrzoVg/qalldnlE0xO270UJTps+huHLR2kplu4ElVmAXaDMYQOkgVgssgv1/
W0OpvzDbvjJg8tXyjuc6WC/aD3LhE61TIATpylGPK0I2Z8rxLYCHxBRWIA5cahO1
YzhpxgWnzipOm0n3wUCgwBsavDKsVq3Muz4JUOCuh/EV2vCAdhdG3l2/UF98+xOd
it+FY55sONiBf6IFbQEqAy1GFXFvmWQXdnw/7+T9mNdWqCCiB4dKAJ6Bi2uBPyFe
IAojBAfc3Fqxzi/V5VCugucr8TKJwSXC4GkR2M4okHSGbJvxNrKKrQd232s466+Y
qnb5QuBMyKv5lDbUGoFgupgl/Qi2nrqi/0gE0gqWYWGdeMg1XFxePl5FkIO8JrJg
JggmB3F0GLHx1gBq+OtheinlWRd+wm6AAV2zinEJmbt7+K/xm+4=
=/4OZ
-----END PGP SIGNATURE-----


Closed
?