[PATCH] gnu: Add emacs-next-minimal.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Christopher Baines
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 29 Mar 2020 01:02
(address . guix-patches@gnu.org)
87sghs2fl6.fsf@asu.edu
Hi Guix,

In preparation for the next emacs version I thought it would be good to
start adding "next" versions of some emacs packages. I added this for
proof-general, but there may be other needs for the minimal emacs for
version 27.

Thanks,

John
Toggle quote (1 lines)
>From 100e821af07716c463131acdb695bce630e2efa4 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 10:38:15 -0700
Subject: [PATCH] gnu: Add emacs-next-minimal.

* gnu/packages/emacs.scm (emacs-next-minimal): New variable.
---
gnu/packages/emacs.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ec8de7373b..5d031b9695 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2019 Valentin Ignatev <valentignatev@gmail.com>
;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -354,6 +355,34 @@ languages.")
(native-inputs
`(("pkg-config" ,pkg-config)))))
+(define-public emacs-next-minimal
+ (package
+ (inherit emacs-next)
+ (name "emacs-next-minimal")
+ (synopsis (package-synopsis emacs-minimal))
+ (build-system gnu-build-system)
+ (inputs
+ `(("jansson" ,jansson)
+ ("texinfo" ,texinfo)
+ ,@(package-inputs emacs-minimal)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ,@(package-native-inputs emacs-minimal)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments emacs-next)
+ ((#:modules _)
+ `((guix build emacs-utils)
+ ,@%gnu-build-system-modules))
+ ((#:imported-modules _)
+ `((guix build emacs-utils)
+ ,@%gnu-build-system-modules))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'install-site-start)
+ (delete 'restore-emacs-pdmp)))
+ ((#:configure-flags flags ''())
+ `(list "--with-gnutls=no" "--disable-build-details"))))))
+
(define-public emacs-xwidgets
(package
(inherit emacs)
--
2.26.0
C
C
Christopher Baines wrote on 18 Dec 2020 11:57
(name . John Soo)(address . jsoo1@asu.edu)(address . 40297@debbugs.gnu.org)
877dpf2xg2.fsf@cbaines.net
John Soo <jsoo1@asu.edu> writes:

Toggle quote (7 lines)
> Hi Guix,
>
> In preparation for the next emacs version I thought it would be good to
> start adding "next" versions of some emacs packages. I added this for
> proof-general, but there may be other needs for the minimal emacs for
> version 27.

Hey John,

This seems OK to me, although I haven't used the emacs-next stuff.

I applied this patch, and built the package, but bin/emacs within the
package is empty, which means Emacs doesn't actually start.

→ ls -lh /gnu/store/nv9bk1l8292cvlvxm96q8bdkg36cdnc9-emacs-next-minimal-28.0.50-0.2ea3466/bin/emacs-28.0.50
-r-xr-xr-x 247 root root 0 Jan 1 1970 /gnu/store/nv9bk1l8292cvlvxm96q8bdkg36cdnc9-emacs-next-minimal-28.0.50-0.2ea3466/bin/emacs-28.0.50

Since it's taken so long for someone to get around to looking at this
patch, it's possible that this wasn't an issue back when you submitted
this.

Any ideas?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/ciy1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdrAg/9EA9bVLy6h+OuAc4wrBTTbIz2LABnSC7Y
eiJmVtSAJ+JbWl3FHNbsEOOs997rsbLKRfzeKqFUBbFz+buXpO7Gpv366YlTI+CA
gaYVLkPjyfPhcUVqPBehQEILduArxmQeqzOe/KyiNCwYvTWJDE5Tye3HftoDK3ty
e92ruEkC/BjTX8W9ux9LmD0wQ/xsMNsVzlXnwr5kvFSCR002vg7SQ8cf1oKP+Bpx
DKYJYEuGVv851/L5d4CkZXbPq7vB8uYEPupdVgmBjtPbyTR2SS+Q5RUVHycFLN0x
ki+SIa7tyBinb/fVifQqhIvJhftQRYuOEzuXSMI0Um3nf0mqpfz0ydubDXrDPZU0
QJWB6CVLb9kRZkO+iIu6gQiVt9i4J5ruW4fR6gHT2NJ66BwQ6LMT+8VHs71UrARB
rZaGY/Z255oFYNg4m7vQAEmNrXBsofz4gVok5akx0ld9dinpFiICQZwisr1XetUm
4N2LNT7VH+inkrJRms3kj7RNCTUJGZUPHfLkB8kjisHbfxsYiJLL3camGUHOLo9E
J2y8Xboov1N4jr4khKIyWCbBbPs4Gi6x8mVfdOzneR9Tsn2ohmnEnls2xZdpF9EN
cxos0GKDeYs33MTZDitPncvXrDn1bZXdAa7gxkW7Y+EoCBNYaI1wMvYKGE1btyig
cRDL8O806WQ=
=UQFh
-----END PGP SIGNATURE-----

J
J
John Soo wrote on 15 Feb 2021 23:21
Closed with emacs 27
(address . 40297-done@debbugs.gnu.org)
87zh05c6qw.fsf@asu.edu

Closed
?