[PATCH] gnu: Add emacs-evil-leader.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 27 Mar 2020 22:52
(address . guix-patches@gnu.org)
87lfnlihz1.fsf@asu.edu
Hi Guix,

Evil leader provides <leader> functionality from vim in evil mode.

Thanks,

John
From 8f508375cde9bce3071bcaa4db57f7a81e600163 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:42:01 -0700
Subject: [PATCH] gnu: Add emacs-evil-leader.

* gnu/packages/emacs-xyz.scm (emacs-evil-leader): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fea4f6dc49..bab7697a9f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21891,3 +21891,30 @@ panes.")
*Ilist* buffer is typically shown as a sidebar (Emacs vertically splits the
window).")
(license license:gpl3+)))
+
+(define-public emacs-evil-leader
+ (package
+ (name "emacs-evil-leader")
+ (version "0.4.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/cofi/evil-leader")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k2zinchs0jjllp8zkpggckyy63dkyi5yig3p46vh4w45jdzysk5"))))
+ (inputs
+ `(("emacs-evil" ,emacs-evil)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/cofi/evil-leader")
+ (synopsis "Provides the leader feature from Vim")
+ (description
+ "Evil Leader provides the @code{<leader>} feature from Vim that provides
+an easy way to bind keys under a variable prefix key. For an experienced
+Emacs User it is nothing more than a convoluted key map, but for a Evil user
+coming from Vim it means an easier start.")
+ (license license:gpl3+)))
--
2.26.0
J
J
John Soo wrote on 29 Mar 2020 00:24
(address . 40261@debbugs.gnu.org)
87y2rk2hby.fsf@asu.edu
Hi Guix,

I realized my patch was based on previous work.

I cherry picked it onto master.

Thanks,

John
Toggle quote (1 lines)
>From 194b5600cc27534b3cc3babfc20018392111c818 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:42:01 -0700
Subject: [PATCH] gnu: Add emacs-evil-leader.

* gnu/packages/emacs-xyz.scm (emacs-evil-leader): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d40b8019e..8f4e3f11ce 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21776,3 +21777,30 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-evil-leader
+ (package
+ (name "emacs-evil-leader")
+ (version "0.4.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/cofi/evil-leader")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k2zinchs0jjllp8zkpggckyy63dkyi5yig3p46vh4w45jdzysk5"))))
+ (inputs
+ `(("emacs-evil" ,emacs-evil)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/cofi/evil-leader")
+ (synopsis "Provides the leader feature from Vim")
+ (description
+ "Evil Leader provides the @code{<leader>} feature from Vim that provides
+an easy way to bind keys under a variable prefix key. For an experienced
+Emacs User it is nothing more than a convoluted key map, but for a Evil user
+coming from Vim it means an easier start.")
+ (license license:gpl3+)))
--
2.26.0
N
N
Nicolas Goaziou wrote on 1 Apr 2020 15:58
(name . John Soo)(address . jsoo1@asu.edu)(address . 40261-done@debbugs.gnu.org)
878sjf2tpb.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (2 lines)
> Subject: [PATCH] gnu: Add emacs-evil-leader.

Applied as ec7d4b4de6b2aec68acd9c5b8672295a2b6c78fb. Thank you!

Regards,

--
Nicolas Goaziou
Closed
?