[PATCH] gnu: Add emacs-evil-tmux-navigator.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Christopher Baines
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 27 Mar 2020 22:46
(address . guix-patches@gnu.org)
87r1xdii8q.fsf@asu.edu
Hi Guix,

evil-tmux-navigator provides seeemless switching between tmux and emacs
panes with nice evil keybindings. It hasn't seen a commit in a long time
but I think that is because it seems to be very stable.

Thanks,

John
From 318bceb99d436d4e94dab66ffa611340e325683e Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:27:15 -0700
Subject: [PATCH] gnu: Add emacs-evil-tmux-navigator.

* gnu/packages/emacs-xyz.scm (emacs-evil-tmux-navigator): New Variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b2ee94bc91..5cc3334aab 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21839,3 +21839,29 @@ conventions.")
(synopsis "Flycheck support for the elm language")
(description "Flycheck support for the elm language.")
(license license:gpl2+)))
+
+(define-public emacs-evil-tmux-navigator
+ (package
+ (name "emacs-evil-tmux-navigator")
+ (version "0.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/keith/evil-tmux-navigator")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1na44rbc03sr5b4z9pvnps6n4nmrqcz58nywix9825l74a419ijx"))))
+ (inputs
+ `(("emacs-evil" ,emacs-evil)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/keith/evil-tmux-navigator")
+ (synopsis
+ "Navigate seamlessly between emacs windows and tmux panes")
+ (description
+ "Use C-h, C-j, C-k and C-l to navigate between emacs windows and tmux
+panes.")
+ (license license:expat)))
--
2.26.0
J
J
John Soo wrote on 28 Mar 2020 21:52
[PATCH] gnu: Add emacs-evil-tmux-navigator
(address . 40259@debbugs.gnu.org)
87ftds42xp.fsf@asu.edu
Hi Guix,

I realized my last patch was based on previous work.

I cherry-picked this one onto master.

Thanks,

John
Toggle quote (1 lines)
>From dfb75bb602bcea6c7a7a59f6b18bf0f0abad0489 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 19 Mar 2020 09:27:15 -0700
Subject: [PATCH] gnu: Add emacs-evil-tmux-navigator.

* gnu/packages/emacs-xyz.scm (emacs-evil-tmux-navigator): New Variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 86033fd200..c69af1e4a4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21774,3 +21775,29 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-evil-tmux-navigator
+ (package
+ (name "emacs-evil-tmux-navigator")
+ (version "0.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/keith/evil-tmux-navigator")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1na44rbc03sr5b4z9pvnps6n4nmrqcz58nywix9825l74a419ijx"))))
+ (inputs
+ `(("emacs-evil" ,emacs-evil)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/keith/evil-tmux-navigator")
+ (synopsis
+ "Navigate seamlessly between emacs windows and tmux panes")
+ (description
+ "Use C-h, C-j, C-k and C-l to navigate between emacs windows and tmux
+panes.")
+ (license license:expat)))
--
2.26.0
C
C
Christopher Baines wrote on 1 Apr 2020 10:11
(name . John Soo)(address . jsoo1@asu.edu)(address . 40259-done@debbugs.gnu.org)
87blobaam3.fsf@cbaines.net
John Soo <jsoo1@asu.edu> writes:

Toggle quote (6 lines)
> Hi Guix,
>
> I realized my last patch was based on previous work.
>
> I cherry-picked this one onto master.

Hi John,

Thanks for the patch. I've now pushed this as
1d5c93d9f8a13588695490db6516b40f54e91fa2.

I made a few changes, I move the package up from the bottom of the
file. I'd always recommend not adding new packages at the bottom of the
module files, as if everyone does this, it becomes harder to apply
patches because there are more conflicts. In this case, I think this
patch ended up conflicting with your addition of emacs-haskell-snippets,
also to the bottom of the emacs-xyz.scm file.

I also tweaked emacs-evil to be a propagated input, just because that
looked to be what the existing emacs-evil-... packages do, and I tweaked
the description to start with "This package lets you " so it reads as a
complete sentance.

Thanks again,

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl6ETMRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xd3EA/+Oe0Mi4eZ0jWZc9ip7Mb6xBiKcBknnMcPMuQDZIVFyeNE+XDrWSiytIoD
o1W03FvS0v6FGjLUT3TTrSSwjgkW4gWpDAf8Sg//2V5bmiZxkYsupXliL9B5TzmJ
lGb01/+gdThExHynl2E3/de99DDdPxtEbvlJguSSS9x4kdYx2Xa+OHbuamoL0Yml
2RELnTtFiSOROY7CdnV6zfHev0eTc1wdBWE4fYXdyKQJqF5p2Hx3Vmsz9ZYeLGQ1
kWASZeE6nm1UFPi4r52AmIJkUB2kCoLAtNT2wDWJX1aA18NZ/uA3aOE4jw3mdWeS
3tM6W1o4hFPJGrs1WFbPZVaiCsm1eVom/RctZoM2O9Bn1Kmdo5SgYR0yIjZoVSbw
Aqi2bzaiiSE/1mps6TeLxTY/vXzKep/3a2TxTbVRi/tJwoaboKlQ3KsyGGs4U/fQ
JLqBv2dawlwNaZCD5l2U3JqN6IZhbGtl0IfjQZuuS5wkmygozj4qrwkJVg5AH2j8
FqPoqCj1WHz9rCH6zuFJYuiojEWjTpF2c71QbP/Fc7JXuiA8yvS8H50DHSf+D6I/
GrO0yEJ3mJu4IoGikPBrCmLoDkcIrY08d30EfTYnwEMApsJ3+K2+LiAxR1aQdjbG
OGsvuiA8pNgN7tEZaZPO0Q1Qhz2gFm3yyDKHBXdotF/j0Z6c9Yk=
=W5Ew
-----END PGP SIGNATURE-----

Closed
?