[PATCH] gnu: sord: Add pcre to inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 23 Mar 2020 17:56
(name . Guix patches)(address . guix-patches@gnu.org)
6ed9c333f5aa1fbb7d5d2f768d9babc223499e30.camel@zrythm.org
Hi,

Sord did not have the `sord_validate` binary (which is needed for
`lv2_validate` from the lv2 package to function properly).

I looked it up and apparently it needs pcre to build:

I have verified that adding pcre as an input now produces sord_validate
in /bin.

Thanks,
Alex
From 3edad6b801d4328e0ebdf9a9244a00fcbd8fda70 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 23 Mar 2020 16:51:44 +0000
Subject: [PATCH] gnu: sord: Add pcre to inputs.

* gnu/packages/rdf.scm (sord): Add pcre needed for sord_validate
---
gnu/packages/rdf.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index b9abd37e40..15f8d64d43 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -319,6 +319,8 @@ ideal (e.g. in LV2 implementations or embedded applications).")
(string-append "-Wl,-rpath="
(assoc-ref outputs "out") "/lib"))
#t)))))
+ (inputs
+ `(("pcre" ,pcre)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(propagated-inputs
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl546iUACgkQAi6uQjE9
cPP99AgAicMOtYcJzMywSRAUcbYVxDebVvXpMqltq577g4knvhS7PAFuM+fMXJP0
9oZ3lMVNoIpa5kJuhUdrx/kPtAx/HJe35yAnFCGzo+bJ1xWaHRdE5uSLnwJBYukH
Z+8KrvECxkmC8CPSLA+xCwGt3UZv4+Oe3UaROggB9mqIgAsfkDkoO23zLtw701AJ
S2r6vcGILAIqTGkDZx142d96w28sn4ND7ZgzursLEXo3dJ1YSDvPjZWRjqLuUdTc
Fw7rX1DsI3pzvbi6RZCk3Y3xh9Df+A4PNy0J01jrpebxGHW/VmkJrGwDazw0p5oV
D9KsyK+auYqKFJ4YhnTKE4AQjbVdug==
=OLhn
-----END PGP SIGNATURE-----


M
M
Mathieu Othacehe wrote on 23 Mar 2020 20:54
(address . guix-patches@gnu.org)(address . 40197-done@debbugs.gnu.org)
87369yzw2b.fsf@gmail.com
Hello,

Toggle quote (6 lines)
> I looked it up and apparently it needs pcre to build:
> https://gitlab.com/drobilla/sord/-/blob/master/wscript#L211
>
> I have verified that adding pcre as an input now produces sord_validate
> in /bin.

Thanks for this patch. I added your copyright, edited a bit the commit
message and pushed.

Mathieu
?