[PATCH 0/3] gnu: Add r-remoter and its dependencies

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Todor Kondi?
Owner
unassigned
Submitted by
Todor Kondi?
Severity
normal
T
T
Todor Kondi? wrote on 17 Mar 2020 13:54
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
0HD-jgnK1IoX44ACJuDfTEKl0iDqgtcVvhNk_Vxq3ULgY_-w2uDojCmYtBRcziY84KfTy4Fc6LxUPuJYt-iitM0U3cZ_DrsqCHB0sjl2GZk=@protonmail.com
Lets make life difficult by submitting git patches using a web interface.
T
T
Todor Kondi? wrote on 17 Mar 2020 14:06
[PATCH 1/3] gnu: Add r-argon2
(name . 40101@debbugs.gnu.org)(address . 40101@debbugs.gnu.org)
Rh_a5PVREyUuoGEyjGAQj2WWiy_eR75m6piwx90wEfiwehyN0AaF_SNp2MYHH147Gd-eXsh71ZOaDIagMktare5Y1BTuDVwxIfAXL6NkXf4=@protonmail.com
* gnu/packages/statistics.scm (r-argon2): New variable.
---
gnu/packages/statistics.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 6616780081..7e3b62c035 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5824,3 +5824,23 @@ Java package that provides routines for various statistical distributions.")
Emacs. It is designed to support editing of scripts and interaction with
various statistical analysis programs such as R, Julia, and JAGS.")
(license license:gpl2+)))
+
+(define-public r-argon2
+ (package
+ (name "r-argon2")
+ (version "0.2-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "argon2" version))
+ (sha256
+ (base32
+ "0kqn06rpb39jlzizjlnc5c44mfic8llrshxn7ljgmyj35lbqwxqh"))))
+ (properties `((upstream-name . "argon2")))
+ (build-system r-build-system)
+ (home-page
+ "https://github.com/wrathematics/argon2")
+ (synopsis "Secure Password Hashing based on Argon2 Algorithm")
+ (description
+ "Utilities for secure password hashing via the argon2 algorithm.")
+ (license license:bsd-2)))
--
2.25.0
T
T
Todor Kondi? wrote on 17 Mar 2020 14:08
[PATCH 2/3] gnu: Add r-getpass
(name . 40101@debbugs.gnu.org)(address . 40101@debbugs.gnu.org)
Df8xdNkjXPHMdLaDg4Bh63tUTvaQXXpk0aWmZ-2NbImFwS8n_4sZNYAYmQLBJ_eN-nj3KYBBZL0yTGBOny8E10WE4Q506_BlyDja9ISd4pM=@protonmail.com
* gnu/packages/statistics.scm (r-getpass) : New variable.
---
gnu/packages/statistics.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 7e3b62c035..f161e6092e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5844,3 +5844,28 @@ various statistical analysis programs such as R, Julia, and JAGS.")
(description
"Utilities for secure password hashing via the argon2 algorithm.")
(license license:bsd-2)))
+
+(define-public r-getpass
+ (package
+ (name "r-getpass")
+ (version "0.2-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "getPass" version))
+ (sha256
+ (base32
+ "03ydafhh0sk3rcnpr3paajyji64x2ddp6p814p9mvbmyrblcgzcc"))))
+ (properties `((upstream-name . "getPass")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rstudioapi" ,r-rstudioapi)))
+ (home-page
+ "https://github.com/wrathematics/getPass")
+ (synopsis "Masked User Input")
+ (description
+ "This package provides a micro-package for reading \"passwords\", i.e.
+reading user input with masking, so that the input is not displayed as it is
+typed. Currently, RStudio, the command line (every OS), and any platform
+where tcltk is present are supported.")
+ (license license:bsd-2)))
--
2.25.0
T
T
Todor Kondi? wrote on 17 Mar 2020 14:09
[PATCH 3/3] gnu: Add r-remoter
(name . 40101@debbugs.gnu.org)(address . 40101@debbugs.gnu.org)
D2p5VbXq9MjhOxght1J__uQh141RU1w4Lw6tROuCiY7AAOf41MTl4Shnn-L0agTDvITUAxk4-2K370Cl5rwU16dq0DBipwPivf4tBgeL6pI=@protonmail.com
* gnu/packages/statistics.scm (r-remoter): New variable.
---
gnu/packages/statistics.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index f161e6092e..216703e899 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5869,3 +5869,30 @@ reading user input with masking, so that the input is not displayed as it is
typed. Currently, RStudio, the command line (every OS), and any platform
where tcltk is present are supported.")
(license license:bsd-2)))
+
+(define-public r-remoter
+ (package
+ (name "r-remoter")
+ (version "0.4-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "remoter" version))
+ (sha256
+ (base32
+ "1a7m63l8phv5jnazvdqdrqkaqjwqzaac5y4jm2jn0ypy4n8jvkfl"))))
+ (properties `((upstream-name . "remoter")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-argon2" ,r-argon2)
+ ("r-getpass" ,r-getpass)
+ ("r-pbdzmq" ,r-pbdzmq)
+ ("r-png" ,r-png)))
+ (home-page "https://github.com/RBigData/remoter")
+ (synopsis
+ "Control a Remote R Session from a Local One")
+ (description
+ "This package provides a set of utilities for client/server computing
+with R, controlling a remote R session (the server) from a local one (the
+client).")
+ (license license:bsd-2)))
--
2.25.0






??????? Original Message ???????
On Tuesday, 17 March 2020 13:56, <help-debbugs@gnu.org> wrote:

Toggle quote (22 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 40101@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
> 40101: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=40101
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
L
L
Leo Famulari wrote on 25 Mar 2020 20:48
Re: [bug#40101] [PATCH 0/3] gnu: Add r-remoter and its dependencies
(name . Todor Kondi?)(address . tk.code@protonmail.com)(address . 40101-done@debbugs.gnu.org)
20200325194809.GA13196@jasmine.lan
On Tue, Mar 17, 2020 at 12:54:56PM +0000, Todor Kondi? via Guix-patches via wrote:
Toggle quote (2 lines)
> Lets make life difficult by submitting git patches using a web interface.

Thanks! The only issue I noticed is that the email address used in the
patch was <guix-patches@gnu.org>.

I fixed that, moved the packages to 'gnu/packages/cran.scm' (they aren't
related to statistics AFAICT), added a copyright line for you, and
pushed as 0c549393b9b9194f47fbee2bdfa1caf8f4e32b12.
Closed
?