[PATCH] gnu: dune: Update to 2.4.0.

  • Done
  • quality assurance status badge
Details
5 participants
  • Julien Lepiller
  • Leo Famulari
  • Christopher Baines
  • Vincent Legoll
  • zimoun
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal
V
V
Vincent Legoll wrote on 16 Mar 2020 17:44
CAEwRq=p2sWWjSUTY=1jAat-pPbY-rEbGOK-mvtNqxg7s7E=uPw@mail.gmail.com
The added "release" make parameter, fixes the following bug:
make: ./dune.exe: Command not found

Tested with ocaml-menhir package update
(which will follow soon)

This may force a lot of other rebuildings, so
may not be suitable for master

--
Vincent Legoll
From 1cd0debdbf5acbbba634feb25b72d46c8d53ea98 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Mon, 16 Mar 2020 16:41:11 +0100
Subject: [PATCH] gnu: dune: Update to 2.4.0.

* gnu/packages/ocaml.scm (dune): Update to 2.4.0
[arguments]: Add "release" to make parameters to force rebuilding
"dune.exe"
---
gnu/packages/ocaml.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 35701039ad..ea4fb3edb1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1242,7 +1242,7 @@ full_split, cut, rcut, etc..")
(define-public dune
(package
(name "dune")
- (version "1.11.3")
+ (version "2.4.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1251,11 +1251,12 @@ full_split, cut, rcut, etc..")
(file-name (git-file-name name version))
(sha256
(base32
- "0l4x0x2fz135pljv88zj8y6w1ninsqw0gn1mdxzprd6wbxbyn8wr"))))
+ "0i8b84mi38r431z4a1yh4xnn9z5mnk1g3di0qz6h4lsxq8pg2m0v"))))
(build-system ocaml-build-system)
(arguments
`(#:tests? #f; require odoc
- #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ #:make-flags (list "release"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
(string-append "LIBDIR=" (assoc-ref %outputs "out")
"/lib/ocaml/site-lib"))
#:phases
--
2.25.1
J
J
Julien Lepiller wrote on 16 Mar 2020 20:46
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . guix-patches@gnu.org)
20200316204618.09d068df@tachikoma.lepiller.eu
Thanks for the patch! I tried using it, but even though dune builds
fine, this new version removed support for jbuild, which creates build
errors when building e.g. ocaml4.07-sexplib0.

Note that according to "guix refresh -l dune" there are only 137
dependents, so this change could go to master. However, we need to find
a solution to the above issue. The guix refresh command should give you
the list of packages that depend on dune. Make sure that those who
build now still build after your patch, or fix them. We could also
duplicate the dune package and uses the older dune for our packages
that still use jbuild. Alternatively, as suggested by dune, maybe we
can try to run "dune upgrade" in these packages.

What do you think would work best?

Le Mon, 16 Mar 2020 17:44:02 +0100,
Vincent Legoll <vincent.legoll@gmail.com> a écrit :

Toggle quote (11 lines)
> The added "release" make parameter, fixes the following bug:
> make: ./dune.exe: Command not found
>
> Tested with ocaml-menhir package update
> (which will follow soon)
>
> This may force a lot of other rebuildings, so
> may not be suitable for master
>
> --
> Vincent Legoll
V
V
Vincent Legoll wrote on 16 Mar 2020 21:45
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . guix-patches@gnu.org)
CAEwRq=rfiZNTzgqZHxx5_tKYxTp-DsnYw051BJbMKHSLCkUM4w@mail.gmail.com
Hello,

On Mon, Mar 16, 2020 at 8:46 PM Julien Lepiller <julien@lepiller.eu> wrote:
Toggle quote (4 lines)
> Thanks for the patch! I tried using it, but even though dune builds
> fine, this new version removed support for jbuild, which creates
> build errors when building e.g. ocaml4.07-sexplib0.

Ah, that explains the build problem I met in my attempt to package
coccinelle... It surprised me since I read in the dune doc that jbuild
should be supported by dune. Maybe that doc is outdated...

Toggle quote (3 lines)
> Note that according to "guix refresh -l dune" there are only 137
> dependents, so this change could go to master.

Yep, I saw that, but I also tried "guix refresh -lr" and that gave a
huge list. Maybe that's not relevant, I'm still low on the
guix / guile learning curve...

Toggle quote (2 lines)
> However, we need to find a solution to the above issue.

Yes

Toggle quote (5 lines)
> The guix refresh command should give you
> the list of packages that depend on dune.
> Make sure that those who
> build now still build after your patch, or fix them.

Yes

Toggle quote (4 lines)
> We could also
> duplicate the dune package and uses the older dune for our
> packages that still use jbuild.

This may be the path of least resistance, and would let us
handle problems without a flag day...

Toggle quote (5 lines)
> Alternatively, as suggested by dune, maybe we
> can try to run "dune upgrade" in these packages.
>
> What do you think would work best?

That is a question I cannot answer, I did not know about dune
before today ;-)

But I'll try to "dune upgrade" a few of them and we'll see where
this'll lead...

I was not expecting to fall in such a rabbit hole...
But this is fun, I'll keep at it.

--
Vincent Legoll
L
L
Leo Famulari wrote on 29 May 2020 19:11
(no subject)
(address . control@debbugs.gnu.org)
20200529171152.GA1454@jasmine.lan
block 40092 by 40091
Z
Z
zimoun wrote on 15 Oct 2020 19:03
Re: [bug#40091] [PATCH] gnu: dune: Update to 2.4.0.
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
86eelz1kxh.fsf@gmail.com
Dear Vincent,

On Mon, 16 Mar 2020 at 17:44, Vincent Legoll <vincent.legoll@gmail.com> wrote:

Toggle quote (9 lines)
> The added "release" make parameter, fixes the following bug:
> make: ./dune.exe: Command not found
>
> Tested with ocaml-menhir package update
> (which will follow soon)
>
> This may force a lot of other rebuildings, so
> may not be suitable for master

Thank you for your contribution. The recent commit 339177956a updates
dune to 2.7.1. Does it work for your use-case?

If yes, feel free to close this.


All the best,
simon
C
C
Christopher Baines wrote on 20 Nov 2020 22:39
(address . 40091-done@debbugs.gnu.org)
873613k8rc.fsf@cbaines.net
Closing, as dune has been updated past 2.4.0.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+4N6dfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcB4A/7B96ppUal7G+RpdwAT7ywtwiqjmnTrLjn
7dD7EwUFcFyx5LOiC1GXcPv7wMc41Kna7fKAtVSt/14LK+MSXx66QRFtGB7KpNvS
FtCp56EunRmxKMlEjQtpNOEtvMOZDQS5pJJDD5WfELZoD7Ul5I750sz6u1umQfhX
godbvR2vl54Sbf6S/TV+7xWzXx2GcgizoRzPE1sEJIq2AVXuaMuvg4t3lHi6RCgu
7AA7RTnV0URfV+/wUi/sGasSuKRI9Pk0edOeqBhaIJT21idkM2HvPS7E3py4mZZh
IScTqlVoB4L5Zs/MxQtFyMFs4Wvy/4IAmZA9GPxMYQHfRU5lVoY+M+T3KtSwMytY
IMADJxAeE7BI4gY8mk3qT+5Auux7hP4DeGL63nMSFUzi6gjQpLhpngtI1WBNdjcf
WaAw4XME4iCepkQmW8gztWH9A72Q8dVsg39FZ21N3cBCU1tKc6CpfVIIQS1tF63v
+fNFhf40hwSnFdfz4IvA8uGcvzoLpHFWjFsG3fT2Cg3GiU7sf4vthkwvxJ/ZJsEB
jyE5okrSxtDgba8hn0RIPQS3vK+rQW5LRTSnYKV5rFIElotTmyyqrWg8Nn4UGPx7
31lutrbStlhyJIYdmR2pQkhNpjyMuyqvjVXCI95j96KlD80IsYXXQG6/eOlce4/W
RMbmJSRaVSY=
=35mR
-----END PGP SIGNATURE-----

Closed
?